summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2014-01-08 15:00:42 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2014-01-08 15:00:42 +0000
commitd7ea358d2f3dc16d693ed57836c6ce5fdc1eb459 (patch)
tree115b6b8cd6b9121eacbd780f9444b7dbd4cb9bc6 /net-fs
parentcleanup; fixed compile with vdr-2.1.2, reported/tested by T.Eckert on vdrport... (diff)
downloadgentoo-2-d7ea358d2f3dc16d693ed57836c6ce5fdc1eb459.tar.gz
gentoo-2-d7ea358d2f3dc16d693ed57836c6ce5fdc1eb459.tar.bz2
gentoo-2-d7ea358d2f3dc16d693ed57836c6ce5fdc1eb459.zip
Update live ebuild now that upstream has merged out-of-source patch
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key F8DBDADE)
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/libnfs/ChangeLog5
-rw-r--r--net-fs/libnfs/libnfs-9999.ebuild45
2 files changed, 27 insertions, 23 deletions
diff --git a/net-fs/libnfs/ChangeLog b/net-fs/libnfs/ChangeLog
index de218bd88ebf..eb01f1be72c6 100644
--- a/net-fs/libnfs/ChangeLog
+++ b/net-fs/libnfs/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-fs/libnfs
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/libnfs/ChangeLog,v 1.7 2014/01/07 17:48:04 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/libnfs/ChangeLog,v 1.8 2014/01/08 15:00:42 maksbotan Exp $
+
+ 08 Jan 2014; Maxim Koltsov <maksbotan@gentoo.org> libnfs-9999.ebuild:
+ Update live ebuild now that upstream has merged out-of-source patch
*libnfs-1.8.0 (07 Jan 2014)
diff --git a/net-fs/libnfs/libnfs-9999.ebuild b/net-fs/libnfs/libnfs-9999.ebuild
index 008aa78d1943..bc3a04124d99 100644
--- a/net-fs/libnfs/libnfs-9999.ebuild
+++ b/net-fs/libnfs/libnfs-9999.ebuild
@@ -1,45 +1,46 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/libnfs/libnfs-9999.ebuild,v 1.3 2012/12/04 03:54:39 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/libnfs/libnfs-9999.ebuild,v 1.4 2014/01/08 15:00:42 maksbotan Exp $
-EAPI="4"
+EAPI="5"
+
+AUTOTOOLS_AUTORECONF="1"
inherit eutils
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://github.com/sahlberg/libnfs.git"
- inherit git-2 autotools
+ inherit git-2 autotools-utils
else
- SRC_URI="https://github.com/downloads/sahlberg/${PN}/${P}.tar.gz"
+ SRC_URI="https://github.com/sahlberg/${PN}/archive/${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
+ inherit autotools-utils
fi
-DESCRIPTION="client library for accessing NFS shares over a network"
+DESCRIPTION="Client library for accessing NFS shares over a network"
HOMEPAGE="https://github.com/sahlberg/libnfs"
LICENSE="LGPL-2.1 GPL-3"
SLOT="0"
-IUSE="static-libs"
+IUSE="examples static-libs"
RDEPEND=""
DEPEND="${RDEPEND}
virtual/pkgconfig"
-src_unpack() {
- default
- [[ ${PV} == "9999" ]] && git-2_src_unpack
-}
+S="${WORKDIR}/${PN}-${P}"
-src_prepare() {
- [[ ${PV} == "9999" ]] && eautoreconf
- epatch "${FILESDIR}"/${PN}-1.5.0-headers.patch
-}
-
-src_configure() {
- econf \
- $(use_enable static-libs static)
-}
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.5.0-headers.patch
+)
src_install() {
- default
- use static-libs || find "${ED}" -name '*.la' -delete
+ autotools-utils_src_install
+ if use examples; then
+ # --enable-examples configure switch just compiles them
+ # better install sources instead
+ exeinto /usr/share/doc/${PF}/examples/
+ for program in $(grep PROGRAMS examples/Makefile.am | cut -d= -f2); do
+ doexe examples/${program}.c
+ done
+ fi
}