summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2010-06-26 09:44:57 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2010-06-26 09:44:57 +0000
commitd36faf8103e69464735a93d70f48469090625f6e (patch)
tree09eca51d213ba3b66b524f958871ea8ed69ac0e7 /net-fs
parentNuke old 2.24 version because of bug 324953 -- permission received from BSD team (diff)
downloadgentoo-2-d36faf8103e69464735a93d70f48469090625f6e.tar.gz
gentoo-2-d36faf8103e69464735a93d70f48469090625f6e.tar.bz2
gentoo-2-d36faf8103e69464735a93d70f48469090625f6e.zip
New package: net-fs/smbnetfs. Bug #96328
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/smbnetfs/ChangeLog15
-rw-r--r--net-fs/smbnetfs/metadata.xml28
-rw-r--r--net-fs/smbnetfs/smbnetfs-0.5.2.ebuild34
3 files changed, 77 insertions, 0 deletions
diff --git a/net-fs/smbnetfs/ChangeLog b/net-fs/smbnetfs/ChangeLog
new file mode 100644
index 000000000000..ee1ebe57882a
--- /dev/null
+++ b/net-fs/smbnetfs/ChangeLog
@@ -0,0 +1,15 @@
+# ChangeLog for net-fs/smbnetfs
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/smbnetfs/ChangeLog,v 1.1 2010/06/26 09:44:57 slyfox Exp $
+
+*smbnetfs-0.5.2 (26 Jun 2010)
+
+ 26 Jun 2010; Sergei Trofimovich <slyfox@gentoo.org>
+ +smbnetfs-0.5.2.ebuild, +metadata.xml:
+ New ebuild. Thanks to Dmitri Vorobyev <vdmitri@fromru.com>, Dmitry S.
+ Kulyabov <yamadharma@gmail.com>, Daniel Lin <ephemient@gmail.com>, Arthur
+ Demchenkov <spinal.by@mail.ru> to resolve bug #96328. Special thanks to
+ Mikhail S. Pobolovets <styx.mp@gmail.com> for help to track down stability
+ issues on amd64. And thanks to Mikhail Kshevetskiy
+ <mikhail.kshevetskiy@gmail.com> for making such a great tool!
+
diff --git a/net-fs/smbnetfs/metadata.xml b/net-fs/smbnetfs/metadata.xml
new file mode 100644
index 000000000000..36c67f4091ff
--- /dev/null
+++ b/net-fs/smbnetfs/metadata.xml
@@ -0,0 +1,28 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>slyfox@gentoo.org</email>
+ <name>Sergei Trofimovich</name>
+ <description>Primary Maintainer</description>
+ </maintainer>
+ <longdescription>
+ SMBNetFS is a Linux/FreeBSD FUSE filesystem that allow you to use samba/microsoft network.
+
+ Features:
+ - Linux-2.6 and FreeBSD >= 6.0 are supported (Linux-2.4 is not tested)
+ - you can use Samba/Microsoft network as a regular unix filesystem
+ - workgroup/computer/share entries are dynamically created
+ - windows domain supported
+ - user defined workgroup/link/hosts are supported
+ - national character supported
+ - in config files you can specify different user/password to access different
+ network shares
+ - command "cd mountpoint/username:password@computer_or_ip" allows you to
+ access "computer_or_ip" as user "username" with password "password"
+ (this is insecure, but usefull)
+ - the program is multithreaded, so simultaneous access to a file/share
+ is possible
+ </longdescription>
+</pkgmetadata>
diff --git a/net-fs/smbnetfs/smbnetfs-0.5.2.ebuild b/net-fs/smbnetfs/smbnetfs-0.5.2.ebuild
new file mode 100644
index 000000000000..4d361fe7b3a2
--- /dev/null
+++ b/net-fs/smbnetfs/smbnetfs-0.5.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/smbnetfs/smbnetfs-0.5.2.ebuild,v 1.1 2010/06/26 09:44:57 slyfox Exp $
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="SMBNetFS is a Linux/FreeBSD FUSE filesystem that allow you to use samba/microsoft network."
+HOMEPAGE="http://sourceforge.net/projects/smbnetfs"
+SRC_URI="mirror://sourceforge/smbnetfs/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+RDEPEND=">=sys-fs/fuse-2.3
+ >=net-fs/samba-3.2[smbclient]"
+
+DEPEND="${RDEPEND}
+ sys-devel/make"
+
+src_install() {
+ emake install DESTDIR="${D}" || die "make install failed"
+ dodoc AUTHORS ChangeLog
+}
+
+pkg_postinst() {
+ elog
+ elog "For quick usage, exec:"
+ elog "'modprobe fuse'"
+ elog "'smbnetfs -oallow_other /mnt/samba'"
+ elog
+}