summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-09-13 18:00:29 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-09-13 18:00:29 +0000
commitca378c405b8c6a6cb77b86d0915a67f8204b8b1c (patch)
tree89cef523c74a438639bbe6d5c97bb6e557fc8c72 /net-fs
parentVersion bump (diff)
downloadgentoo-2-ca378c405b8c6a6cb77b86d0915a67f8204b8b1c.tar.gz
gentoo-2-ca378c405b8c6a6cb77b86d0915a67f8204b8b1c.tar.bz2
gentoo-2-ca378c405b8c6a6cb77b86d0915a67f8204b8b1c.zip
Version bump to latest.
(Portage version: 2.2.0_alpha125/cvs/Linux x86_64)
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/cifs-utils/ChangeLog7
-rw-r--r--net-fs/cifs-utils/cifs-utils-5.6.ebuild76
2 files changed, 82 insertions, 1 deletions
diff --git a/net-fs/cifs-utils/ChangeLog b/net-fs/cifs-utils/ChangeLog
index 7bb65efa9dc8..c1c6bb2b6c5d 100644
--- a/net-fs/cifs-utils/ChangeLog
+++ b/net-fs/cifs-utils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-fs/cifs-utils
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/cifs-utils/ChangeLog,v 1.31 2012/09/13 09:25:12 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/cifs-utils/ChangeLog,v 1.32 2012/09/13 18:00:29 scarabeus Exp $
+
+*cifs-utils-5.6 (13 Sep 2012)
+
+ 13 Sep 2012; Tomáš Chvátal <scarabeus@gentoo.org> +cifs-utils-5.6.ebuild:
+ Version bump to latest.
13 Sep 2012; Anthony G. Basile <blueness@gentoo.org>
cifs-utils-5.5-r1.ebuild:
diff --git a/net-fs/cifs-utils/cifs-utils-5.6.ebuild b/net-fs/cifs-utils/cifs-utils-5.6.ebuild
new file mode 100644
index 000000000000..b431e892b4b4
--- /dev/null
+++ b/net-fs/cifs-utils/cifs-utils-5.6.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/cifs-utils/cifs-utils-5.6.ebuild,v 1.1 2012/09/13 18:00:29 scarabeus Exp $
+
+EAPI=4
+
+inherit eutils confutils linux-info
+
+DESCRIPTION="Tools for Managing Linux CIFS Client Filesystems"
+HOMEPAGE="http://wiki.samba.org/index.php/LinuxCIFS_utils"
+SRC_URI="ftp://ftp.samba.org/pub/linux-cifs/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="ads +caps caps-ng creds upcall"
+
+DEPEND="!net-fs/mount-cifs
+ !<net-fs/samba-3.6_rc1
+ ads? ( sys-libs/talloc virtual/krb5 sys-apps/keyutils )
+ caps? ( sys-libs/libcap )
+ caps-ng? ( sys-libs/libcap-ng )
+ creds? ( sys-apps/keyutils )
+ upcall? ( sys-apps/keyutils sys-libs/talloc virtual/krb5 )"
+RDEPEND="${DEPEND}"
+
+REQUIRED_USE="^^ ( caps caps-ng )"
+
+DOCS="doc/linux-cifs-client-guide.odt"
+
+pkg_setup() {
+ confutils_use_conflict caps caps-ng
+ if ! linux_config_exists || ! linux_chkconfig_present CIFS; then
+ ewarn "You must enable CIFS support in your kernel config, "
+ ewarn "to be able to mount samba shares. You can find it at"
+ ewarn
+ ewarn " File systems"
+ ewarn " Network File Systems"
+ ewarn " CIFS support"
+ ewarn
+ ewarn "and recompile your kernel ..."
+ fi
+}
+
+src_prepare() {
+ # bug #424487
+ epatch "${FILESDIR}"/${P}-initialize_rc_var_properly.patch
+}
+
+src_configure() {
+ econf
+ $(use_enable ads cifsupcall) \
+ $(use_with caps libcap) \
+ $(use_with caps-ng libcap-ng) \
+ $(use_enable creds cifscreds) \
+ $(use_enable upcall cifsupcall) \
+ --with-libcap-ng=$(use caps-ng && echo 'yes' || echo 'no')
+ --disable-cifsidmap \
+ --disable-cifsacl
+}
+
+pkg_postinst() {
+ # Inform about set-user-ID bit of mount.cifs
+ ewarn "setuid use flag was dropped due to multiple security implications"
+ ewarn "such as CVE-2009-2948, CVE-2011-3585 and CVE-2012-1586"
+ ewarn "You are free to set setuid flags by yourself"
+
+ # Inform about upcall usage
+ if use ads ; then
+ ewarn "Using mount.cifs in combination with keyutils"
+ ewarn "in order to mount DFS shares, you need to add"
+ ewarn "the following line to /etc/request-key.conf:"
+ ewarn " create dns_resolver * * /usr/sbin/cifs.upcall %k"
+ ewarn "Otherwise, your DFS shares will not work properly."
+ fi
+}