summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-09-19 22:39:27 +0000
committerMike Frysinger <vapier@gentoo.org>2010-09-19 22:39:27 +0000
commitb9ea9242155c1e295940fe6ade7cc8625df23fb2 (patch)
tree13d99ca63da32e404cc560841492f5f33ddd950d /net-fs
parentold (diff)
downloadgentoo-2-b9ea9242155c1e295940fe6ade7cc8625df23fb2.tar.gz
gentoo-2-b9ea9242155c1e295940fe6ade7cc8625df23fb2.tar.bz2
gentoo-2-b9ea9242155c1e295940fe6ade7cc8625df23fb2.zip
Fix multilib dir handling with backed up /var/lib/nfs.
(Portage version: 2.2_rc83/cvs/Linux x86_64)
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/nfs-utils/ChangeLog5
-rw-r--r--net-fs/nfs-utils/nfs-utils-1.2.2-r2.ebuild16
2 files changed, 11 insertions, 10 deletions
diff --git a/net-fs/nfs-utils/ChangeLog b/net-fs/nfs-utils/ChangeLog
index b864c486bbea..7353a1829fa9 100644
--- a/net-fs/nfs-utils/ChangeLog
+++ b/net-fs/nfs-utils/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-fs/nfs-utils
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/ChangeLog,v 1.172 2010/08/07 21:13:01 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/ChangeLog,v 1.173 2010/09/19 22:39:27 vapier Exp $
+
+ 19 Sep 2010; Mike Frysinger <vapier@gentoo.org> nfs-utils-1.2.2-r2.ebuild:
+ Fix multilib dir handling with backed up /var/lib/nfs.
07 Aug 2010; Mike Frysinger <vapier@gentoo.org> files/nfs.initd:
Port logic over for detecting rpc.gssd needs in nfs init.d script #330795 by
diff --git a/net-fs/nfs-utils/nfs-utils-1.2.2-r2.ebuild b/net-fs/nfs-utils/nfs-utils-1.2.2-r2.ebuild
index fe7d5bdc238f..83272ff43265 100644
--- a/net-fs/nfs-utils/nfs-utils-1.2.2-r2.ebuild
+++ b/net-fs/nfs-utils/nfs-utils-1.2.2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/nfs-utils-1.2.2-r2.ebuild,v 1.1 2010/07/23 01:33:58 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/nfs-utils-1.2.2-r2.ebuild,v 1.2 2010/09/19 22:39:27 vapier Exp $
EAPI="2"
@@ -66,10 +66,9 @@ src_install() {
# Don't overwrite existing xtab/etab, install the original
# versions somewhere safe... more info in pkg_postinst
- dodir /usr/lib/nfs
- keepdir /var/lib/nfs/{sm,sm.bak}
- mv "${D}"/var/lib/nfs/* "${D}"/usr/lib/nfs
- keepdir /var/lib/nfs
+ dodir /usr/$(get_libdir)/nfs
+ mv "${D}"/var/lib/nfs "${D}"/usr/$(get_libdir)/ || die
+ keepdir /var/lib/nfs/{,sm,sm.bak}
# Install some client-side binaries in /sbin
dodir /sbin
@@ -101,10 +100,9 @@ src_install() {
}
pkg_postinst() {
- # Install default xtab and friends if there's none existing.
- # In src_install we put them in /usr/lib/nfs for safe-keeping, but
- # the daemons actually use the files in /var/lib/nfs. This fixes
- # bug 30486
+ # Install default xtab and friends if there's none existing. In
+ # src_install we put them in /usr/lib/nfs for safe-keeping, but
+ # the daemons actually use the files in /var/lib/nfs. #30486
local f
for f in "${ROOT}"/usr/$(get_libdir)/nfs/*; do
[[ -e ${ROOT}/var/lib/nfs/${f##*/} ]] && continue