summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorVictor Ostorga <vostorga@gentoo.org>2011-06-02 15:54:15 +0000
committerVictor Ostorga <vostorga@gentoo.org>2011-06-02 15:54:15 +0000
commitb14c79bf8d6c6642ccb576f4e837146c1c500ab8 (patch)
tree64be535fac0711230874cc79ee49c22f546a6b5e /net-fs
parentRemove unnessecary DEP on gnome-vfs, #369743 (diff)
downloadgentoo-2-b14c79bf8d6c6642ccb576f4e837146c1c500ab8.tar.gz
gentoo-2-b14c79bf8d6c6642ccb576f4e837146c1c500ab8.tar.bz2
gentoo-2-b14c79bf8d6c6642ccb576f4e837146c1c500ab8.zip
Version bump to 5.0
(Portage version: 2.1.9.42/cvs/Linux i686)
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/cifs-utils/ChangeLog7
-rw-r--r--net-fs/cifs-utils/cifs-utils-5.0.ebuild76
2 files changed, 82 insertions, 1 deletions
diff --git a/net-fs/cifs-utils/ChangeLog b/net-fs/cifs-utils/ChangeLog
index 2d958453ede1..c1d92974eabd 100644
--- a/net-fs/cifs-utils/ChangeLog
+++ b/net-fs/cifs-utils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-fs/cifs-utils
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/cifs-utils/ChangeLog,v 1.7 2011/05/09 18:12:23 vostorga Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/cifs-utils/ChangeLog,v 1.8 2011/06/02 15:54:15 vostorga Exp $
+
+*cifs-utils-5.0 (02 Jun 2011)
+
+ 02 Jun 2011; Víctor Ostorga <vostorga@gentoo.org> +cifs-utils-5.0.ebuild:
+ Version bump to 5.0
09 May 2011; Víctor Ostorga <vostorga@gentoo.org>
cifs-utils-4.8.1.ebuild:
diff --git a/net-fs/cifs-utils/cifs-utils-5.0.ebuild b/net-fs/cifs-utils/cifs-utils-5.0.ebuild
new file mode 100644
index 000000000000..d3a7ec2ff850
--- /dev/null
+++ b/net-fs/cifs-utils/cifs-utils-5.0.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/cifs-utils/cifs-utils-5.0.ebuild,v 1.1 2011/06/02 15:54:15 vostorga Exp $
+
+EAPI=2
+
+inherit eutils confutils linux-info
+
+DESCRIPTION="Tools for Managing Linux CIFS Client Filesystems"
+HOMEPAGE="http://www.samba.org/linux-cifs/cifs-utils/"
+SRC_URI="ftp://ftp.samba.org/pub/linux-cifs/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~x86"
+IUSE="ads +caps caps-ng creds setuid"
+
+DEPEND="!net-fs/mount-cifs
+ !<net-fs/samba-3.6
+ ads? ( sys-libs/talloc virtual/krb5 sys-apps/keyutils )
+ caps? ( sys-libs/libcap )
+ caps-ng? ( sys-libs/libcap-ng )
+ creds? ( sys-apps/keyutils )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ confutils_use_conflict caps caps-ng
+ if ! linux_config_exists || ! linux_chkconfig_present CIFS; then
+ ewarn "You must enable CIFS support in your kernel config, "
+ ewarn "to be able to mount samba shares. You can find it at"
+ ewarn
+ ewarn " File systems"
+ ewarn " Network File Systems"
+ ewarn " CIFS support"
+ ewarn
+ ewarn "and recompile your kernel ..."
+ fi
+}
+
+src_configure() {
+ local myconf=
+ use caps && myconf="${myconf} --with-libcap-ng=no"
+ use caps-ng && myconf="${myconf} --with-libcap-ng=yes"
+ econf \
+ $(use_enable ads cifsupcall) \
+ $(use_with caps libcap) \
+ $(use_enable creds cifscreds) \
+ ${myconf}
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ # Set set-user-ID bit of mount.cifs
+ if use setuid ; then
+ chmod u+s "${D}"/sbin/mount.cifs
+ fi
+ dodoc doc/linux-cifs-client-guide.odt
+}
+
+pkg_postinst() {
+ # Inform about set-user-ID bit of mount.cifs
+ if use setuid ; then
+ ewarn "Setting SETUID bit for mount.cifs."
+ ewarn "However, there may be severe security implications. Also see:"
+ ewarn "http://samba.org/samba/security/CVE-2009-2948.html"
+ fi
+
+ # Inform about upcall usage
+ if use ads ; then
+ ewarn "Using mount.cifs in combination with keyutils"
+ ewarn "in order to mount DFS shares, you need to add"
+ ewarn "the following line to /etc/request-key.conf:"
+ ewarn " create dns_resolver * * /usr/sbin/cifs.upcall %k"
+ ewarn "Otherwise, your DFS shares will not work properly."
+ fi
+}