summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorVictor Ostorga <vostorga@gentoo.org>2013-02-06 17:11:01 +0000
committerVictor Ostorga <vostorga@gentoo.org>2013-02-06 17:11:01 +0000
commit9e5a3c51421f5b76f6c1f850abd7b8befe973ed9 (patch)
treef7e3d89c25c1faa045eb4ddba99d71e0a25dd720 /net-fs
parentFix race condition in installing scripts, bug #455878. (diff)
downloadgentoo-2-9e5a3c51421f5b76f6c1f850abd7b8befe973ed9.tar.gz
gentoo-2-9e5a3c51421f5b76f6c1f850abd7b8befe973ed9.tar.bz2
gentoo-2-9e5a3c51421f5b76f6c1f850abd7b8befe973ed9.zip
Version bump
(Portage version: 2.1.11.31/cvs/Linux i686, signed Manifest commit with key 0xE25EE336)
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/samba/ChangeLog7
-rw-r--r--net-fs/samba/samba-4.0.3.ebuild155
2 files changed, 161 insertions, 1 deletions
diff --git a/net-fs/samba/ChangeLog b/net-fs/samba/ChangeLog
index 013c6fc87ab8..cf3b8a19f0b9 100644
--- a/net-fs/samba/ChangeLog
+++ b/net-fs/samba/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-fs/samba
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/ChangeLog,v 1.559 2013/02/04 22:37:50 vostorga Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/ChangeLog,v 1.560 2013/02/06 17:11:01 vostorga Exp $
+
+*samba-4.0.3 (06 Feb 2013)
+
+ 06 Feb 2013; Víctor Ostorga <vostorga@gentoo.org> +samba-4.0.3.ebuild:
+ Version bump
*samba-3.6.12 (04 Feb 2013)
diff --git a/net-fs/samba/samba-4.0.3.ebuild b/net-fs/samba/samba-4.0.3.ebuild
new file mode 100644
index 000000000000..2fbd22b6f997
--- /dev/null
+++ b/net-fs/samba/samba-4.0.3.ebuild
@@ -0,0 +1,155 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-4.0.3.ebuild,v 1.1 2013/02/06 17:11:01 vostorga Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+
+inherit python-r1 waf-utils multilib linux-info
+
+MY_PV="${PV/_rc/rc}"
+MY_P="${PN}-${MY_PV}"
+
+if [ "${PV}" = "4.9999" ]; then
+ EGIT_REPO_URI="git://git.samba.org/samba.git"
+ KEYWORDS=""
+ inherit git-2
+else
+ SRC_URI="mirror://samba/stable/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Samba Suite Version 4"
+HOMEPAGE="http://www.samba.org/"
+LICENSE="GPL-3"
+
+SLOT="0"
+
+IUSE="acl addns ads aio avahi client cluster cups gnutls iprint
+ldap pam quota selinux swat syslog test winbind"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-libs/iniparser
+ dev-libs/popt
+ sys-libs/readline
+ virtual/libiconv
+ dev-python/subunit
+ sys-libs/libcap
+ >=sys-libs/ldb-1.1.15
+ >=sys-libs/tdb-1.2.11[python]
+ >=sys-libs/talloc-2.0.8[python]
+ >=sys-libs/tevent-0.9.17
+ sys-libs/zlib
+ >=app-crypt/heimdal-1.5[-ssl]
+ addns? ( net-dns/bind-tools[gssapi] )
+ client? ( net-fs/cifs-utils[ads?] )
+ cluster? ( >=dev-db/ctdb-1.0.114_p1 )
+ ldap? ( net-nds/openldap )
+ gnutls? ( >=net-libs/gnutls-1.4.0 )
+ selinux? ( sec-policy/selinux-samba )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+REQUIRED_USE="ads? ( ldap )"
+
+RESTRICT="mirror"
+
+S="${WORKDIR}/${MY_P}"
+
+CONFDIR="${FILESDIR}/$(get_version_component_range 1-2)"
+
+WAF_BINARY="${S}/buildtools/bin/waf"
+
+pkg_setup() {
+ python_export_best
+ if use aio; then
+ if ! linux_config_exists || ! linux_chkconfig_present AIO; then
+ ewarn "You must enable AIO support in your kernel config, "
+ ewarn "to be able to support asynchronous I/O. "
+ ewarn "You can find it at"
+ ewarn
+ ewarn "General Support"
+ ewarn " Enable AIO support "
+ ewarn
+ ewarn "and recompile your kernel..."
+ fi
+ fi
+}
+
+src_configure() {
+ local myconf=''
+ use "cluster" && myconf+=" --with-ctdb-dir=/usr"
+ use "test" && myconf+=" --enable-selftest"
+ myconf="${myconf} \
+ --enable-fhs \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --with-modulesdir=/usr/$(get_libdir)/samba \
+ --disable-rpath \
+ --disable-rpath-install \
+ --nopyc \
+ --nopyo \
+ --disable-ntdb \
+ --bundled-libraries=NONE \
+ --builtin-libraries=NONE \
+ $(use_with addns dnsupdate) \
+ $(use_with acl) \
+ $(use_with ads) \
+ $(use_with aio aio-support) \
+ $(use_enable avahi) \
+ $(use_with cluster cluster-support) \
+ $(use_enable cups) \
+ $(use_enable gnutls) \
+ $(use_enable iprint) \
+ $(use_with ldap) \
+ $(use_with pam) \
+ $(use_with pam pam_smbpass) \
+ $(use_with quota) \
+ $(use_with syslog) \
+ $(use_with swat) \
+ $(use_with winbind)
+ "
+ CPPFLAGS="-I/usr/include/et ${CPPFLAGS}" \
+ waf-utils_src_configure ${myconf}
+}
+
+src_install() {
+ waf-utils_src_install
+
+ python_replicate_script \
+ "${D}/usr/sbin/samba_upgradeprovision" \
+ "${D}/usr/sbin/samba_dnsupdate" \
+ "${D}/usr/sbin/samba_spnupdate" \
+ "${D}/usr/sbin/samba_upgradedns" \
+ "${D}/usr/sbin/samba_kcc" \
+ "${D}/usr/bin/samba-tool"
+
+ # Make all .so files executable
+ find "${D}" -type f -name "*.so" -exec chmod +x {} +
+
+ # Move all LDB modules to their correct path
+ mkdir -p "${D}"/usr/$(get_libdir)/ldb/modules/ldb
+ mv "${D}"/usr/$(get_libdir)/ldb/*.so "${D}"/usr/$(get_libdir)/ldb/modules/ldb
+
+ # Install init script and conf.d file
+ newinitd "${CONFDIR}/samba4.initd-r1" samba
+ newconfd "${CONFDIR}/samba4.confd" samba
+}
+
+src_test() {
+ "${WAF_BINARY}" test || die "test failed"
+}
+
+pkg_postinst() {
+ elog "This is is the first stable release of Samba 4.0"
+
+ ewarn "Be aware the this release contains the best of all of Samba's"
+ ewarn "technology parts, both a file server (that you can reasonably expect"
+ ewarn "to upgrade existing Samba 3.x releases to) and the AD domain"
+ ewarn "controller work previously known as 'samba4'."
+
+ elog "For further information and migration steps make sure to read "
+ elog "http://samba.org/samba/history/${P}.html "
+ elog "http://samba.org/samba/history/${PN}-4.0.0.html and"
+ elog "http://wiki.samba.org/index.php/Samba4/HOWTO "
+}