summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-06-28 16:46:15 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-06-28 16:46:15 +0000
commit8a816266637dc3d3003d78cb180ba68541a5411f (patch)
tree311b0452c5c26963779a8ab6da58db4b737947f3 /net-fs
parentKeep libtool from using /bin/sh even if it is bash so people can change on th... (diff)
downloadgentoo-2-8a816266637dc3d3003d78cb180ba68541a5411f.tar.gz
gentoo-2-8a816266637dc3d3003d78cb180ba68541a5411f.tar.bz2
gentoo-2-8a816266637dc3d3003d78cb180ba68541a5411f.zip
Nailing makeopts down to -j1. Samba upstream doesn't care, there are spurious failures. Fixes #257861
(Portage version: 2.2_rc33/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/samba/ChangeLog12
-rw-r--r--net-fs/samba/samba-3.0.35.ebuild10
-rw-r--r--net-fs/samba/samba-3.2.13-r2.ebuild8
3 files changed, 20 insertions, 10 deletions
diff --git a/net-fs/samba/ChangeLog b/net-fs/samba/ChangeLog
index 3bf3d376c2fe..563d6d320653 100644
--- a/net-fs/samba/ChangeLog
+++ b/net-fs/samba/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for net-fs/samba
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/ChangeLog,v 1.362 2009/06/27 07:27:20 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/ChangeLog,v 1.363 2009/06/28 16:46:15 patrick Exp $
+
+ 28 Jun 2009; Patrick Lauer <patrick@gentoo.org> samba-3.0.35.ebuild,
+ samba-3.2.13-r2.ebuild:
+ Nailing makeopts down to -j1. Samba upstream doesn't care, there are
+ spurious failures. Fixes #257861
+
+ 28 Jun 2009; Patrick Lauer <patrick@gentoo.org> samba-3.0.35.ebuild,
+ samba-3.2.13-r1.ebuild:
+ Nailing makeopts down to -j1. Samba upstream doesn't care, there are
+ spurious failures. Fixes #257861
*samba-3.2.13-r2 (27 Jun 2009)
diff --git a/net-fs/samba/samba-3.0.35.ebuild b/net-fs/samba/samba-3.0.35.ebuild
index 5c99c3e27406..76dda6781f63 100644
--- a/net-fs/samba/samba-3.0.35.ebuild
+++ b/net-fs/samba/samba-3.0.35.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-3.0.35.ebuild,v 1.1 2009/06/25 18:18:09 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-3.0.35.ebuild,v 1.2 2009/06/28 16:46:15 patrick Exp $
inherit autotools eutils pam python multilib versionator confutils
@@ -132,11 +132,11 @@ src_compile() {
$(use_with winbind) \
${myconf} ${mylangs} ${mymod_shared}
- emake proto || die "emake proto failed"
- emake everything || die "emake everything failed"
+ emake -j1 proto || die "emake proto failed"
+ emake -j1 everything || die "emake everything failed"
if use python ; then
- emake python_ext || die "emake python_ext failed"
+ emake -j1 python_ext || die "emake python_ext failed"
fi
if use oav ; then
@@ -153,7 +153,7 @@ src_compile() {
--with-filetype \
--with-fileregexp \
$(use_enable debug)
- emake || die "emake oav plugins failed"
+ emake -j1 || die "emake oav plugins failed"
fi
}
diff --git a/net-fs/samba/samba-3.2.13-r2.ebuild b/net-fs/samba/samba-3.2.13-r2.ebuild
index 0d981ebb0093..e57f7b9d229d 100644
--- a/net-fs/samba/samba-3.2.13-r2.ebuild
+++ b/net-fs/samba/samba-3.2.13-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-3.2.13-r2.ebuild,v 1.1 2009/06/27 07:27:20 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-3.2.13-r2.ebuild,v 1.2 2009/06/28 16:46:15 patrick Exp $
inherit eutils pam multilib versionator confutils
@@ -128,8 +128,8 @@ src_compile() {
$(use_with winbind) \
${myconf} ${mylangs} ${mymod_shared} || die "econf failed"
- emake proto || die "emake proto failed"
- emake everything || die "emake everything failed"
+ emake -j1 proto || die "emake proto failed"
+ emake -j1 everything || die "emake everything failed"
}
@@ -141,7 +141,7 @@ src_test() {
src_install() {
cd "${S}/source"
- emake DESTDIR="${D}" install-everything || die "emake install-everything failed"
+ emake -j1 DESTDIR="${D}" install-everything || die "emake install-everything failed"
# Extra rpctorture progs
local extra_bins="rpctorture"