summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorVictor Ostorga <vostorga@gentoo.org>2011-03-02 20:13:50 +0000
committerVictor Ostorga <vostorga@gentoo.org>2011-03-02 20:13:50 +0000
commit8804c59ed0312743d5b1d5d91eb445fa33b1eb56 (patch)
treebb999327ebe7d6cfc80a19a2c8add991d29d7dc5 /net-fs
parentCorrect Slots for gtk 3 introduction to tree (diff)
downloadgentoo-2-8804c59ed0312743d5b1d5d91eb445fa33b1eb56.tar.gz
gentoo-2-8804c59ed0312743d5b1d5d91eb445fa33b1eb56.tar.bz2
gentoo-2-8804c59ed0312743d5b1d5d91eb445fa33b1eb56.zip
Bump fixing bug 356917 CVE-2011-0719 . Dropping vulnerable release. Fixing installation of examples
(Portage version: 2.1.9.25/cvs/Linux i686)
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/samba/ChangeLog9
-rw-r--r--net-fs/samba/samba-3.4.12.ebuild (renamed from net-fs/samba/samba-3.5.6.ebuild)125
2 files changed, 56 insertions, 78 deletions
diff --git a/net-fs/samba/ChangeLog b/net-fs/samba/ChangeLog
index 93b8d369345b..e1a3eb5b8ce0 100644
--- a/net-fs/samba/ChangeLog
+++ b/net-fs/samba/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-fs/samba
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/ChangeLog,v 1.458 2011/03/02 10:56:59 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/ChangeLog,v 1.459 2011/03/02 20:13:50 vostorga Exp $
+
+*samba-3.4.12 (02 Mar 2011)
+
+ 02 Mar 2011; Víctor Ostorga <vostorga@gentoo.org> +samba-3.4.12.ebuild,
+ -samba-3.5.6.ebuild:
+ Bump fixing bug 356917 CVE-2011-0719 . Dropping vulnerable release. Fixing
+ installation of examples
*samba-3.5.7 (02 Mar 2011)
diff --git a/net-fs/samba/samba-3.5.6.ebuild b/net-fs/samba/samba-3.4.12.ebuild
index edbb4cb12128..0ea9fab32c0b 100644
--- a/net-fs/samba/samba-3.5.6.ebuild
+++ b/net-fs/samba/samba-3.4.12.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-3.5.6.ebuild,v 1.5 2011/01/28 15:23:12 vostorga Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-3.4.12.ebuild,v 1.1 2011/03/02 20:13:50 vostorga Exp $
EAPI="2"
-inherit pam confutils versionator multilib eutils
+inherit pam confutils versionator multilib
MY_PV=${PV/_/}
MY_P="${PN}-${MY_PV}"
@@ -14,7 +14,7 @@ HOMEPAGE="http://www.samba.org/"
SRC_URI="mirror://samba/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
IUSE="acl addns ads aio avahi caps +client cluster cups debug doc examples fam
ldap ldb +netapi pam quota +readline +server +smbclient smbsharemodes swat
syslog winbind "
@@ -33,7 +33,7 @@ DEPEND="dev-libs/popt
caps? ( sys-libs/libcap )
client? ( !net-fs/mount-cifs
dev-libs/iniparser )
- cluster? ( >=dev-db/ctdb-1.0.114_p1 )
+ cluster? ( dev-db/ctdb )
cups? ( net-print/cups )
debug? ( dev-libs/dmalloc )
fam? ( virtual/fam )
@@ -50,9 +50,34 @@ RESTRICT="test"
SBINPROGS=""
BINPROGS=""
-KRBPLUGIN=""
-PLUGINEXT=".so"
-SHAREDMODS=""
+
+if use server ; then
+ SBINPROGS="${SBINPROGS} bin/smbd bin/nmbd"
+ BINPROGS="${BINPROGS} bin/testparm bin/smbstatus bin/smbcontrol bin/pdbedit
+ bin/profiles bin/sharesec bin/eventlogadm"
+
+ use swat && SBINPROGS="${SBINPROGS} bin/swat"
+ use winbind && SBINPROGS="${SBINPROGS} bin/winbindd"
+ use ads && use winbind && SBIN_PROGS="${SBINPROGS} bin/winbind_krb5_locator"
+fi
+
+if use client ; then
+ BINPROGS="${BINPROGS} bin/smbclient bin/net bin/smbget bin/smbtree
+ bin/nmblookup bin/smbpasswd bin/rpcclient bin/smbcacls bin/smbcquotas
+ bin/ntlm_auth"
+
+ use ads && SBINPROGS="${SBINPROGS} bin/cifs.upcall"
+fi
+
+use cups && BINPROGS="${BINPROGS} bin/smbspool"
+use ldb && BINPROGS="${BINPROGS} bin/ldbedit bin/ldbsearch bin/ldbadd bin/ldbdel bin/ldbmodify bin/ldbrename";
+
+if use winbind ; then
+ BINPROGS="${BINPROGS} bin/wbinfo"
+ mymod_shared="--with-shared-modules=idmap_rid,idmap_hash"
+ use ldap && mymod_shared="${mymod_shared},idmap_adex,idmap_ldap"
+ use ads && mymod_shared="${mymod_shared},idmap_ad"
+fi
S="${WORKDIR}/${MY_P}/source3"
@@ -64,34 +89,6 @@ S="${WORKDIR}/${MY_P}/source3"
CONFDIR="${FILESDIR}/$(get_version_component_range 1-2)"
pkg_setup() {
- if use server ; then
- SBINPROGS="${SBINPROGS} bin/smbd bin/nmbd"
- BINPROGS="${BINPROGS} bin/testparm bin/smbstatus bin/smbcontrol bin/pdbedit
- bin/profiles bin/sharesec bin/eventlogadm"
-
- use swat && SBINPROGS="${SBINPROGS} bin/swat"
- use winbind && SBINPROGS="${SBINPROGS} bin/winbindd"
- use ads && use winbind && KRBPLUGIN="${KRBPLUGIN} bin/winbind_krb5_locator"
- fi
-
- if use client ; then
- BINPROGS="${BINPROGS} bin/smbclient bin/net bin/smbget bin/smbtree
- bin/nmblookup bin/smbpasswd bin/rpcclient bin/smbcacls bin/smbcquotas
- bin/ntlm_auth"
-
- use ads && SBINPROGS="${SBINPROGS} bin/cifs.upcall"
- fi
-
- use cups && BINPROGS="${BINPROGS} bin/smbspool"
- use ldb && BINPROGS="${BINPROGS} bin/ldbedit bin/ldbsearch bin/ldbadd bin/ldbdel bin/ldbmodify bin/ldbrename";
-
- if use winbind ; then
- BINPROGS="${BINPROGS} bin/wbinfo"
- SHAREDMODS="${SHAREDMODS}idmap_rid,idmap_hash"
- use ads && SHAREDMODS="${SHAREDMODS},idmap_ad"
- use ldap && SHAREDMODS="${SHAREDMODS},idmap_ldap,idmap_adex"
- fi
-
if use winbind &&
[[ $(tc-getCC)$ == *gcc* ]] &&
[[ $(gcc-major-version)$(gcc-minor-version) -lt 43 ]]
@@ -104,6 +101,7 @@ pkg_setup() {
confutils_use_depend_all ads ldap
confutils_use_depend_all swat server
+ confutils_use_depend_all client netapi
}
src_prepare() {
@@ -114,7 +112,7 @@ src_prepare() {
-e 's|LDSHFLAGS="|LDSHFLAGS="\\${LDFLAGS} |g' \
configure || die "sed failed"
- epatch "${CONFDIR}"/${P}-kerberos-dummy.patch
+ epatch "${CONFDIR}"/${PN}-3.4.9-kerberos-dummy.patch
}
src_configure() {
@@ -170,7 +168,6 @@ src_configure() {
$(use_with ads dnsupdate) \
--without-automount \
$(use_with client cifsmount) \
- $(use_with client cifsumount) \
$(use_with pam) \
$(use_with pam pam_smbpass) \
$(use_with syslog) \
@@ -188,7 +185,7 @@ src_configure() {
$(use_with aio aio-support) \
--with-sendfile-support \
$(use_with winbind) \
- --with-shared-modules=${SHAREDMODS} \
+ ${mymod_shared} \
--without-included-popt \
--without-included-iniparser
}
@@ -237,11 +234,6 @@ src_compile() {
emake ${SBINPROGS} || die "emake sbinprogs failed";
fi
- if [ -n "${KRBPLUGIN}" ] ; then
- einfo "make krbplugin"
- emake ${KRBPLUGIN}${PLUGINEXT} || die "emake krbplugin failed";
- fi
-
if use client ; then
einfo "make {,u}mount.cifs"
emake bin/{,u}mount.cifs || die "emake {,u}mount.cifs failed"
@@ -315,23 +307,6 @@ src_install() {
doman ../docs/manpages/${prog/bin\/}* || die "doman failed"
done
- # install krbplugin
- if [ -n "${KRBPLUGIN}" ] ; then
- if has_version app-crypt/mit-krb5 ; then
- insinto /usr/$(get_libdir)/krb5/plugins/libkrb5
- doins ${KRBPLUGIN}${PLUGINEXT} || die "installing
- ${KRBPLUGIN}${PLUGINEXT} failed"
- elif has_version app-crypt/heimdal ; then
- insinto /usr/$(get_libdir)/plugin/krb5
- doins ${KRBPLUGIN}${PLUGINEXT} || die "installing
- ${KRBPLUGIN}${PLUGINEXT} failed"
- fi
- insinto /usr
- for prog in ${KRBPLUGIN} ; do
- doman ../docs/manpages/${prog/bin\/}* || die "doman failed"
- done
- fi
-
# install server components
if use server ; then
doman ../docs/manpages/vfs* ../docs/manpages/samba.7
@@ -377,9 +352,7 @@ src_install() {
fi
# install the spooler to cups
- if use cups ; then
- dosym /usr/bin/smbspool $(cups-config --serverbin)/backend/smb
- fi
+ use cups && dosym /usr/bin/smbspool $(cups-config --serverbin)/backend/smb
# install misc files
insinto /etc/samba
@@ -397,6 +370,7 @@ src_install() {
# install examples
if use examples ; then
+ einfo "install examples"
insinto /usr/share/doc/${PF}/examples
if use smbclient ; then
@@ -408,10 +382,10 @@ src_install() {
fi
if use server ; then
- cd ../examples
- doins -r auth autofs dce-dfs LDAP logon misc pdb \
- perfcounter printer-accounting printing scripts tridge \
- validchars VFS
+ doins -r \
+ ../examples/{auth,autofs,dce-dfs,LDAP,logon,misc} \
+ ../examples/{pdb,perfcounter,printer-accounting} \
+ ../examples/{printing,scripts,tridge,validchars,VFS}
fi
fi
@@ -425,16 +399,13 @@ src_install() {
}
pkg_postinst() {
- elog "The default value of 'wide links' has been changed to 'no' in samba 3.5"
- elog "to avoid an insecure default configuration"
- elog "('wide links = yes' and 'unix extensions = yes'). For more details,"
- elog "please see http://www.samba.org/samba/news/symlink_attack.html ."
- elog ""
- elog "An EXPERIMENTAL implementation of the SMB2 protocol has been added."
- elog "SMB2 can be enabled by setting 'max protocol = smb2'. SMB2 is a new "
- elog "implementation of the SMB protocol used by Windows Vista and higher"
- elog ""
+ elog "The default passdb backend has been changed to 'tdbsam' in samba 3.4!"
+ elog "That breaks existing setups using the 'smbpasswd' backend without"
+ elog "explicit declaration!"
+ elog "Please use 'passdb backend = smbpasswd' if you would like to stick to the"
+ elog "'smbpasswd' backend or convert your smbpasswd entries using e.g. "
+ elog "'pdbedit -i smbpasswd -e tdbsam'."
elog "For further information make sure to read the release notes at"
elog "http://samba.org/samba/history/${P}.html and "
- elog "http://samba.org/samba/history/${PN}-3.5.0.html"
+ elog "http://samba.org/samba/history/${PN}-3.4.0.html"
}