summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-08-08 14:23:25 +0000
committerMike Frysinger <vapier@gentoo.org>2014-08-08 14:23:25 +0000
commit7ab93d25091c2683c9eee77f0a5a6e645463ec5b (patch)
treec6124910c3e1e9df4e3c3efb6078e52f75855845 /net-fs
parentStable for HPPA (bug #518616). (diff)
downloadgentoo-2-7ab93d25091c2683c9eee77f0a5a6e645463ec5b.tar.gz
gentoo-2-7ab93d25091c2683c9eee77f0a5a6e645463ec5b.tar.bz2
gentoo-2-7ab93d25091c2683c9eee77f0a5a6e645463ec5b.zip
Version bump #519226 by Mirko Guenther.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/libnfs/ChangeLog10
-rw-r--r--net-fs/libnfs/files/libnfs-1.9.5-headers.patch86
-rw-r--r--net-fs/libnfs/files/libnfs-1.9.5-implicit-internal.patch27
-rw-r--r--net-fs/libnfs/libnfs-1.9.5.ebuild47
-rw-r--r--net-fs/libnfs/libnfs-9999.ebuild6
5 files changed, 170 insertions, 6 deletions
diff --git a/net-fs/libnfs/ChangeLog b/net-fs/libnfs/ChangeLog
index 0564cbaf198b..5ffefb1d5806 100644
--- a/net-fs/libnfs/ChangeLog
+++ b/net-fs/libnfs/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-fs/libnfs
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/libnfs/ChangeLog,v 1.11 2014/06/07 19:16:07 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/libnfs/ChangeLog,v 1.12 2014/08/08 14:23:24 vapier Exp $
+
+*libnfs-1.9.5 (08 Aug 2014)
+
+ 08 Aug 2014; Mike Frysinger <vapier@gentoo.org>
+ +files/libnfs-1.9.5-headers.patch,
+ +files/libnfs-1.9.5-implicit-internal.patch, +libnfs-1.9.5.ebuild,
+ libnfs-9999.ebuild:
+ Version bump #519226 by Mirko Guenther.
07 Jun 2014; Agostino Sarubbo <ago@gentoo.org> libnfs-1.8.0.ebuild:
Stable for x86, wrt bug #502876
diff --git a/net-fs/libnfs/files/libnfs-1.9.5-headers.patch b/net-fs/libnfs/files/libnfs-1.9.5-headers.patch
new file mode 100644
index 000000000000..96719ffd54c2
--- /dev/null
+++ b/net-fs/libnfs/files/libnfs-1.9.5-headers.patch
@@ -0,0 +1,86 @@
+From 0bfc3e09b7d7ca2b75d42c17874b89333b96f371 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Mon, 3 Dec 2012 22:30:04 -0500
+Subject: [PATCH] fix implicit decl warnings
+
+Include the proper headers to fix warnings like:
+libnfs-sync.c:1529:3: warning: implicit declaration of function 'gettimeofday' [-Wimplicit-function-declaration]
+libnfs-zdr.c:506:2: warning: implicit declaration of function 'getuid' [-Wimplicit-function-declaration]
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ lib/libnfs-sync.c | 1 +
+ lib/libnfs-zdr.c | 9 +++++++++
+ lib/libnfs.c | 1 +
+ lib/socket.c | 1 +
+ 4 files changed, 12 insertions(+)
+
+diff --git a/lib/libnfs-sync.c b/lib/libnfs-sync.c
+index 0fc1094..c140258 100644
+--- a/lib/libnfs-sync.c
++++ b/lib/libnfs-sync.c
+@@ -77,6 +77,7 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <assert.h>
++#include <sys/time.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <fcntl.h>
+diff --git a/lib/libnfs-zdr.c b/lib/libnfs-zdr.c
+index c32f661..b6b3ed9 100644
+--- a/lib/libnfs-zdr.c
++++ b/lib/libnfs-zdr.c
+@@ -20,6 +20,10 @@
+ * i.e. zdrmem_create() buffers.
+ * It aims to be compatible with normal rpcgen generated functions.
+ */
++#ifdef HAVE_CONFIG_H
++#include "config.h"
++#endif
++
+ #ifdef WIN32
+ #include "win32_compat.h"
+ #endif
+@@ -28,9 +32,14 @@
+ #include "aros_compat.h"
+ #endif
+
++#ifdef HAVE_ARPA_INET_H
++#include <arpa/inet.h>
++#endif
++
+ #include <stdlib.h>
+ #include <string.h>
+ #include <time.h>
++#include <unistd.h>
+ #include "libnfs-zdr.h"
+
+ struct opaque_auth _null_auth;
+diff --git a/lib/libnfs.c b/lib/libnfs.c
+index 5692dc3..0a7d139 100644
+--- a/lib/libnfs.c
++++ b/lib/libnfs.c
+@@ -73,6 +73,7 @@
+ #include <string.h>
+ #include <assert.h>
+ #include <errno.h>
++#include <time.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <fcntl.h>
+diff --git a/lib/socket.c b/lib/socket.c
+index 3f7f89f..f8db957 100644
+--- a/lib/socket.c
++++ b/lib/socket.c
+@@ -68,6 +68,7 @@
+ #include <fcntl.h>
+ #include <string.h>
+ #include <errno.h>
++#include <time.h>
+ #include <sys/types.h>
+ #include "libnfs-zdr.h"
+ #include "libnfs.h"
+--
+2.0.0
+
diff --git a/net-fs/libnfs/files/libnfs-1.9.5-implicit-internal.patch b/net-fs/libnfs/files/libnfs-1.9.5-implicit-internal.patch
new file mode 100644
index 000000000000..e702c81f5cb4
--- /dev/null
+++ b/net-fs/libnfs/files/libnfs-1.9.5-implicit-internal.patch
@@ -0,0 +1,27 @@
+From 2be32c3c41207c029f54ebd0f4aa08e216bd3c21 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Fri, 8 Aug 2014 05:45:32 -0400
+Subject: [PATCH 3/3] fix implicit decls of rpc_{g,s}et_error
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ lib/libnfs-zdr.c | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/lib/libnfs-zdr.c b/lib/libnfs-zdr.c
+index b6b3ed9..90abe26 100644
+--- a/lib/libnfs-zdr.c
++++ b/lib/libnfs-zdr.c
+@@ -41,6 +41,9 @@
+ #include <time.h>
+ #include <unistd.h>
+ #include "libnfs-zdr.h"
++#include "libnfs.h"
++#include "libnfs-raw.h"
++#include "libnfs-private.h"
+
+ struct opaque_auth _null_auth;
+
+--
+2.0.0
+
diff --git a/net-fs/libnfs/libnfs-1.9.5.ebuild b/net-fs/libnfs/libnfs-1.9.5.ebuild
new file mode 100644
index 000000000000..5cb0829aa897
--- /dev/null
+++ b/net-fs/libnfs/libnfs-1.9.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/libnfs/libnfs-1.9.5.ebuild,v 1.1 2014/08/08 14:23:24 vapier Exp $
+
+EAPI="5"
+
+AUTOTOOLS_AUTORECONF="1"
+
+inherit eutils
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://github.com/sahlberg/libnfs.git"
+ inherit git-2 autotools-utils
+else
+ SRC_URI="https://github.com/sahlberg/${PN}/archive/${P}.tar.gz"
+ KEYWORDS="~arm ~amd64 ~x86"
+ inherit autotools-utils
+fi
+
+DESCRIPTION="Client library for accessing NFS shares over a network"
+HOMEPAGE="https://github.com/sahlberg/libnfs"
+
+LICENSE="LGPL-2.1 GPL-3"
+SLOT="0"
+IUSE="examples static-libs"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${PN}-${P}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.9.5-headers.patch
+ "${FILESDIR}"/${PN}-1.9.5-implicit-internal.patch
+)
+
+src_install() {
+ autotools-utils_src_install
+ if use examples; then
+ # --enable-examples configure switch just compiles them
+ # better install sources instead
+ exeinto /usr/share/doc/${PF}/examples/
+ for program in $(grep PROGRAMS examples/Makefile.am | cut -d= -f2); do
+ doexe examples/${program}.c
+ done
+ fi
+}
diff --git a/net-fs/libnfs/libnfs-9999.ebuild b/net-fs/libnfs/libnfs-9999.ebuild
index e89961a38582..303dbb3f9af8 100644
--- a/net-fs/libnfs/libnfs-9999.ebuild
+++ b/net-fs/libnfs/libnfs-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/libnfs/libnfs-9999.ebuild,v 1.5 2014/05/16 03:35:16 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/libnfs/libnfs-9999.ebuild,v 1.6 2014/08/08 14:23:24 vapier Exp $
EAPI="5"
@@ -29,10 +29,6 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${PN}-${P}"
-PATCHES=(
- "${FILESDIR}"/${PN}-1.5.0-headers.patch
-)
-
src_install() {
autotools-utils_src_install
if use examples; then