summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorDylan Carlson <absinthe@gentoo.org>2003-06-06 16:41:34 +0000
committerDylan Carlson <absinthe@gentoo.org>2003-06-06 16:41:34 +0000
commit57f2d90c58493aed3442a5c0ffb69449318e9d6b (patch)
tree1eab09fc28d6caff370dd6d0177a991c5281da15 /net-fs
parentTightened security on mount binaries. (diff)
downloadgentoo-2-57f2d90c58493aed3442a5c0ffb69449318e9d6b.tar.gz
gentoo-2-57f2d90c58493aed3442a5c0ffb69449318e9d6b.tar.bz2
gentoo-2-57f2d90c58493aed3442a5c0ffb69449318e9d6b.zip
Tightened security on mount binaries.
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/shfs/ChangeLog8
-rw-r--r--net-fs/shfs/Manifest2
-rw-r--r--net-fs/shfs/files/digest-shfs-0.31-r11
-rw-r--r--net-fs/shfs/shfs-0.31-r1.ebuild82
4 files changed, 91 insertions, 2 deletions
diff --git a/net-fs/shfs/ChangeLog b/net-fs/shfs/ChangeLog
index caf97a5897f6..258b49169a8a 100644
--- a/net-fs/shfs/ChangeLog
+++ b/net-fs/shfs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-fs/shfs
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/shfs/ChangeLog,v 1.1 2003/06/03 07:38:29 absinthe Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/shfs/ChangeLog,v 1.2 2003/06/06 16:41:30 absinthe Exp $
+
+*shfs-0.31-r1 (06 Jun 2003)
+
+ 06 Jun 2003; Dylan Carlson <absinthe@gentoo.org> shfs-0.31-r1.ebuild:
+ More secure permissions on the mount binaries, and some helpful notes after
+ package install.
*shfs-0.31 (03 Jun 2003)
diff --git a/net-fs/shfs/Manifest b/net-fs/shfs/Manifest
index 671af7933c89..945cebcd5573 100644
--- a/net-fs/shfs/Manifest
+++ b/net-fs/shfs/Manifest
@@ -1,6 +1,6 @@
MD5 7bbbaeef212f17eeb8de0d47ee8576c6 shfs-0.31.ebuild 1658
MD5 93ea2de6d6764dda3aaeef17ba6e6201 shfs-0.31-r1.ebuild 2447
-MD5 aff5e0c9a07b8b5a929ac26f4dc28cdc ChangeLog 1055
+MD5 6ea07284fdc998cb2c075aee453bce42 ChangeLog 1055
MD5 6c1fade43f037362288f5f508ba5fe47 files/digest-shfs-0.31-r1 62
MD5 a47ecfb8f1ab11f208660d0b45c1a3d7 files/shfs-gentoo-0.31-makefile-root.diff 612
MD5 d9c3f912bc5642882b84fa7f3edd8db8 files/amd.conf 842
diff --git a/net-fs/shfs/files/digest-shfs-0.31-r1 b/net-fs/shfs/files/digest-shfs-0.31-r1
new file mode 100644
index 000000000000..c69b1f0e222b
--- /dev/null
+++ b/net-fs/shfs/files/digest-shfs-0.31-r1
@@ -0,0 +1 @@
+MD5 61d7ed5faaf5d98381fd18b103f58359 shfs-0.31-1.tar.gz 71010
diff --git a/net-fs/shfs/shfs-0.31-r1.ebuild b/net-fs/shfs/shfs-0.31-r1.ebuild
new file mode 100644
index 000000000000..abb5d28c47d1
--- /dev/null
+++ b/net-fs/shfs/shfs-0.31-r1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+
+IUSE="amd doc"
+
+MY_P=${P}-1
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Secure Shell File System"
+HOMEPAGE="http://shfs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc"
+DEPEND="virtual/linux-sources
+ net-misc/openssh
+ amd? ( net-fs/am-utils )"
+
+src_compile() {
+ epatch ${FILESDIR}/shfs-gentoo-${PV}-makefile-root.diff
+ use ppc && epatch ${FILESDIR}/shfs-gentoo-${PV}-ppc.diff
+ emake || die
+}
+
+src_install() {
+ # Install kernel module
+ cd ${S}/shfs
+ mv Makefile Makefile.old
+ cat Makefile.old | grep -v depmod > Makefile
+ einfo " Installing kernel module..."
+ make MODULESDIR=${D}/lib/modules/${KV} install || die
+
+ # Install binaries
+ cd ${S}/shfsmount
+ dobin shfsmount
+ dobin shfsumount
+
+ # Allows users to mount/umount
+ einfo " Setting suid bit on /usr/bin executables..."
+ fperms 4511 /usr/bin/shfsmount
+ fperms 4511 /usr/bin/shfsumount
+
+ # Performs symlink to support use of mount(8)
+ dodir /sbin
+ einfo " Adding /sbin/mount.shfs symlink..."
+ dosym /usr/bin/shfsmount /sbin/mount.shfs
+
+ # Install docs
+ doman ${S}/docs/manpages/shfsmount.8 ${S}/docs/manpages/shfsumount.8
+ use doc && dohtml -r ${S}/docs/html
+
+ # Install automount support (if desired)
+ if [ -n "`use amd`" ] ; then
+ einfo " Installing am-utils config files..."
+ insinto /etc/amd
+ doins ${FILESDIR}/amd.conf
+ doins ${FILESDIR}/amd.shfs
+ exeinto /etc/amd
+ doexe ${FILESDIR}/shfs.mount
+ dosym /etc/amd/shfs.mount /etc/amd/shfs.unmount
+ fi
+}
+
+pkg_postinst() {
+ echo "running depmod...."
+ depmod -aq || die
+
+ echo " "
+ einfo " Use either 'shfsmount' or 'mount -t shfs' to mount remote"
+ einfo " filesystems to into your local filesystem. "
+ echo " "
+ echo " "
+ einfo " Note the following: "
+ einfo " "
+ einfo " 1. The shfs.o kernel module has to be loaded first "
+ einfo " before you can start mounting filesystems. "
+ einfo " Try: 'insmod shfs' as root. "
+ einfo " "
+ einfo " 2. When mounting, you must enter the absolute path of "
+ einfo " the remote filesystem without any special chars, "
+ einfo " such as tilde (~), for example. "
+ echo " "
+}