summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-07-16 16:15:45 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-07-16 16:15:45 +0000
commit34d97fce24f6d442036601dd52dfc9c8385518c6 (patch)
tree80cbadac4fd6e3829091e32ba7c8e08d1e77752b /net-fs
parentVersion bumpecd. (diff)
downloadgentoo-2-34d97fce24f6d442036601dd52dfc9c8385518c6.tar.gz
gentoo-2-34d97fce24f6d442036601dd52dfc9c8385518c6.tar.bz2
gentoo-2-34d97fce24f6d442036601dd52dfc9c8385518c6.zip
Version bumpecd.
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/nfs-utils/ChangeLog7
-rw-r--r--net-fs/nfs-utils/Manifest4
-rw-r--r--net-fs/nfs-utils/files/digest-nfs-utils-1.0.41
-rw-r--r--net-fs/nfs-utils/nfs-utils-1.0.4.ebuild66
4 files changed, 75 insertions, 3 deletions
diff --git a/net-fs/nfs-utils/ChangeLog b/net-fs/nfs-utils/ChangeLog
index 42effb51c18f..4e522eeda668 100644
--- a/net-fs/nfs-utils/ChangeLog
+++ b/net-fs/nfs-utils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-fs/nfs-utils
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/ChangeLog,v 1.18 2003/06/20 12:54:00 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/ChangeLog,v 1.19 2003/07/16 16:15:33 mholzer Exp $
+
+*nfs-utils-1.0.4 (17 Jul 2003)
+
+ 17 Jul 2003; Martin Holzer <mholzer@gentoo.org> nfs-utils-1.0.4.ebuild:
+ Version bumped.
21 May 2003; Christian Birchinger <joker@gentoo.org> nfs-utils-1.0.3.ebuild:
Added sparc stable keyword
diff --git a/net-fs/nfs-utils/Manifest b/net-fs/nfs-utils/Manifest
index bbf34406b69f..9fb68f71386f 100644
--- a/net-fs/nfs-utils/Manifest
+++ b/net-fs/nfs-utils/Manifest
@@ -1,8 +1,8 @@
-MD5 30a95bdadee9113f92ba57dece5b74d0 ChangeLog 2900
+MD5 f4e6fe281169d7e8f2b5d34d118bb68e ChangeLog 3026
MD5 459bf83dd49739fb9c7191e012f74ddf nfs-utils-0.3.3-r1.ebuild 1504
MD5 b46af45b8acea0fc23c697913ea229cd nfs-utils-1.0.1-r1.ebuild 1911
MD5 647233e075929789b077b1e3851d09f2 nfs-utils-1.0.3.ebuild 1916
-MD5 647233e075929789b077b1e3851d09f2 nfs-utils-1.0.4.ebuild 1916
+MD5 53d66f8912844e3d1b7bf7e37b266f44 nfs-utils-1.0.4.ebuild 1920
MD5 2311e90a0af37bd25f8b2ee25e5aed11 files/digest-nfs-utils-0.3.3-r1 67
MD5 da4b8b95f4c8a015c4a69257ea6582e1 files/digest-nfs-utils-1.0.1-r1 66
MD5 4e34670d8ee2afcd3614a77e290de110 files/digest-nfs-utils-1.0.3 67
diff --git a/net-fs/nfs-utils/files/digest-nfs-utils-1.0.4 b/net-fs/nfs-utils/files/digest-nfs-utils-1.0.4
new file mode 100644
index 000000000000..c11dd09f7e2b
--- /dev/null
+++ b/net-fs/nfs-utils/files/digest-nfs-utils-1.0.4
@@ -0,0 +1 @@
+MD5 5b9166b909e8d9585296166af8cb63f7 nfs-utils-1.0.4.tar.gz 265318
diff --git a/net-fs/nfs-utils/nfs-utils-1.0.4.ebuild b/net-fs/nfs-utils/nfs-utils-1.0.4.ebuild
new file mode 100644
index 000000000000..aecc98a685ab
--- /dev/null
+++ b/net-fs/nfs-utils/nfs-utils-1.0.4.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/nfs-utils-1.0.4.ebuild,v 1.1 2003/07/16 16:15:34 mholzer Exp $
+
+IUSE="tcpd"
+
+DESCRIPTION="NFS client and server daemons"
+SRC_URI="mirror://sourceforge/nfs/${P}.tar.gz"
+HOMEPAGE="http://nfs.sourceforge.net/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~alpha ~sparc ~arm ~hppa"
+
+DEPEND="tcpd? ( sys-apps/tcp-wrappers )"
+RDEPEND="${DEPEND} >=net-nds/portmap-5b-r6"
+
+src_compile() {
+ ./configure \
+ --mandir=/usr/share/man \
+ --with-statedir=/var/lib/nfs \
+ --disable-rquotad --enable-nfsv3 || die "Configure failed"
+
+ if ! use tcpd; then
+ sed -e "s:\(-lwrap\|-DHAVE_TCP_WRAPPER\)::" < config.mk > config.mk.new
+ mv --force config.mk.new config.mk
+ fi
+
+ # parallel make still fails
+ make || die "Failed to compile"
+}
+
+src_install() {
+ make install install_prefix=${D} MANDIR=${D}/usr/share/man \
+ || die "Failed to install"
+
+ # Install some client-side binaries in /sbin
+ mkdir ${D}/sbin
+ mv ${D}/usr/sbin/rpc.{lockd,statd} ${D}/sbin
+
+ dodoc ChangeLog COPYING README
+ docinto linux-nfs ; dodoc linux-nfs/*
+
+ insinto /etc ; doins ${FILESDIR}/exports
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/nfs-1 nfs
+ newexe ${FILESDIR}/nfsmount nfsmount
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/nfs.confd nfs
+}
+
+pkg_postinst() {
+ einfo "NFS V2 and V3 servers now default to \"sync\" IO if ${P}"
+ einfo "(or later) is installed."
+ einfo "More info at ${HOMEPAGE} (see questions 5, 12, 13, and 14)."
+ echo
+ ewarn "PLEASE note: Since the latest NFS utils has changed the server"
+ ewarn "default to \"sync\" IO, then if no behavior is specified in the"
+ ewarn "export list, thus assuming the default behavior, a warning will"
+ ewarn "be generated at export time."
+ echo
+ # Running depscan since we introduced /etc/init.d/{portmap,nfs}
+ /etc/init.d/depscan.sh
+}