summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-06-06 23:27:08 +0000
committerMike Frysinger <vapier@gentoo.org>2005-06-06 23:27:08 +0000
commit15257c000e2b3651809c8184ac6e32ac46e581b1 (patch)
treed87e0610b3806d3e6682b0d43522ab876af77256 /net-fs
parentfixed bug that clobbers any make.conf variable containing *SYNC* (diff)
downloadgentoo-2-15257c000e2b3651809c8184ac6e32ac46e581b1.tar.gz
gentoo-2-15257c000e2b3651809c8184ac6e32ac46e581b1.tar.bz2
gentoo-2-15257c000e2b3651809c8184ac6e32ac46e581b1.zip
fix libtool errors #74774
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/am-utils/am-utils-6.0.9-r1.ebuild16
1 files changed, 9 insertions, 7 deletions
diff --git a/net-fs/am-utils/am-utils-6.0.9-r1.ebuild b/net-fs/am-utils/am-utils-6.0.9-r1.ebuild
index 657c3390f363..e67b11510278 100644
--- a/net-fs/am-utils/am-utils-6.0.9-r1.ebuild
+++ b/net-fs/am-utils/am-utils-6.0.9-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/am-utils/am-utils-6.0.9-r1.ebuild,v 1.10 2004/11/05 22:56:09 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/am-utils/am-utils-6.0.9-r1.ebuild,v 1.11 2005/06/06 23:27:08 vapier Exp $
inherit eutils
@@ -13,15 +13,18 @@ SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE="ldap"
-RDEPEND="virtual/libc
- ldap? ( >=net-nds/openldap-1.2 )"
+RDEPEND="ldap? ( >=net-nds/openldap-1.2 )"
DEPEND="${RDEPEND}
>=sys-apps/portage-2.0.51"
src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}/am-utils-gdbm.patch"
+ epatch "${FILESDIR}"/am-utils-gdbm.patch
+ libtoolize --copy --force && \
+ aclocal && \
+ autoconf && \
+ automake || die "autotools failed"
}
src_compile() {
@@ -36,7 +39,6 @@ src_install() {
make DESTDIR="${D}" install || die "make install failed"
insinto /etc/amd
- doins ${FILESDIR}/amd.{conf,net}
-
+ doins "${FILESDIR}"/amd.{conf,net}
newinitd "${FILESDIR}/amd.rc" amd
}