summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-03-24 21:44:02 +0000
committerMike Frysinger <vapier@gentoo.org>2013-03-24 21:44:02 +0000
commit4481dad2634144a69cf5c6d0c31d04ba85d5df86 (patch)
tree66647618bdcf2b91dc3af3a28286728dccde9cde /net-fs/nfs-utils
parentFix collision with sys-apps/hwids. (diff)
downloadgentoo-2-4481dad2634144a69cf5c6d0c31d04ba85d5df86.tar.gz
gentoo-2-4481dad2634144a69cf5c6d0c31d04ba85d5df86.tar.bz2
gentoo-2-4481dad2634144a69cf5c6d0c31d04ba85d5df86.zip
Fix uClibc build w/missing libio.h #459200 by Mark Reiche.
(Portage version: 2.2.0_alpha169/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'net-fs/nfs-utils')
-rw-r--r--net-fs/nfs-utils/ChangeLog7
-rw-r--r--net-fs/nfs-utils/files/nfs-utils-1.2.7-libio.patch50
-rw-r--r--net-fs/nfs-utils/nfs-utils-1.2.6.ebuild3
-rw-r--r--net-fs/nfs-utils/nfs-utils-1.2.7.ebuild3
4 files changed, 60 insertions, 3 deletions
diff --git a/net-fs/nfs-utils/ChangeLog b/net-fs/nfs-utils/ChangeLog
index d1a5c61c3a17..1ab53088f2fc 100644
--- a/net-fs/nfs-utils/ChangeLog
+++ b/net-fs/nfs-utils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-fs/nfs-utils
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/ChangeLog,v 1.213 2013/03/24 21:38:12 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/ChangeLog,v 1.214 2013/03/24 21:44:02 vapier Exp $
+
+ 24 Mar 2013; Mike Frysinger <vapier@gentoo.org>
+ +files/nfs-utils-1.2.7-libio.patch, nfs-utils-1.2.6.ebuild,
+ nfs-utils-1.2.7.ebuild:
+ Fix uClibc build w/missing libio.h #459200 by Mark Reiche.
*nfs-utils-1.2.7 (24 Mar 2013)
diff --git a/net-fs/nfs-utils/files/nfs-utils-1.2.7-libio.patch b/net-fs/nfs-utils/files/nfs-utils-1.2.7-libio.patch
new file mode 100644
index 000000000000..056ae7db97b0
--- /dev/null
+++ b/net-fs/nfs-utils/files/nfs-utils-1.2.7-libio.patch
@@ -0,0 +1,50 @@
+https://bugs.gentoo.org/459200
+
+From 2d9fb08c588970b842ce2a609088079181e6aafb Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Sun, 24 Mar 2013 17:41:19 -0400
+Subject: [PATCH [nfs-utils]] check for libio.h availability
+
+On some systems (like uClibc), there isn't a libio.h header. But it
+isn't also needed on them. So check for the header first.
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ configure.ac | 2 +-
+ support/include/sockaddr.h | 6 ++++++
+ 2 files changed, 7 insertions(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index f461219..cc7f3b4 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -358,7 +358,7 @@ AC_CHECK_HEADERS([arpa/inet.h fcntl.h libintl.h limits.h \
+ stdlib.h string.h sys/file.h sys/ioctl.h sys/mount.h \
+ sys/param.h sys/socket.h sys/time.h sys/vfs.h \
+ syslog.h unistd.h com_err.h et/com_err.h \
+- ifaddrs.h nfs-plugin.h])
++ ifaddrs.h nfs-plugin.h libio.h])
+
+ dnl *************************************************************
+ dnl Checks for typedefs, structures, and compiler characteristics
+diff --git a/support/include/sockaddr.h b/support/include/sockaddr.h
+index 72766db..a1c30f9 100644
+--- a/support/include/sockaddr.h
++++ b/support/include/sockaddr.h
+@@ -20,7 +20,13 @@
+ #ifndef NFS_UTILS_SOCKADDR_H
+ #define NFS_UTILS_SOCKADDR_H
+
++#ifdef HAVE_CONFIG_H
++#include <config.h>
++#endif
++
++#ifdef HAVE_LIBIO_H
+ #include <libio.h>
++#endif
+ #include <stdbool.h>
+ #include <sys/socket.h>
+ #include <netinet/in.h>
+--
+1.8.1.2
+
diff --git a/net-fs/nfs-utils/nfs-utils-1.2.6.ebuild b/net-fs/nfs-utils/nfs-utils-1.2.6.ebuild
index a3cddcc87c15..d17a028ba33e 100644
--- a/net-fs/nfs-utils/nfs-utils-1.2.6.ebuild
+++ b/net-fs/nfs-utils/nfs-utils-1.2.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/nfs-utils-1.2.6.ebuild,v 1.14 2013/03/24 20:29:48 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/nfs-utils-1.2.6.ebuild,v 1.15 2013/03/24 21:44:02 vapier Exp $
EAPI="4"
@@ -59,6 +59,7 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-1.2.6-osd-install.patch
epatch "${FILESDIR}"/${PN}-1.2.6-conditionals.patch
epatch "${FILESDIR}"/${PN}-1.2.7-nfsiostat-python3.patch #458934
+ epatch "${FILESDIR}"/${PN}-1.2.7-libio.patch #459200
eautoreconf
}
diff --git a/net-fs/nfs-utils/nfs-utils-1.2.7.ebuild b/net-fs/nfs-utils/nfs-utils-1.2.7.ebuild
index 2ba39c4f4a27..19379d36a5ca 100644
--- a/net-fs/nfs-utils/nfs-utils-1.2.7.ebuild
+++ b/net-fs/nfs-utils/nfs-utils-1.2.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/nfs-utils-1.2.7.ebuild,v 1.1 2013/03/24 21:38:12 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/nfs-utils-1.2.7.ebuild,v 1.2 2013/03/24 21:44:02 vapier Exp $
EAPI="4"
@@ -56,6 +56,7 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-1.1.4-mtab-sym.patch
epatch "${FILESDIR}"/${PN}-1.2.6-cross-build.patch
epatch "${FILESDIR}"/${PN}-1.2.7-nfsiostat-python3.patch #458934
+ epatch "${FILESDIR}"/${PN}-1.2.7-libio.patch #459200
eautoreconf
}