summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2011-09-09 21:13:31 +0000
committerSteve Dibb <beandog@gentoo.org>2011-09-09 21:13:31 +0000
commitf45ded2065718d6e0d24922bc323492ef97c6910 (patch)
treea30c8da4b4752d335036a69b14b4a7293a28f4a4 /net-fs/netatalk
parentMarked stable on AMD64 based on arch testing by Agostino "ago" Sarubbo in bug... (diff)
downloadgentoo-2-f45ded2065718d6e0d24922bc323492ef97c6910.tar.gz
gentoo-2-f45ded2065718d6e0d24922bc323492ef97c6910.tar.bz2
gentoo-2-f45ded2065718d6e0d24922bc323492ef97c6910.zip
Version bump
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'net-fs/netatalk')
-rw-r--r--net-fs/netatalk/ChangeLog7
-rw-r--r--net-fs/netatalk/netatalk-2.1.6.ebuild90
2 files changed, 96 insertions, 1 deletions
diff --git a/net-fs/netatalk/ChangeLog b/net-fs/netatalk/ChangeLog
index ca269394cbfa..22e8dbe8223e 100644
--- a/net-fs/netatalk/ChangeLog
+++ b/net-fs/netatalk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-fs/netatalk
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/netatalk/ChangeLog,v 1.68 2011/09/02 17:11:23 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/netatalk/ChangeLog,v 1.69 2011/09/09 21:13:31 beandog Exp $
+
+*netatalk-2.1.6 (09 Sep 2011)
+
+ 09 Sep 2011; Steve Dibb <beandog@gentoo.org> +netatalk-2.1.6.ebuild:
+ Version bump
*netatalk-2.2.0 (02 Sep 2011)
diff --git a/net-fs/netatalk/netatalk-2.1.6.ebuild b/net-fs/netatalk/netatalk-2.1.6.ebuild
new file mode 100644
index 000000000000..0af89852d3db
--- /dev/null
+++ b/net-fs/netatalk/netatalk-2.1.6.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/netatalk/netatalk-2.1.6.ebuild,v 1.1 2011/09/09 21:13:31 beandog Exp $
+
+EAPI="2"
+
+inherit pam
+
+DESCRIPTION="Kernel level implementation of the AppleTalk Protocol Suite"
+HOMEPAGE="http://netatalk.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="cracklib cups debug kerberos pam slp ssl tcpd xfs"
+
+RDEPEND=">=sys-libs/db-4.2.52
+ cracklib? ( sys-libs/cracklib )
+ pam? ( virtual/pam )
+ ssl? ( dev-libs/openssl )
+ tcpd? ( sys-apps/tcp-wrappers )
+ slp? ( net-libs/openslp )
+ cups? ( net-print/cups )
+ kerberos? ( virtual/krb5 )
+ >=sys-apps/coreutils-7.1
+ !app-text/yudit"
+DEPEND="${RDEPEND}
+ xfs? ( sys-fs/xfsprogs )"
+
+src_prepare() {
+ # until someone that understands their config script build
+ # system gets a patch pushed upstream to make
+ # --enable-srvloc passed to configure also add slpd to the
+ # use line on the initscript, we'll need to do it this way
+ if use slp ; then
+ sed -i -e '/^[[:space:]]*use\>/s:$: slpd:' \
+ distrib/initscripts/rc.atalk.gentoo.tmpl || die
+ fi
+}
+
+src_configure() {
+ use xfs || eval $(printf 'export ac_cv_header_%s=no\n' {linux,xfs}_{dqblk_xfs,libxfs,xqm,xfs_fs}_h)
+
+ # Ignore --enable-gentoo, we install the init.d by hand and we avoid having
+ # to sed the Makefiles to not do rc-update.
+ # --enable-shadow: let build system detect shadow.h in toolchain
+ econf \
+ $(use_with pam) \
+ $(use_enable cups) \
+ $(use_enable debug) \
+ $(use_enable tcpd tcp-wrappers) \
+ $(use_enable kerberos krbV-uam) \
+ --disable-krb4-uam \
+ $(use_enable slp srvloc) \
+ $(use_with ssl ssl-dir) \
+ $(use_with cracklib) \
+ $(use_with slp srvloc) \
+ --disable-afs \
+ --enable-fhs \
+ --with-bdb=/usr
+}
+
+src_compile() {
+ emake || die
+
+ # Create the init script manually (it's more messy to --enable-gentoo)
+ emake -C distrib/initscripts rc.atalk.gentoo || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc CONTRIBUTORS NEWS README TODO VERSION
+
+ newinitd distrib/initscripts/rc.atalk.gentoo atalk || die
+
+ # The pamd file isn't what we need, use pamd_mimic_system
+ rm -rf "${D}/etc/pam.d"
+ pamd_mimic_system netatalk auth account password session
+
+ # Move /usr/include/netatalk to /usr/include/netatalk2 to avoid collisions
+ # with /usr/include/netatalk/at.h provided by glibc (strange, uh?)
+ # Packages that wants to link to netatalk should then probably change the
+ # includepath then, but right now, nothing uses netatalk.
+ # On a side note, it also solves collisions with freebsd-lib and other libcs
+ mv "${D}"/usr/include/netatalk{,2} || die
+ sed -i \
+ -e 's/include <netatalk/include <netatalk2/g' \
+ "${D}"usr/include/{netatalk2,atalk}/* || die
+}