summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-01-10 23:10:39 +0000
committerMike Frysinger <vapier@gentoo.org>2010-01-10 23:10:39 +0000
commitcb0ba8a43306c4293b6af743f4e0f9a7c822f32a (patch)
tree363b9c7291f11d871a8c60d29df1d9ce044a9cea /net-fs/netatalk
parentbackport RTLD_NOLOAD support from 8.0; code part (diff)
downloadgentoo-2-cb0ba8a43306c4293b6af743f4e0f9a7c822f32a.tar.gz
gentoo-2-cb0ba8a43306c4293b6af743f4e0f9a7c822f32a.tar.bz2
gentoo-2-cb0ba8a43306c4293b6af743f4e0f9a7c822f32a.zip
Version bump #279057 and block app-text/yudit #247972.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'net-fs/netatalk')
-rw-r--r--net-fs/netatalk/ChangeLog10
-rw-r--r--net-fs/netatalk/files/netatalk-2.0.5-control-pam.patch23
-rw-r--r--net-fs/netatalk/netatalk-2.0.5.ebuild91
3 files changed, 122 insertions, 2 deletions
diff --git a/net-fs/netatalk/ChangeLog b/net-fs/netatalk/ChangeLog
index e36796709d49..d89f4cf3d0b4 100644
--- a/net-fs/netatalk/ChangeLog
+++ b/net-fs/netatalk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-fs/netatalk
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/netatalk/ChangeLog,v 1.55 2009/05/21 20:24:33 ranger Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/netatalk/ChangeLog,v 1.56 2010/01/10 23:10:39 vapier Exp $
+
+*netatalk-2.0.5 (10 Jan 2010)
+
+ 10 Jan 2010; Mike Frysinger <vapier@gentoo.org> +netatalk-2.0.5.ebuild,
+ +files/netatalk-2.0.5-control-pam.patch:
+ Version bump #279057 and block app-text/yudit #247972.
21 May 2009; Brent Baude <ranger@gentoo.org> netatalk-2.0.3-r4.ebuild:
stable ppc, bug 265037
diff --git a/net-fs/netatalk/files/netatalk-2.0.5-control-pam.patch b/net-fs/netatalk/files/netatalk-2.0.5-control-pam.patch
new file mode 100644
index 000000000000..4c069dcab258
--- /dev/null
+++ b/net-fs/netatalk/files/netatalk-2.0.5-control-pam.patch
@@ -0,0 +1,23 @@
+don't install the pam.d file if pam is disabled
+
+--- a/configure
++++ b/configure
+@@ -28572,12 +28572,16 @@
+ LIBS="$savedLIBS"
+ fi
+
+- netatalk_cv_install_pam=yes
+- if test x"$pam_found" = "xyes" -a "x$PAMDIR" = "xNONE"; then
++ if test "x$require_pam" != "xnever"; then
++ netatalk_cv_install_pam=yes
++ if test x"$pam_found" = "xyes" -a "x$PAMDIR" = "xNONE" ; then
+ { echo "$as_me:$LINENO: WARNING: PAM support can be compiled, but the install location for the netatalk.pamd file could not be determined. Either install this file by hand or specify the install path." >&5
+ echo "$as_me: WARNING: PAM support can be compiled, but the install location for the netatalk.pamd file could not be determined. Either install this file by hand or specify the install path." >&2;}
+ netatalk_cv_install_pam=no
+ fi
++ else
++ netatalk_cv_install_pam=no
++ fi
+
+ { echo "$as_me:$LINENO: checking whether to enable PAM support" >&5
+ echo $ECHO_N "checking whether to enable PAM support... $ECHO_C" >&6; }
diff --git a/net-fs/netatalk/netatalk-2.0.5.ebuild b/net-fs/netatalk/netatalk-2.0.5.ebuild
new file mode 100644
index 000000000000..39024ccf3b88
--- /dev/null
+++ b/net-fs/netatalk/netatalk-2.0.5.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/netatalk/netatalk-2.0.5.ebuild,v 1.1 2010/01/10 23:10:39 vapier Exp $
+
+inherit eutils pam autotools
+
+DESCRIPTION="Kernel level implementation of the AppleTalk Protocol Suite"
+HOMEPAGE="http://netatalk.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="ssl pam tcpd slp cups kerberos krb4 debug cracklib xfs"
+
+RDEPEND=">=sys-libs/db-4.2.52
+ cracklib? ( sys-libs/cracklib )
+ pam? ( virtual/pam )
+ ssl? ( dev-libs/openssl )
+ tcpd? ( sys-apps/tcp-wrappers )
+ slp? ( net-libs/openslp )
+ cups? ( net-print/cups )
+ kerberos? ( virtual/krb5 )
+ krb4? ( virtual/krb5 )
+ >=sys-apps/coreutils-7.1
+ !app-text/yudit"
+DEPEND="${RDEPEND}
+ xfs? ( sys-fs/xfsprogs <sys-kernel/linux-headers-2.6.16 )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-control-pam.patch
+
+ # until someone that understands their config script build
+ # system gets a patch pushed upstream to make
+ # --enable-srvloc passed to configure also add slpd to the
+ # use line on the initscript, we'll need to do it this way
+ if use slp ; then
+ sed -i -e '/^[[:space:]]*use\>/s:$: slpd:' \
+ distrib/initscripts/rc.atalk.gentoo.tmpl || die
+ fi
+}
+
+src_compile() {
+ if ! use xfs ; then
+ eval $(printf '%s\n' {linux,xfs}/{dqblk_xfs,libxfs,xqm,xfs_fs}.h | \
+ sed -e 's:[/.]:_:g' -e 's:^:export ac_cv_header_:' -e 's:$:=no:')
+ fi
+
+ # Ignore --enable-gentoo, we install the init.d by hand and we avoid having to
+ # sed the Makefiles to not do rc-update.
+ # --enable-shadow: let build system detect shadow.h in toolchain
+ econf \
+ $(use_with pam) \
+ $(use_enable cups) \
+ $(use_enable debug) \
+ $(use_enable tcpd tcp-wrappers) \
+ $(use_enable kerberos krbV-uam) \
+ $(use_enable krb4 krb4-uam) \
+ $(use_enable slp srvloc) \
+ $(use_with ssl ssl-dir) \
+ $(use_with cracklib) \
+ $(use_with slp srvloc) \
+ $(use_with xfs) \
+ --disable-afs \
+ --enable-fhs \
+ --with-bdb=/usr
+ emake || die
+
+ # Create the init script manually (it's more messy to --enable-gentoo)
+ emake -C distrib/initscripts rc.atalk.gentoo || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc CONTRIBUTORS NEWS README TODO VERSION
+
+ newinitd distrib/initscripts/rc.atalk.gentoo atalk || die
+
+ # The pamd file isn't what we need, use pamd_mimic_system
+ rm -rf "${D}/etc/pam.d"
+ pamd_mimic_system netatalk auth account password session
+
+ # Move /usr/include/netatalk to /usr/include/netatalk2 to avoid collisions
+ # with /usr/include/netatalk/at.h provided by glibc (strange, uh?)
+ # Packages that wants to link to netatalk should then probably change the
+ # includepath then, but right now, nothing uses netatalk.
+ # On a side note, it also solves collisions with freebsd-lib and other libcs
+ mv "${D}"/usr/include/netatalk{,2} || die
+}