summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-01-04 20:26:10 +0000
committerMike Frysinger <vapier@gentoo.org>2011-01-04 20:26:10 +0000
commit8bdd52b087ad63296a8fb84c73277685c6fbfd31 (patch)
tree727954d6e6f9eda2f88be8bcbd9ca710ecdc7707 /net-fs/netatalk
parentfixed implicit RDEPEND (diff)
downloadgentoo-2-8bdd52b087ad63296a8fb84c73277685c6fbfd31.tar.gz
gentoo-2-8bdd52b087ad63296a8fb84c73277685c6fbfd31.tar.bz2
gentoo-2-8bdd52b087ad63296a8fb84c73277685c6fbfd31.zip
Version bump #350549 by Timothy Miller.
(Portage version: 2.2.0_alpha10/cvs/Linux x86_64)
Diffstat (limited to 'net-fs/netatalk')
-rw-r--r--net-fs/netatalk/ChangeLog9
-rw-r--r--net-fs/netatalk/netatalk-2.1.5.ebuild90
2 files changed, 97 insertions, 2 deletions
diff --git a/net-fs/netatalk/ChangeLog b/net-fs/netatalk/ChangeLog
index 5158a1314c64..cb40ceb4843a 100644
--- a/net-fs/netatalk/ChangeLog
+++ b/net-fs/netatalk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-fs/netatalk
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/netatalk/ChangeLog,v 1.66 2010/10/15 02:05:39 vapier Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/netatalk/ChangeLog,v 1.67 2011/01/04 20:26:10 vapier Exp $
+
+*netatalk-2.1.5 (04 Jan 2011)
+
+ 04 Jan 2011; Mike Frysinger <vapier@gentoo.org> +netatalk-2.1.5.ebuild:
+ Version bump #350549 by Timothy Miller.
15 Oct 2010; Mike Frysinger <vapier@gentoo.org> netatalk-2.0.5-r1.ebuild,
netatalk-2.1.ebuild, netatalk-2.1.3.ebuild:
diff --git a/net-fs/netatalk/netatalk-2.1.5.ebuild b/net-fs/netatalk/netatalk-2.1.5.ebuild
new file mode 100644
index 000000000000..4e5a05880c39
--- /dev/null
+++ b/net-fs/netatalk/netatalk-2.1.5.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/netatalk/netatalk-2.1.5.ebuild,v 1.1 2011/01/04 20:26:10 vapier Exp $
+
+EAPI="2"
+
+inherit pam
+
+DESCRIPTION="Kernel level implementation of the AppleTalk Protocol Suite"
+HOMEPAGE="http://netatalk.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="cracklib cups debug kerberos pam slp ssl tcpd xfs"
+
+RDEPEND=">=sys-libs/db-4.2.52
+ cracklib? ( sys-libs/cracklib )
+ pam? ( virtual/pam )
+ ssl? ( dev-libs/openssl )
+ tcpd? ( sys-apps/tcp-wrappers )
+ slp? ( net-libs/openslp )
+ cups? ( net-print/cups )
+ kerberos? ( virtual/krb5 )
+ >=sys-apps/coreutils-7.1
+ !app-text/yudit"
+DEPEND="${RDEPEND}
+ xfs? ( sys-fs/xfsprogs )"
+
+src_prepare() {
+ # until someone that understands their config script build
+ # system gets a patch pushed upstream to make
+ # --enable-srvloc passed to configure also add slpd to the
+ # use line on the initscript, we'll need to do it this way
+ if use slp ; then
+ sed -i -e '/^[[:space:]]*use\>/s:$: slpd:' \
+ distrib/initscripts/rc.atalk.gentoo.tmpl || die
+ fi
+}
+
+src_configure() {
+ use xfs || eval $(printf 'export ac_cv_header_%s=no\n' {linux,xfs}_{dqblk_xfs,libxfs,xqm,xfs_fs}_h)
+
+ # Ignore --enable-gentoo, we install the init.d by hand and we avoid having
+ # to sed the Makefiles to not do rc-update.
+ # --enable-shadow: let build system detect shadow.h in toolchain
+ econf \
+ $(use_with pam) \
+ $(use_enable cups) \
+ $(use_enable debug) \
+ $(use_enable tcpd tcp-wrappers) \
+ $(use_enable kerberos krbV-uam) \
+ --disable-krb4-uam \
+ $(use_enable slp srvloc) \
+ $(use_with ssl ssl-dir) \
+ $(use_with cracklib) \
+ $(use_with slp srvloc) \
+ --disable-afs \
+ --enable-fhs \
+ --with-bdb=/usr
+}
+
+src_compile() {
+ emake || die
+
+ # Create the init script manually (it's more messy to --enable-gentoo)
+ emake -C distrib/initscripts rc.atalk.gentoo || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc CONTRIBUTORS NEWS README TODO VERSION
+
+ newinitd distrib/initscripts/rc.atalk.gentoo atalk || die
+
+ # The pamd file isn't what we need, use pamd_mimic_system
+ rm -rf "${D}/etc/pam.d"
+ pamd_mimic_system netatalk auth account password session
+
+ # Move /usr/include/netatalk to /usr/include/netatalk2 to avoid collisions
+ # with /usr/include/netatalk/at.h provided by glibc (strange, uh?)
+ # Packages that wants to link to netatalk should then probably change the
+ # includepath then, but right now, nothing uses netatalk.
+ # On a side note, it also solves collisions with freebsd-lib and other libcs
+ mv "${D}"/usr/include/netatalk{,2} || die
+ sed -i \
+ -e 's/include <netatalk/include <netatalk2/g' \
+ "${D}"usr/include/{netatalk2,atalk}/* || die
+}