summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaurice van der Pot <griffon26@gentoo.org>2007-05-11 19:49:06 +0000
committerMaurice van der Pot <griffon26@gentoo.org>2007-05-11 19:49:06 +0000
commit395595c8252978e3c9a9076076064e8e949f643e (patch)
tree283114e1bd168182471dc68273644853d5e8e47c /net-fs/ncpfs
parentDont run make bootstrap for src_test, it deletes ocamlopt, upstream does not ... (diff)
downloadgentoo-2-395595c8252978e3c9a9076076064e8e949f643e.tar.gz
gentoo-2-395595c8252978e3c9a9076076064e8e949f643e.tar.bz2
gentoo-2-395595c8252978e3c9a9076076064e8e949f643e.zip
Added missing includes to ncpfs-2.2.6 fixing compile errors (bug #157462 and #178090)
(Portage version: 2.1.2.5)
Diffstat (limited to 'net-fs/ncpfs')
-rw-r--r--net-fs/ncpfs/ChangeLog11
-rw-r--r--net-fs/ncpfs/files/ncpfs-2.2.6-missing-includes.patch22
-rw-r--r--net-fs/ncpfs/ncpfs-2.2.6.ebuild5
3 files changed, 34 insertions, 4 deletions
diff --git a/net-fs/ncpfs/ChangeLog b/net-fs/ncpfs/ChangeLog
index a9d582181f0e..9d5d7a1b72d8 100644
--- a/net-fs/ncpfs/ChangeLog
+++ b/net-fs/ncpfs/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-fs/ncpfs
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/ncpfs/ChangeLog,v 1.22 2006/11/28 17:31:37 chtekk Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/ncpfs/ChangeLog,v 1.23 2007/05/11 19:49:06 griffon26 Exp $
+
+ 11 May 2007; Maurice van der Pot <griffon26@gentoo.org>
+ +files/ncpfs-2.2.6-missing-includes.patch, ncpfs-2.2.6.ebuild:
+ Added some includes for missing header files, fixing errors during
+ compilation reported as bug #157462 and bug #178090 by Willard Dawson
+ <willard.dawson@sungard.com> and Marat Radchenko <valder@yandex.ru>
+ respectively.
28 Nov 2006; Luca Longinotti <chtekk@gentoo.org> -ncpfs-2.2.0.19.ebuild,
-ncpfs-2.2.0.19-r1.ebuild, -ncpfs-2.2.0.19-r2.ebuild, -ncpfs-2.2.3.ebuild,
diff --git a/net-fs/ncpfs/files/ncpfs-2.2.6-missing-includes.patch b/net-fs/ncpfs/files/ncpfs-2.2.6-missing-includes.patch
new file mode 100644
index 000000000000..11a4f87add48
--- /dev/null
+++ b/net-fs/ncpfs/files/ncpfs-2.2.6-missing-includes.patch
@@ -0,0 +1,22 @@
+diff -ruN ncpfs-2.2.6/contrib/pam/pam_ncp_auth.c ncpfs-2.2.6-fixed/contrib/pam/pam_ncp_auth.c
+--- ncpfs-2.2.6/contrib/pam/pam_ncp_auth.c 2005-01-27 18:35:59.000000000 +0100
++++ ncpfs-2.2.6-fixed/contrib/pam/pam_ncp_auth.c 2007-05-11 21:38:05.143474750 +0200
+@@ -257,6 +257,7 @@
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <string.h>
++#include <syslog.h>
+ #include <unistd.h>
+ #include <pwd.h>
+ #include <grp.h>
+diff -ruN ncpfs-2.2.6/sutil/ncpm_common.c ncpfs-2.2.6-fixed/sutil/ncpm_common.c
+--- ncpfs-2.2.6/sutil/ncpm_common.c 2005-01-27 18:35:59.000000000 +0100
++++ ncpfs-2.2.6-fixed/sutil/ncpm_common.c 2007-05-11 21:38:29.609003750 +0200
+@@ -82,6 +82,7 @@
+
+ #include "ncpm_common.h"
+
++#include <stddef.h>
+ #include <stdio.h>
+ #include <string.h>
+ #include <signal.h>
diff --git a/net-fs/ncpfs/ncpfs-2.2.6.ebuild b/net-fs/ncpfs/ncpfs-2.2.6.ebuild
index 9b6e709d9158..b621a7fba44b 100644
--- a/net-fs/ncpfs/ncpfs-2.2.6.ebuild
+++ b/net-fs/ncpfs/ncpfs-2.2.6.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/ncpfs/ncpfs-2.2.6.ebuild,v 1.3 2006/01/28 05:40:03 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/ncpfs/ncpfs-2.2.6.ebuild,v 1.4 2007/05/11 19:49:06 griffon26 Exp $
inherit eutils confutils
@@ -25,6 +25,7 @@ src_unpack() {
cd ${S} || die "Unable to cd to ${S}"
epatch "${FILESDIR}"/${PN}-2.2.5-php.patch || die "Unable to apply PHP patch"
epatch "${FILESDIR}"/${P}-gcc4.patch
+ epatch "${FILESDIR}"/${P}-missing-includes.patch
}
src_compile() {