summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2008-06-11 13:43:26 +0000
committerTiziano Müller <dev-zero@gentoo.org>2008-06-11 13:43:26 +0000
commit3a94a1ed1f8fd0f3d5aeaee929ce46819c12fa2f (patch)
tree9da70d802f139bcd98a9bb58bbdc534a23a38d9e /net-fs/mount-cifs
parentmedia-sound/banshee:podcast - Build with podcasting support (diff)
downloadgentoo-2-3a94a1ed1f8fd0f3d5aeaee929ce46819c12fa2f.tar.gz
gentoo-2-3a94a1ed1f8fd0f3d5aeaee929ce46819c12fa2f.tar.bz2
gentoo-2-3a94a1ed1f8fd0f3d5aeaee929ce46819c12fa2f.zip
Version bump (fixes bug #225509, patch included)
(Portage version: 2.1.5.4)
Diffstat (limited to 'net-fs/mount-cifs')
-rw-r--r--net-fs/mount-cifs/ChangeLog8
-rw-r--r--net-fs/mount-cifs/mount-cifs-3.0.30.ebuild31
2 files changed, 38 insertions, 1 deletions
diff --git a/net-fs/mount-cifs/ChangeLog b/net-fs/mount-cifs/ChangeLog
index 255154310369..5e7118ad4471 100644
--- a/net-fs/mount-cifs/ChangeLog
+++ b/net-fs/mount-cifs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-fs/mount-cifs
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/mount-cifs/ChangeLog,v 1.13 2008/02/01 14:07:27 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/mount-cifs/ChangeLog,v 1.14 2008/06/11 13:43:26 dev-zero Exp $
+
+*mount-cifs-3.0.30 (11 Jun 2008)
+
+ 11 Jun 2008; Tiziano Müller <dev-zero@gentoo.org>
+ +mount-cifs-3.0.30.ebuild:
+ Version bump (fixes bug #225509, patch included)
01 Feb 2008; Raúl Porcel <armin76@gentoo.org> mount-cifs-3.0.28.ebuild:
alpha/ia64/sparc stable wrt #206502
diff --git a/net-fs/mount-cifs/mount-cifs-3.0.30.ebuild b/net-fs/mount-cifs/mount-cifs-3.0.30.ebuild
new file mode 100644
index 000000000000..c0b25b942883
--- /dev/null
+++ b/net-fs/mount-cifs/mount-cifs-3.0.30.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/mount-cifs/mount-cifs-3.0.30.ebuild,v 1.1 2008/06/11 13:43:26 dev-zero Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="cifs filesystem mount helper split from Samba"
+HOMEPAGE="http://linux-cifs.samba.org/cifs/cifs_download.html"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND="!<net-fs/samba-3.0.25"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ cd "${S}/source/client"
+ $(tc-getCC) ${CFLAGS} mount.cifs.c -o mount.cifs || die "make mount.cifs failed"
+ $(tc-getCC) ${CFLAGS} umount.cifs.c -o umount.cifs || die "make umount.cifs failed"
+}
+
+src_install() {
+ dobin source/client/{mount,umount}.cifs
+ dosym /usr/bin/mount.cifs /sbin/mount.cifs
+
+ docinto html
+ dohtml docs/htmldocs/*
+ doman docs/manpages/{mount,umount}.cifs.8
+}