summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Drake <dsd@gentoo.org>2005-07-29 18:38:58 +0000
committerDaniel Drake <dsd@gentoo.org>2005-07-29 18:38:58 +0000
commit3a77b8b98b3602b1a54c2d6080ede8e895fdf79c (patch)
tree242c4f5fbaa2ad378f1dd9a5cfbb1bc39fbb4ac8 /net-fs/coda-kernel
parentStable on ppc64 (bug #99881) (diff)
downloadgentoo-2-3a77b8b98b3602b1a54c2d6080ede8e895fdf79c.tar.gz
gentoo-2-3a77b8b98b3602b1a54c2d6080ede8e895fdf79c.tar.bz2
gentoo-2-3a77b8b98b3602b1a54c2d6080ede8e895fdf79c.zip
Version bump and conversion to linux-mod
(Portage version: 1.589-cvs)
Diffstat (limited to 'net-fs/coda-kernel')
-rw-r--r--net-fs/coda-kernel/ChangeLog9
-rw-r--r--net-fs/coda-kernel/Manifest14
-rw-r--r--net-fs/coda-kernel/coda-kernel-6.2.ebuild33
-rw-r--r--net-fs/coda-kernel/files/digest-coda-kernel-6.21
4 files changed, 44 insertions, 13 deletions
diff --git a/net-fs/coda-kernel/ChangeLog b/net-fs/coda-kernel/ChangeLog
index 0d988d13167e..018f2d5a8665 100644
--- a/net-fs/coda-kernel/ChangeLog
+++ b/net-fs/coda-kernel/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-fs/coda-kernel
-# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/coda-kernel/ChangeLog,v 1.2 2004/06/24 22:42:52 agriffis Exp $
+# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/coda-kernel/ChangeLog,v 1.3 2005/07/29 18:38:58 dsd Exp $
+
+*coda-kernel-6.2 (29 Jul 2005)
+
+ 29 Jul 2005; Daniel Drake <dsd@gentoo.org> +coda-kernel-6.2.ebuild:
+ Version bump and conversion to linux-mod
*coda-kernel-6.0.0 (20 Nov 2003)
diff --git a/net-fs/coda-kernel/Manifest b/net-fs/coda-kernel/Manifest
index 907429c0b0d4..0a2d48fefc88 100644
--- a/net-fs/coda-kernel/Manifest
+++ b/net-fs/coda-kernel/Manifest
@@ -1,14 +1,6 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 9f90235c0e59f4adc3a3f591ab5a9670 ChangeLog 439
+MD5 14939c1364fce42dad6788298282c9f7 coda-kernel-6.2.ebuild 1053
MD5 66c34a68f19def8947ff68b1280f9b1f coda-kernel-6.0.0.ebuild 1412
+MD5 9f90235c0e59f4adc3a3f591ab5a9670 ChangeLog 439
MD5 47cb41aa35e40830d5874d3214268770 metadata.xml 332
+MD5 aa24351ff473d8b3def550fdede285ed files/digest-coda-kernel-6.2 63
MD5 c7f6a115db65915dee65cd11dba37b64 files/digest-coda-kernel-6.0.0 65
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.9.10 (GNU/Linux)
-
-iD8DBQFBYHK/I1lqEGTUzyQRAsk2AJ9ZfO2zPb2kTpsbHjqPdyG0iAUGbgCgqeJD
-HjO6kHQZyecT3TCJgbjQSuo=
-=kt57
------END PGP SIGNATURE-----
diff --git a/net-fs/coda-kernel/coda-kernel-6.2.ebuild b/net-fs/coda-kernel/coda-kernel-6.2.ebuild
new file mode 100644
index 000000000000..03fa1f00b3e7
--- /dev/null
+++ b/net-fs/coda-kernel/coda-kernel-6.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/coda-kernel/coda-kernel-6.2.ebuild,v 1.1 2005/07/29 18:38:58 dsd Exp $
+
+inherit linux-mod
+
+MY_PN=linux-coda
+MY_P=${MY_PN}-${PV}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Kernel module for the Coda Filesystem. The stock module will not work for Coda versions 6.0 and above."
+HOMEPAGE="http://www.coda.cs.cmu.edu/"
+SRC_URI="ftp://ftp.coda.cs.cmu.edu/pub/coda/linux/kernel/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~mips ~amd64 ~ia64"
+IUSE=""
+
+pkg_setup() {
+ if kernel_is 2 4; then
+ MODULE_NAMES="coda(coda:${S}/linux2.4)"
+ elif kernel_is 2 6; then
+ MODULE_NAMES="coda(coda:${S}/linux2.6)"
+ else
+ die "Unsupported kernel"
+ fi
+
+ BUILD_TARGETS="all"
+ CONFIG_CHECK="!CODA_FS"
+ CODA_FS_ERROR="You must disable \"Coda file system support\" in your kernel configuration, because it conflicts with this package."
+ linux-mod_pkg_setup
+ BUILD_PARAMS="KVER=${KV_FULL} KSRC=${KV_DIR}"
+}
+
diff --git a/net-fs/coda-kernel/files/digest-coda-kernel-6.2 b/net-fs/coda-kernel/files/digest-coda-kernel-6.2
new file mode 100644
index 000000000000..36e7831bf51b
--- /dev/null
+++ b/net-fs/coda-kernel/files/digest-coda-kernel-6.2
@@ -0,0 +1 @@
+MD5 f9061feb3a951fe36ad1147b3cbffdaa linux-coda-6.2.tgz 152672