summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2013-04-03 13:44:00 +0000
committerLars Wendler <polynomial-c@gentoo.org>2013-04-03 13:44:00 +0000
commitde207625200413b351a4867b925888b1cc99739e (patch)
treee225083b712f378461bfd74746c90679f47c7478 /net-fs/cifs-utils
parentVersion bump (diff)
downloadgentoo-2-de207625200413b351a4867b925888b1cc99739e.tar.gz
gentoo-2-de207625200413b351a4867b925888b1cc99739e.tar.bz2
gentoo-2-de207625200413b351a4867b925888b1cc99739e.zip
Version bump
(Portage version: 2.2.0_alpha171/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'net-fs/cifs-utils')
-rw-r--r--net-fs/cifs-utils/ChangeLog7
-rw-r--r--net-fs/cifs-utils/cifs-utils-6.0.ebuild82
2 files changed, 88 insertions, 1 deletions
diff --git a/net-fs/cifs-utils/ChangeLog b/net-fs/cifs-utils/ChangeLog
index dcd50c4a511e..49816544ae0f 100644
--- a/net-fs/cifs-utils/ChangeLog
+++ b/net-fs/cifs-utils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-fs/cifs-utils
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/cifs-utils/ChangeLog,v 1.50 2013/02/25 12:07:15 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/cifs-utils/ChangeLog,v 1.51 2013/04/03 13:44:00 polynomial-c Exp $
+
+*cifs-utils-6.0 (03 Apr 2013)
+
+ 03 Apr 2013; Lars Wendler <polynomial-c@gentoo.org> +cifs-utils-6.0.ebuild:
+ Non-maintainer commit: Version bump.
*cifs-utils-5.9-r1 (25 Feb 2013)
diff --git a/net-fs/cifs-utils/cifs-utils-6.0.ebuild b/net-fs/cifs-utils/cifs-utils-6.0.ebuild
new file mode 100644
index 000000000000..7371ba4b3b79
--- /dev/null
+++ b/net-fs/cifs-utils/cifs-utils-6.0.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/cifs-utils/cifs-utils-6.0.ebuild,v 1.1 2013/04/03 13:44:00 polynomial-c Exp $
+
+EAPI=4
+
+inherit eutils confutils linux-info
+
+DESCRIPTION="Tools for Managing Linux CIFS Client Filesystems"
+HOMEPAGE="http://wiki.samba.org/index.php/LinuxCIFS_utils"
+SRC_URI="ftp://ftp.samba.org/pub/linux-cifs/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~arm-linux ~x86-linux"
+IUSE="ads +caps caps-ng creds upcall"
+
+DEPEND="!net-fs/mount-cifs
+ !<net-fs/samba-3.6_rc1
+ ads? ( sys-libs/talloc virtual/krb5 sys-apps/keyutils )
+ caps? ( sys-libs/libcap )
+ caps-ng? ( sys-libs/libcap-ng )
+ creds? ( sys-apps/keyutils )
+ upcall? ( sys-apps/keyutils sys-libs/talloc virtual/krb5 )"
+RDEPEND="${DEPEND}"
+
+REQUIRED_USE="^^ ( caps caps-ng )"
+
+DOCS="doc/linux-cifs-client-guide.odt"
+
+pkg_setup() {
+ linux-info_pkg_setup
+
+ confutils_use_conflict caps caps-ng
+ if ! linux_config_exists || ! linux_chkconfig_present CIFS; then
+ ewarn "You must enable CIFS support in your kernel config, "
+ ewarn "to be able to mount samba shares. You can find it at"
+ ewarn
+ ewarn " File systems"
+ ewarn " Network File Systems"
+ ewarn " CIFS support"
+ ewarn
+ ewarn "and recompile your kernel ..."
+ fi
+}
+
+src_configure() {
+ ROOTSBINDIR="${EPREFIX}"/sbin \
+ econf \
+ $(use_enable ads cifsupcall) \
+ $(use_with caps libcap) \
+ $(use_with caps-ng libcap-ng) \
+ $(use_enable creds cifscreds) \
+ $(use_enable upcall cifsupcall) \
+ --with-libcap-ng=$(use caps-ng && echo 'yes' || echo 'no') \
+ --disable-cifsidmap \
+ --disable-cifsacl
+}
+
+src_install() {
+ default
+
+ # remove empty directories
+ find "${ED}" -type d -print0 | xargs --null rmdir \
+ --ignore-fail-on-non-empty &>/dev/null
+}
+
+pkg_postinst() {
+ # Inform about set-user-ID bit of mount.cifs
+ ewarn "setuid use flag was dropped due to multiple security implications"
+ ewarn "such as CVE-2009-2948, CVE-2011-3585 and CVE-2012-1586"
+ ewarn "You are free to set setuid flags by yourself"
+
+ # Inform about upcall usage
+ if use ads ; then
+ ewarn "Using mount.cifs in combination with keyutils"
+ ewarn "in order to mount DFS shares, you need to add"
+ ewarn "the following line to /etc/request-key.conf:"
+ ewarn " create dns_resolver * * /usr/sbin/cifs.upcall %k"
+ ewarn "Otherwise, your DFS shares will not work properly."
+ fi
+}