summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2011-09-15 03:52:42 +0000
committerPeter Volkov <pva@gentoo.org>2011-09-15 03:52:42 +0000
commite516073cddbfba8640475220fb206dd01594c29e (patch)
treee1a4362ca8f1dee87a625d8c0076874721c37600 /net-fs/autofs
parentVersion bump #382869 by Emulatorman. (diff)
downloadgentoo-2-e516073cddbfba8640475220fb206dd01594c29e.tar.gz
gentoo-2-e516073cddbfba8640475220fb206dd01594c29e.tar.bz2
gentoo-2-e516073cddbfba8640475220fb206dd01594c29e.zip
Fix ldap problem with -sasl, bug #381315 thank Martin Stockinger for report and Dustin Polke for this job.
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'net-fs/autofs')
-rw-r--r--net-fs/autofs/ChangeLog9
-rw-r--r--net-fs/autofs/autofs-5.0.6-r2.ebuild115
-rw-r--r--net-fs/autofs/files/autofs-5.0.6-revert-ldap.patch18
3 files changed, 141 insertions, 1 deletions
diff --git a/net-fs/autofs/ChangeLog b/net-fs/autofs/ChangeLog
index ef50efd431c0..3d18a50b415e 100644
--- a/net-fs/autofs/ChangeLog
+++ b/net-fs/autofs/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-fs/autofs
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/ChangeLog,v 1.122 2011/09/13 17:53:17 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/ChangeLog,v 1.123 2011/09/15 03:52:42 pva Exp $
+
+*autofs-5.0.6-r2 (14 Sep 2011)
+
+ 14 Sep 2011; Peter Volkov <pva@gentoo.org> +autofs-5.0.6-r2.ebuild,
+ +files/autofs-5.0.6-revert-ldap.patch:
+ Fix ldap problem with -sasl, bug #381315 thank Martin Stockinger for report
+ and Dustin Polke for this job.
13 Sep 2011; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Drop maintainer due retirement, bug #99651
diff --git a/net-fs/autofs/autofs-5.0.6-r2.ebuild b/net-fs/autofs/autofs-5.0.6-r2.ebuild
new file mode 100644
index 000000000000..a5e1c2712e4d
--- /dev/null
+++ b/net-fs/autofs/autofs-5.0.6-r2.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/autofs-5.0.6-r2.ebuild,v 1.1 2011/09/15 03:52:42 pva Exp $
+
+EAPI="4"
+inherit eutils multilib autotools linux-info
+
+DESCRIPTION="Kernel based automounter"
+HOMEPAGE="http://www.linux-consulting.com/Amd_AutoFS/autofs.html"
+PATCH_VER=""
+[[ -n ${PATCH_VER} ]] && \
+ PATCHSET_URI="mirror://gentoo/${P}-patches-${PATCH_VER}.tar.lzma"
+SRC_URI="mirror://kernel/linux/daemons/${PN}/v5/${P}.tar.bz2
+ ${PATCHSET_URI}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="hesiod ldap sasl"
+
+# USE="sasl" adds SASL support to the LDAP module which will not be build. If
+# SASL support should be available, please add "ldap" to the USE flags.
+REQUIRED_USE="sasl? ( ldap )"
+
+# currently, sasl code assumes the presence of kerberosV
+RDEPEND="hesiod? ( net-dns/hesiod )
+ ldap? ( >=net-nds/openldap-2.0
+ sasl? ( dev-libs/cyrus-sasl
+ dev-libs/libxml2
+ virtual/krb5 ) )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ # Upstream's patchset
+ if [[ -n ${PATCH_VER} ]]; then
+ EPATCH_SUFFIX="patch" \
+ epatch "${WORKDIR}"/patches
+ fi
+
+ # Fix for bug #210762
+ # Upstream reference: http://thread.gmane.org/gmane.linux.kernel.autofs/4203
+ epatch "${FILESDIR}"/${PN}-5.0.3-heimdal.patch
+
+ # Accumulated fixes for bugs
+ # #154797: Respect CC and CFLAGS
+ # #253412: Respect LDFLAGS
+ # #247969: Link order for --as-needed
+ epatch "${FILESDIR}"/${P}-respect-user-flags-and-fix-asneeded.patch
+
+ # do not include <nfs/nfs.h>, rather <linux/nfs.h>,
+ # as the former is a lame header for the latter (bug #157968)
+ sed 's@nfs/nfs.h@linux/nfs.h@' -i include/rpc_subs.h || die
+
+ # Upstream reference: http://thread.gmane.org/gmane.linux.kernel.autofs/5371
+ epatch "${FILESDIR}"/${PN}-5.0.5-fix-install-deadlink.patch
+
+ # Upstream reference: http://thread.gmane.org/gmane.linux.kernel.autofs/6039
+ # Disable LDAP specific code if USE="-ldap", let's see what upstream says...
+ epatch "${FILESDIR}"/${PN}-5.0.5-fix-building-without-ldap.patch
+
+ # https://bugs.gentoo.org/show_bug.cgi?id=361899
+ epatch "${FILESDIR}"/${PN}-5.0.5-add-missing-endif-HAVE_SASL-in-modules-lookup_ldap.c.patch
+
+ # Fix for bug #373577
+ # Upstream reference: http://article.gmane.org/gmane.linux.kernel.autofs/6187
+ # Fix regression in IPv6 name lookup regression
+ epatch "${FILESDIR}"/${P}-ipv6_name_lookup_regression.patch
+
+ # https://bugs.gentoo.org/show_bug.cgi?id=381315
+ epatch "${FILESDIR}"/${P}-revert-ldap.patch
+ eautoreconf
+}
+
+src_configure() {
+ # work around bug #355975 (mount modifies timestamp of /etc/mtab)
+ # with >=sys-apps/util-linux-2.19,
+ addpredict "/etc/mtab"
+
+ # --with-confdir is for bug #361481
+ econf \
+ --with-confdir=/etc/conf.d \
+ $(use_with ldap openldap) \
+ $(use_with sasl) \
+ $(use_with hesiod) \
+ --enable-ignore-busy
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc README* CHANGELOG CREDITS COPYRIGHT INSTALL
+
+ # kernel patches
+ docinto patches
+ dodoc patches/${PN}4-2.6.??{,.?{,?}}-v5-update-????????.patch
+
+ newinitd "${FILESDIR}"/autofs5.initd autofs
+ insinto etc/autofs
+ newins "${FILESDIR}"/autofs5-auto.master auto.master
+}
+
+pkg_postinst() {
+ if kernel_is -lt 2 6 30; then
+ elog "This version of ${PN} requires a kernel with autofs4 supporting"
+ elog "protocol version 5.00. Patches for kernels older than 2.6.30 have"
+ elog "been installed into"
+ elog "${EROOT}usr/share/doc/${P}/patches."
+ elog "For further instructions how to patch the kernel, please refer to"
+ elog "${EROOT}usr/share/doc/${P}/INSTALL."
+ elog
+ fi
+ elog "If you plan on using autofs for automounting remote NFS mounts,"
+ elog "please check that both portmap (or rpcbind) and rpc.statd/lockd"
+ elog "are running."
+}
diff --git a/net-fs/autofs/files/autofs-5.0.6-revert-ldap.patch b/net-fs/autofs/files/autofs-5.0.6-revert-ldap.patch
new file mode 100644
index 000000000000..49901ddfc69b
--- /dev/null
+++ b/net-fs/autofs/files/autofs-5.0.6-revert-ldap.patch
@@ -0,0 +1,18 @@
+--- modules/lookup_ldap.c
++++ modules/lookup_ldap.c
+@@ -1488,6 +1488,7 @@ int lookup_init(const char *mapfmt, int
+ }
+ }
+
++#ifdef WITH_SASL
+ /*
+ * First, check to see if a preferred authentication method was
+ * specified by the user. parse_ldap_config will return error
+@@ -1500,7 +1501,6 @@ int lookup_init(const char *mapfmt, int
+ return 1;
+ }
+
+-#ifdef WITH_SASL
+ /* Init the sasl callbacks */
+ if (!autofs_sasl_client_init(LOGOPT_NONE)) {
+ error(LOGOPT_ANY, "failed to init sasl client");