summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2011-04-03 17:55:17 +0000
committerPeter Volkov <pva@gentoo.org>2011-04-03 17:55:17 +0000
commitbca36acda37295bd739d308840a42542813418ff (patch)
treea3b40305bbe452c6f60b12224807e71667e6d504 /net-fs/autofs
parentRemoved masking of ZendOptimizer as it has been removed from the tree (diff)
downloadgentoo-2-bca36acda37295bd739d308840a42542813418ff.tar.gz
gentoo-2-bca36acda37295bd739d308840a42542813418ff.tar.bz2
gentoo-2-bca36acda37295bd739d308840a42542813418ff.zip
Use proper if-logic in autofs.initd, bug #361787, thank Piotr Mitas for report Dustin Polke for fix
(Portage version: 2.1.9.45/cvs/Linux x86_64)
Diffstat (limited to 'net-fs/autofs')
-rw-r--r--net-fs/autofs/ChangeLog9
-rw-r--r--net-fs/autofs/autofs-5.0.5-r2.ebuild (renamed from net-fs/autofs/autofs-5.0.5-r1.ebuild)2
-rw-r--r--net-fs/autofs/files/autofs5.initd20
3 files changed, 20 insertions, 11 deletions
diff --git a/net-fs/autofs/ChangeLog b/net-fs/autofs/ChangeLog
index 6c9c78c3771b..5e74c8bed438 100644
--- a/net-fs/autofs/ChangeLog
+++ b/net-fs/autofs/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-fs/autofs
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/ChangeLog,v 1.100 2011/04/03 11:16:05 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/ChangeLog,v 1.101 2011/04/03 17:55:17 pva Exp $
+
+*autofs-5.0.5-r2 (03 Apr 2011)
+
+ 03 Apr 2011; Peter Volkov <pva@gentoo.org> files/autofs5.initd,
+ -autofs-5.0.5-r1.ebuild, +autofs-5.0.5-r2.ebuild:
+ Use proper if-logic in autofs.initd, bug #361787, thank Piotr Mitas for
+ report Dustin Polke for fix
03 Apr 2011; Peter Volkov <pva@gentoo.org> -autofs-3.1.7-r5.ebuild,
-autofs-3.1.7-r6.ebuild, -autofs-5.0.4.ebuild, -autofs-5.0.4-r2.ebuild,
diff --git a/net-fs/autofs/autofs-5.0.5-r1.ebuild b/net-fs/autofs/autofs-5.0.5-r2.ebuild
index 0e3836576bac..4c00474db3e2 100644
--- a/net-fs/autofs/autofs-5.0.5-r1.ebuild
+++ b/net-fs/autofs/autofs-5.0.5-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/autofs-5.0.5-r1.ebuild,v 1.1 2011/04/03 09:49:15 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/autofs-5.0.5-r2.ebuild,v 1.1 2011/04/03 17:55:17 pva Exp $
EAPI="4"
inherit eutils multilib autotools linux-info
diff --git a/net-fs/autofs/files/autofs5.initd b/net-fs/autofs/files/autofs5.initd
index 27e15cf654db..73857bc5d8b9 100644
--- a/net-fs/autofs/files/autofs5.initd
+++ b/net-fs/autofs/files/autofs5.initd
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/files/autofs5.initd,v 1.1 2011/04/03 09:49:15 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/files/autofs5.initd,v 1.2 2011/04/03 17:55:17 pva Exp $
DAEMON=/usr/sbin/automount
PIDFILE=/var/run/autofs.pid
@@ -29,18 +29,20 @@ start() {
sleep 1
if [ -e "/proc/misc" ]; then
MINOR=$(awk "/${DEVICE}/ {print \$1}" /proc/misc)
- [ -n "${MINOR}" -a ! -c "/dev/${DEVICE}" ] && \
+ if [ -n "${MINOR}" -a ! -c "/dev/${DEVICE}" ]; then
mknod -m 0600 "/dev/${DEVICE}" c 10 ${MINOR}
- if [ $? -ne 0 ]; then
- eend 1 "Could not create '/dev/${DEVICE}'"
- return 1
+ if [ $? -ne 0 ]; then
+ eend 1 "Could not create '/dev/${DEVICE}'"
+ return 1
+ fi
fi
fi
- [ -x /sbin/restorecon -a -c "/dev/${DEVICE}" ] && \
+ if [ -x /sbin/restorecon -a -c "/dev/${DEVICE}" ]; then
/sbin/restorecon "/dev/${DEVICE}"
- if [ $? -ne 0 ]; then
- eend 1 "Failed to execute '/sbin/restorecon \"/dev/${DEVICE}\"'"
- return 1
+ if [ $? -ne 0 ]; then
+ eend 1 "Failed to execute '/sbin/restorecon \"/dev/${DEVICE}\"'"
+ return 1
+ fi
fi
else
[ -c "/dev/${DEVICE}" ] && rm -rf "/dev/${DEVICE}"