summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2011-04-06 14:10:32 +0000
committerPeter Volkov <pva@gentoo.org>2011-04-06 14:10:32 +0000
commit8deeda98cd123c8b3944937ca55e5c6def28c91e (patch)
treec7309dbf5436b190a33d0585e0b03f7b4dc73a0b /net-fs/autofs
parentVersion bump. (diff)
downloadgentoo-2-8deeda98cd123c8b3944937ca55e5c6def28c91e.tar.gz
gentoo-2-8deeda98cd123c8b3944937ca55e5c6def28c91e.tar.bz2
gentoo-2-8deeda98cd123c8b3944937ca55e5c6def28c91e.zip
Version bump, bug #324961 thank Dustin Polke for this job.
(Portage version: 2.1.9.45/cvs/Linux x86_64)
Diffstat (limited to 'net-fs/autofs')
-rw-r--r--net-fs/autofs/ChangeLog11
-rw-r--r--net-fs/autofs/autofs-4.1.4.ebuild90
-rw-r--r--net-fs/autofs/files/autofs-4.1.4-clean-up-maps.patch68
-rw-r--r--net-fs/autofs/files/autofs-4.1.4-fix-install-ldap-samples-and-maps.patch55
-rw-r--r--net-fs/autofs/files/autofs-4.1.4-fix-man-pages.patch41
-rw-r--r--net-fs/autofs/files/autofs-4.1.4-init.patch13
-rw-r--r--net-fs/autofs/files/autofs-4.1.4-respect-user-flags-and-fix-asneeded.patch140
7 files changed, 417 insertions, 1 deletions
diff --git a/net-fs/autofs/ChangeLog b/net-fs/autofs/ChangeLog
index 5e74c8bed438..00603ceec3b0 100644
--- a/net-fs/autofs/ChangeLog
+++ b/net-fs/autofs/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-fs/autofs
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/ChangeLog,v 1.101 2011/04/03 17:55:17 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/ChangeLog,v 1.102 2011/04/06 14:10:32 pva Exp $
+
+*autofs-4.1.4 (06 Apr 2011)
+
+ 06 Apr 2011; Peter Volkov <pva@gentoo.org> +autofs-4.1.4.ebuild,
+ +files/autofs-4.1.4-clean-up-maps.patch,
+ +files/autofs-4.1.4-fix-install-ldap-samples-and-maps.patch,
+ +files/autofs-4.1.4-fix-man-pages.patch, +files/autofs-4.1.4-init.patch,
+ +files/autofs-4.1.4-respect-user-flags-and-fix-asneeded.patch:
+ Version bump, bug #324961 thank Dustin Polke for this job.
*autofs-5.0.5-r2 (03 Apr 2011)
diff --git a/net-fs/autofs/autofs-4.1.4.ebuild b/net-fs/autofs/autofs-4.1.4.ebuild
new file mode 100644
index 000000000000..b2d56306a6a7
--- /dev/null
+++ b/net-fs/autofs/autofs-4.1.4.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/autofs-4.1.4.ebuild,v 1.1 2011/04/06 14:10:32 pva Exp $
+
+EAPI="4"
+
+inherit eutils multilib autotools
+
+PATCH_VER="1"
+DESCRIPTION="Kernel based automounter"
+HOMEPAGE="http://www.linux-consulting.com/Amd_AutoFS/autofs.html"
+SRC_URI="mirror://kernel/linux/daemons/${PN}/v4/${P}.tar.bz2
+ mirror://gentoo/${P}-patches-${PATCH_VER}.tar.lzma"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="hesiod ldap"
+
+DEPEND="hesiod? ( net-dns/hesiod )
+ ldap? ( >=net-nds/openldap-2.0 )"
+RDEPEND="${DEPEND}"
+
+UPSTREAM_FILESDIR="gentoo/${CATEGORY}/${PN}/files"
+
+src_prepare() {
+ EPATCH_SUFFIX="patch" \
+ epatch "${WORKDIR}"/patches
+
+ # Accumulated fixes for bugs
+ # #154797: Respect CC and CFLAGS
+ # #253412: Respect LDFLAGS
+ # #247969: Link order for --as-needed
+ epatch "${FILESDIR}"/${P}-respect-user-flags-and-fix-asneeded.patch
+
+ # Reflect init script implementation
+ epatch "${FILESDIR}"/${P}-fix-man-pages.patch
+
+ # Use Gentoo specific maps, init script and config file
+ for i in home master misc; do
+ if [ -e samples/auto.${i} ]; then
+ mv samples/auto.${i}{,.bak} || die "Failed to backup auto.${i}"
+ fi
+ ln -s "${S}/${UPSTREAM_FILESDIR}"/auto.${i} samples/auto.${i} || \
+ die "Failed to symlink auto.${i}"
+ done
+
+ # Clean-up maps and disable everything.
+ epatch "${FILESDIR}"/${P}-clean-up-maps.patch
+
+ # Fix installation path of ldap samples and maps
+ epatch "${FILESDIR}"/${P}-fix-install-ldap-samples-and-maps.patch
+
+ epatch "${FILESDIR}"/${P}-init.patch #Fix init script deps
+
+ # Do not include <nfs/nfs.h>, rather <linux/nfs.h>,
+ # as the former is a lame header for the latter (bug #157968)
+ sed 's@nfs/nfs.h@linux/nfs.h@' -i lib/rpc_subs.c || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with ldap openldap) \
+ $(use_with hesiod)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc README* CHANGELOG CREDITS COPYRIGHT
+
+ newinitd ${UPSTREAM_FILESDIR}/${PN}.init ${PN}
+ newconfd ${UPSTREAM_FILESDIR}/${PN}.conf ${PN}
+}
+
+pkg_postinst() {
+ elog "If you plan on using autofs for automounting remote NFS mounts,"
+ elog "please check that both portmap (or rpcbind) and rpc.statd/lockd"
+ elog "are running."
+ elog
+ elog "Also the normal autofs status has been renamed stats"
+ elog "as there is already a predefined Gentoo status"
+ if use ldap; then
+ elog
+ elog "Sample files for ldap have been installed into"
+ elog "${PREFIX}/usr/share/share/doc/${P}/samples."
+ fi
+}
diff --git a/net-fs/autofs/files/autofs-4.1.4-clean-up-maps.patch b/net-fs/autofs/files/autofs-4.1.4-clean-up-maps.patch
new file mode 100644
index 000000000000..51ccf9543baf
--- /dev/null
+++ b/net-fs/autofs/files/autofs-4.1.4-clean-up-maps.patch
@@ -0,0 +1,68 @@
+--- samples/auto.net.old 2010-06-20 22:13:27.049079018 +0200
++++ samples/auto.net 2010-06-20 22:15:31.729124132 +0200
+@@ -1,4 +1,4 @@
+-#!/bin/bash
++#!/bin/sh
+
+ # $Id: autofs-4.1.4-clean-up-maps.patch,v 1.1 2011/04/06 14:10:32 pva Exp $
+
+@@ -11,7 +11,7 @@ key="$1"
+
+ # add "nosymlink" here if you want to suppress symlinking local filesystems
+ # add "nonstrict" to make it OK for some filesystems to not mount
+-opts="-fstype=nfs,hard,intr,nodev,nosuid"
++opts="-fstype=nfs,hard,intr,nodev,nosuid,nonstrict"
+
+ # Showmount comes in a number of names and varieties. "showmount" is
+ # typically an older version which accepts the '--no-headers' flag
+@@ -20,24 +20,14 @@ opts="-fstype=nfs,hard,intr,nodev,nosuid
+ #SHOWMOUNT="kshowmount --no-headers -e $key"
+ #SHOWMOUNT="showmount -e $key | tail -n +2"
+
+-for P in /bin /sbin /usr/bin /usr/sbin
+-do
+- for M in showmount kshowmount
+- do
+- if [ -x $P/$M ]
+- then
+- SMNT=$P/$M
+- break
+- fi
+- done
+-done
++SMNT=/usr/sbin/showmount
+
+ [ -x $SMNT ] || exit 1
+
+ # Newer distributions get this right
+ SHOWMOUNT="$SMNT --no-headers -e $key"
+
+-$SHOWMOUNT | LC_ALL=C sort +0 | \
++$SHOWMOUNT | LC_ALL=C sort -k 1 | \
+ awk -v key="$key" -v opts="$opts" -- '
+ BEGIN { ORS=""; first=1 }
+ { if (first) { print opts; first=0 }; print " \\\n\t" $1, key ":" $1 }
+--- samples/auto.smb.old 2010-06-20 22:10:17.507329273 +0200
++++ samples/auto.smb 2010-06-20 22:15:58.884079957 +0200
+@@ -1,4 +1,4 @@
+-#!/bin/bash
++#!/bin/sh
+
+ # $Id: autofs-4.1.4-clean-up-maps.patch,v 1.1 2011/04/06 14:10:32 pva Exp $
+
+@@ -7,14 +7,7 @@
+ key="$1"
+ opts="-fstype=cifs"
+
+-for P in /bin /sbin /usr/bin /usr/sbin
+-do
+- if [ -x $P/smbclient ]
+- then
+- SMBCLIENT=$P/smbclient
+- break
+- fi
+-done
++SMBCLIENT="/usr/bin/smbclient"
+
+ [ -x $SMBCLIENT ] || exit 1
+
diff --git a/net-fs/autofs/files/autofs-4.1.4-fix-install-ldap-samples-and-maps.patch b/net-fs/autofs/files/autofs-4.1.4-fix-install-ldap-samples-and-maps.patch
new file mode 100644
index 000000000000..02939a7c34b0
--- /dev/null
+++ b/net-fs/autofs/files/autofs-4.1.4-fix-install-ldap-samples-and-maps.patch
@@ -0,0 +1,55 @@
+--- samples/Makefile.old 2010-06-21 16:08:54.916105841 +0200
++++ samples/Makefile 2010-06-21 16:11:52.867934825 +0200
+@@ -13,34 +13,33 @@ endif
+ CFLAGS += -I../include
+ LIBS = -lldap -llber
+
+-all: $(BINS) rc.autofs
++all: $(BINS)
+
+ autofs-ldap-auto-master: $(OBJS)
+ $(CC) $(AUTOFS_LDFLAGS) $(LDFLAGS) -o autofs-ldap-auto-master $(OBJS) $(LIBS)
+
+-rc.autofs: rc.autofs.in
+- sed -e "s|@@sbindir@@|$(sbindir)|g" \
+- -e "s|@@autofslibdir@@|$(autofslibdir)|g" \
+- -e "s|@@initdir@@|$(initdir)|g" < rc.autofs.in > rc.autofs
+-
+ install: all
+- install -d -m 755 $(INSTALLROOT)/etc
+- -mv -f $(INSTALLROOT)/etc/auto.master $(INSTALLROOT)/etc/auto.master.old
+- install -c auto.master -m 644 $(INSTALLROOT)/etc
+- -mv -f $(INSTALLROOT)/etc/auto.misc $(INSTALLROOT)/etc/auto.misc.old
+- install -c auto.misc -m 644 $(INSTALLROOT)/etc
+- -mv -f $(INSTALLROOT)/etc/auto.net $(INSTALLROOT)/etc/auto.net.old
+- install -c auto.net -m 755 $(INSTALLROOT)/etc
+- -mv -f $(INSTALLROOT)/etc/auto.smb $(INSTALLROOT)/etc/auto.smb.old
+- install -c auto.smb -m 755 $(INSTALLROOT)/etc
+- install -d -m 755 $(INSTALLROOT)$(initdir)
+- install -c rc.autofs -m 755 $(INSTALLROOT)$(initdir)/autofs
+- install -d -m 755 $(INSTALLROOT)$(autofslibdir)
++ install -d -m 755 $(INSTALLROOT)/etc/autofs
++ install -c auto.master -m 644 $(INSTALLROOT)/etc/autofs
++ install -c auto.misc -m 644 $(INSTALLROOT)/etc/autofs
++ install -c auto.net -m 755 $(INSTALLROOT)/etc/autofs
++ install -c auto.smb -m 755 $(INSTALLROOT)/etc/autofs
++ install -c auto.home -m 755 $(INSTALLROOT)/etc/autofs
+ install -d -m 755 $(INSTALLROOT)/var/run/autofs
+ ifeq ($(LDAP), 1)
++ install -d -m 755 $(INSTALLROOT)$(autofslibdir)
+ install -c autofs-ldap-auto-master -m 755 $(INSTALLROOT)$(autofslibdir)
++ install -d -m 755 $(INSTALLROOT)/etc/openldap/schema
++ install -c autofs.schema -m 644 $(INSTALLROOT)/etc/openldap/schema
++ install -d -m 755 $(INSTALLROOT)/usr/share/doc/${P}/samples
++ install -c auto.master.ldap -m 644 $(INSTALLROOT)/usr/share/doc/${P}/samples
++ install -c ldap-automount-auto.direct -m 644 $(INSTALLROOT)/usr/share/doc/${P}/samples
++ install -c ldap-automount-auto.indirect -m 644 $(INSTALLROOT)/usr/share/doc/${P}/samples
++ install -c ldap-automount-auto.master -m 644 $(INSTALLROOT)/usr/share/doc/${P}/samples
++ install -c ldap-nis-auto.direct -m 644 $(INSTALLROOT)/usr/share/doc/${P}/samples
++ install -c ldap-nis-auto.indirect -m 644 $(INSTALLROOT)/usr/share/doc/${P}/samples
++ install -c ldap-nis-auto.master -m 644 $(INSTALLROOT)/usr/share/doc/${P}/samples
+ endif
+
+ clean):
+ rm -f *.o *.s autofs-ldap-auto-master rc.autofs
+-
diff --git a/net-fs/autofs/files/autofs-4.1.4-fix-man-pages.patch b/net-fs/autofs/files/autofs-4.1.4-fix-man-pages.patch
new file mode 100644
index 000000000000..ffda7d0f360d
--- /dev/null
+++ b/net-fs/autofs/files/autofs-4.1.4-fix-man-pages.patch
@@ -0,0 +1,41 @@
+--- man/autofs.8.in.old 2005-01-05 11:12:42.000000000 +0100
++++ man/autofs.8.in 2010-05-31 23:10:16.589319809 +0200
+@@ -4,7 +4,7 @@
+ @@INIT.D@@/autofs \- Control Script for automounter
+ .SH SYNOPSIS
+ .B @@INIT.D@@/autofs
+-.I start|stop|reload|status
++.I start|stop|reload|stats|status
+ .SH "DESCRIPTION"
+ .B autofs
+ control the operation of the
+@@ -30,7 +30,7 @@ to find mount points on the system. For
+ .BR automount (8)
+ process is started with the appropriate parameters. You can check the
+ active mount points for the automounter with the
+-.B @@INIT.D@@/autofs status
++.B @@INIT.D@@/autofs stats
+ command. If the
+ .I auto.master
+ configuration file contains a line of the form
+@@ -54,9 +54,12 @@ map is modified then the
+ .B autofs
+ script must be rerun to activate the changes.
+ .P
+-.B @@INIT.D@@/autofs status
++.B @@INIT.D@@/autofs stats
+ will display the current configuration and a list of currently running
+ automount daemons.
++.P
++.B @@INIT.D@@/autofs status
++will display whether automount service is running.
+ .SH "SEE ALSO"
+ .BR automount (8),
+ .BR autofs (5),
+@@ -64,4 +67,5 @@ automount daemons.
+ .SH AUTHOR
+ This manual page was written by Christoph Lameter <chris@waterf.org>,
+ for the Debian GNU/Linux system. Edited by H. Peter Anvin
+-<hpa@transmeta.com>.
++<hpa@transmeta.com>. Edited by D. Polke <dustin.polke@uni-siegen.de> to
++reflect Gentoo's init script implementation.
diff --git a/net-fs/autofs/files/autofs-4.1.4-init.patch b/net-fs/autofs/files/autofs-4.1.4-init.patch
new file mode 100644
index 000000000000..d7ec75164094
--- /dev/null
+++ b/net-fs/autofs/files/autofs-4.1.4-init.patch
@@ -0,0 +1,13 @@
+--- gentoo/net-fs/autofs/files/autofs.init.orig
++++ gentoo/net-fs/autofs/files/autofs.init
+@@ -11,8 +11,8 @@ DAEMON=/usr/sbin/automount
+ SYSCONFDIR=/etc/autofs
+
+ depend() {
+- need localmount portmap
+- use ypbind nfs slapd portmap
++ need localmount
++ use ypbind nfs slapd portmap net
+ }
+
+ opts="start stop status stats reload restart"
diff --git a/net-fs/autofs/files/autofs-4.1.4-respect-user-flags-and-fix-asneeded.patch b/net-fs/autofs/files/autofs-4.1.4-respect-user-flags-and-fix-asneeded.patch
new file mode 100644
index 000000000000..505cf4e8fd44
--- /dev/null
+++ b/net-fs/autofs/files/autofs-4.1.4-respect-user-flags-and-fix-asneeded.patch
@@ -0,0 +1,140 @@
+=== modified file 'Makefile.conf.in'
+--- Makefile.conf.in 2011-04-06 13:55:30 +0000
++++ Makefile.conf.in 2011-04-06 13:56:05 +0000
+@@ -58,3 +58,6 @@
+
+ # Location for init.d files
+ initdir = @initdir@
++
++# Use the compiler detected by configure
++CC := @CC@
+
+=== modified file 'Makefile.rules'
+--- Makefile.rules 2011-04-06 13:55:30 +0000
++++ Makefile.rules 2011-04-06 13:57:27 +0000
+@@ -11,24 +11,20 @@
+ Makefile.conf.in .version .autofs-* configure.in aclocal.m4 \
+ configure *.patch autofs.spec
+
++# Attempt to be friends with autotools
++INSTALLROOT = $(DESTDIR)
++
+ # autofs utility library
+ AUTOFS_LIB = ../lib/autofs.a
+
+ # Compilers, linkers and flags
+-# The STRIP defined here *must not* remove any dynamic-loading symbols
+-
+ ifdef DEBUG
+-CFLAGS = -O2 -g -DDEBUG
+-LDFLAGS = -g
+-STRIP = :
++CFLAGS ?= -O2 -g -DDEBUG
+ else
+-CFLAGS = -O3 -fomit-frame-pointer -Wall
+-LDFLAGS = -s
+-STRIP = strip --strip-debug
++CFLAGS ?= -O3 -fomit-frame-pointer -Wall
+ endif
++AUTOFS_LDFLAGS = -g
+
+-CC = gcc
+-CXX = g++
+ CXXFLAGS = $(CFLAGS)
+ LD = ld
+ SOLDFLAGS = -shared -Xlinker -rpath -Xlinker $(autofslibdir)
+@@ -44,5 +40,4 @@
+ $(CC) $(CFLAGS) -S $<
+
+ .c.so:
+- $(CC) $(SOLDFLAGS) $(CFLAGS) -o $*.so $< $(AUTOFS_LIB)
+- $(STRIP) $*.so
++ $(CC) $(LDFLAGS) $(SOLDFLAGS) $(CFLAGS) -o $*.so $< $(AUTOFS_LIB)
+
+=== modified file 'daemon/Makefile'
+--- daemon/Makefile 2011-04-06 13:55:30 +0000
++++ daemon/Makefile 2011-04-06 13:56:05 +0000
+@@ -12,14 +12,13 @@
+ version := $(shell cat ../.version)
+
+ CFLAGS += -rdynamic $(DAEMON_CFLAGS) -DAUTOFS_LIB_DIR=\"$(autofslibdir)\" -DVERSION_STRING=\"$(version)\" -I../include
+-LDFLAGS += -rdynamic
++AUTOFS_LDFLAGS += -rdynamic
+ LIBS = -ldl
+
+ all: automount
+
+ automount: $(OBJS) $(AUTOFS_LIB)
+- $(CC) $(LDFLAGS) $(DAEMON_LDFLAGS) -o automount $(OBJS) $(AUTOFS_LIB) $(LIBS)
+- $(STRIP) automount
++ $(CC) $(AUTOFS_LDFLAGS) $(DAEMON_LDFLAGS) $(LDFLAGS) -o automount $(OBJS) $(AUTOFS_LIB) $(LIBS)
+
+ clean:
+ rm -f *.o *.s *~ automount
+
+=== modified file 'lib/Makefile'
+--- lib/Makefile 2011-04-06 13:55:30 +0000
++++ lib/Makefile 2011-04-06 13:56:05 +0000
+@@ -35,18 +35,15 @@
+
+ mount_clnt.o: mount_clnt.c
+ $(CC) $(CFLAGS) -o mount_clnt.o -c mount_clnt.c
+- $(STRIP) mount_clnt.o
+
+ mount_xdr.c: mount.h
+ $(RPCGEN) -c -o mount_xdr.c mount.x
+
+ mount_xdr.o: mount_xdr.c
+ $(CC) $(CFLAGS) -Wno-unused-variable -o mount_xdr.o -c mount_xdr.c
+- $(STRIP) mount_xdr.o
+
+ listmount.o: listmount.c
+ $(CC) $(CFLAGS) -o listmount.o -c listmount.c
+- $(STRIP) listmount.o
+
+ install: all
+
+
+=== modified file 'modules/Makefile'
+--- modules/Makefile 2011-04-06 13:55:30 +0000
++++ modules/Makefile 2011-04-06 13:56:42 +0000
+@@ -69,20 +69,16 @@
+ # Ad hoc compilation rules for modules which need auxilliary libraries
+ #
+ lookup_yp.so: lookup_yp.c
+- $(CC) $(SOLDFLAGS) $(CFLAGS) -o lookup_yp.so lookup_yp.c $(AUTOFS_LIB) $(LIBNSL)
+- $(STRIP) lookup_yp.so
++ $(CC) $(LDFLAGS) $(SOLDFLAGS) $(CFLAGS) -o lookup_yp.so lookup_yp.c $(AUTOFS_LIB) $(LIBNSL)
+
+ lookup_nisplus.so: lookup_nisplus.c
+- $(CC) $(SOLDFLAGS) $(CFLAGS) -o lookup_nisplus.so lookup_nisplus.c \
++ $(CC) $(LDFLAGS) $(SOLDFLAGS) $(CFLAGS) -o lookup_nisplus.so lookup_nisplus.c \
+ $(AUTOFS_LIB) $(LIBNSL)
+- $(STRIP) lookup_nisplus.so
+
+ lookup_hesiod.so: lookup_hesiod.c
+- $(CC) $(SOLDFLAGS) $(CFLAGS) $(HESIOD_FLAGS) -o lookup_hesiod.so \
++ $(CC) $(LDFLAGS) $(SOLDFLAGS) $(CFLAGS) $(HESIOD_FLAGS) -o lookup_hesiod.so \
+ lookup_hesiod.c $(AUTOFS_LIB) $(LIBHESIOD) $(LIBRESOLV)
+- $(STRIP) lookup_hesiod.so
+
+ lookup_ldap.so: lookup_ldap.c
+- $(CC) $(SOLDFLAGS) $(CFLAGS) $(LDAP_FLAGS) -o lookup_ldap.so \
++ $(CC) $(LDFLAGS) $(SOLDFLAGS) $(CFLAGS) $(LDAP_FLAGS) -o lookup_ldap.so \
+ lookup_ldap.c $(AUTOFS_LIB) $(LIBLDAP)
+- $(STRIP) lookup_ldap.so
+
+=== modified file 'samples/Makefile'
+--- samples/Makefile 2011-04-06 13:55:30 +0000
++++ samples/Makefile 2011-04-06 13:56:05 +0000
+@@ -16,8 +16,7 @@
+ all: $(BINS) rc.autofs
+
+ autofs-ldap-auto-master: $(OBJS)
+- $(CC) $(LDFLAGS) -o autofs-ldap-auto-master $(OBJS) $(LIBS)
+- $(STRIP) autofs-ldap-auto-master
++ $(CC) $(AUTOFS_LDFLAGS) $(LDFLAGS) -o autofs-ldap-auto-master $(OBJS) $(LIBS)
+
+ rc.autofs: rc.autofs.in
+ sed -e "s|@@sbindir@@|$(sbindir)|g" \
+