summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefaan De Roeck <stefaan@gentoo.org>2008-02-05 12:32:20 +0000
committerStefaan De Roeck <stefaan@gentoo.org>2008-02-05 12:32:20 +0000
commit40364ea673442dc4eadfb6891c2bae82a33428c7 (patch)
treebf92b5217d57e56adbe3ef8d8ba552b1e51ef67c /net-fs/autofs
parentversion bump which incorporates all fixes already done here and uses distfile... (diff)
downloadgentoo-2-40364ea673442dc4eadfb6891c2bae82a33428c7.tar.gz
gentoo-2-40364ea673442dc4eadfb6891c2bae82a33428c7.tar.bz2
gentoo-2-40364ea673442dc4eadfb6891c2bae82a33428c7.zip
Rename file in the tree, specify name in metadata
(Portage version: 2.1.4.1)
Diffstat (limited to 'net-fs/autofs')
-rw-r--r--net-fs/autofs/ChangeLog7
-rw-r--r--net-fs/autofs/autofs-5.0.3-r1.ebuild15
-rw-r--r--net-fs/autofs/autofs-5.0.3.ebuild4
-rw-r--r--net-fs/autofs/files/autofs5.rc1 (renamed from net-fs/autofs/files/autofs.rc14)2
-rw-r--r--net-fs/autofs/metadata.xml3
5 files changed, 24 insertions, 7 deletions
diff --git a/net-fs/autofs/ChangeLog b/net-fs/autofs/ChangeLog
index c02d0c876a81..30d05ba64e9b 100644
--- a/net-fs/autofs/ChangeLog
+++ b/net-fs/autofs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-fs/autofs
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/ChangeLog,v 1.66 2008/02/01 09:07:18 stefaan Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/ChangeLog,v 1.67 2008/02/05 12:32:19 stefaan Exp $
+
+ 05 Feb 2008; Stefaan De Roeck <stefaan@gentoo.org> +files/autofs5.rc1,
+ -files/autofs.rc14, metadata.xml, autofs-5.0.3.ebuild,
+ autofs-5.0.3-r1.ebuild:
+ Rename file in the tree, specify name in metadata
*autofs-5.0.3-r1 (01 Feb 2008)
diff --git a/net-fs/autofs/autofs-5.0.3-r1.ebuild b/net-fs/autofs/autofs-5.0.3-r1.ebuild
index 333775746f81..43ad9fa3ac31 100644
--- a/net-fs/autofs/autofs-5.0.3-r1.ebuild
+++ b/net-fs/autofs/autofs-5.0.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/autofs-5.0.3-r1.ebuild,v 1.1 2008/02/01 09:07:18 stefaan Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/autofs-5.0.3-r1.ebuild,v 1.2 2008/02/05 12:32:19 stefaan Exp $
inherit eutils multilib autotools
@@ -31,9 +31,20 @@ src_unpack() {
cd "${S}"
eautoconf || die "Autoconf failed"
+
+ # # use CC and CFLAGS from environment (bug #154797)
+ # write these values in Makefile.conf
+# (echo "CC := @CC@"; echo "CFLAGS := @CFLAGS@") >> Makefile.conf.in
+ # make sure Makefile.conf is parsed after Makefile.rules
+# sed -ni '/include Makefile.conf/{x; n; G}; p' Makefile
+
+ # do not include <nfs/nfs.h>, rather <linux/nfs.h>,
+ # as the former is a lame header for the latter (bug #157968)
+ sed -i 's@nfs/nfs.h@linux/nfs.h@' include/rpc_subs.h
}
src_compile() {
+ CFLAGS="${CFLAGS}" \
econf \
$(use_with ldap openldap) \
$(use_with sasl) \
@@ -46,7 +57,7 @@ src_compile() {
src_install() {
make DESTDIR="${D}" install || die "make install failed"
- newinitd "${FILESDIR}"/autofs.rc14 autofs
+ newinitd "${FILESDIR}"/autofs5.rc1 autofs
}
pkg_postinst() {
diff --git a/net-fs/autofs/autofs-5.0.3.ebuild b/net-fs/autofs/autofs-5.0.3.ebuild
index 6814a7c9f4d4..4e5cc4532755 100644
--- a/net-fs/autofs/autofs-5.0.3.ebuild
+++ b/net-fs/autofs/autofs-5.0.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/autofs-5.0.3.ebuild,v 1.1 2008/01/31 23:19:24 stefaan Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/autofs-5.0.3.ebuild,v 1.2 2008/02/05 12:32:19 stefaan Exp $
inherit eutils multilib autotools
@@ -39,7 +39,7 @@ src_compile() {
src_install() {
make DESTDIR="${D}" install || die "make install failed"
- newinitd "${FILESDIR}"/autofs.rc14 autofs
+ newinitd "${FILESDIR}"/autofs5.rc1 autofs
}
pkg_postinst() {
diff --git a/net-fs/autofs/files/autofs.rc14 b/net-fs/autofs/files/autofs5.rc1
index 948e9242f761..9e4252adf3ea 100644
--- a/net-fs/autofs/files/autofs.rc14
+++ b/net-fs/autofs/files/autofs5.rc1
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/files/autofs.rc14,v 1.1 2008/01/31 23:19:25 stefaan Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/files/autofs5.rc1,v 1.1 2008/02/05 12:32:20 stefaan Exp $
DAEMON=/usr/sbin/automount
PIDFILE=/var/run/autofs.pid
diff --git a/net-fs/autofs/metadata.xml b/net-fs/autofs/metadata.xml
index 9e24abe6169e..b3cc0332d3b8 100644
--- a/net-fs/autofs/metadata.xml
+++ b/net-fs/autofs/metadata.xml
@@ -3,6 +3,7 @@
<pkgmetadata>
<herd>net-fs</herd>
<maintainer>
- <email>stefaan@gentoo.org</email>
+ <email>stefaan@gentoo.org</email>
+ <name>Stefaan De Roeck</name>
</maintainer>
</pkgmetadata>