summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2008-04-05 10:24:24 +0000
committerCédric Krier <cedk@gentoo.org>2008-04-05 10:24:24 +0000
commitf9554c18e3226ef3c427da2f966a316998d3cda4 (patch)
treebb010eb015015cedbc0b3c1e55033c8433dfea14 /net-firewall
parentCall base_src_unpack explicitly in src_unpack. Fixes bug #207361. (diff)
downloadgentoo-2-f9554c18e3226ef3c427da2f966a316998d3cda4.tar.gz
gentoo-2-f9554c18e3226ef3c427da2f966a316998d3cda4.tar.bz2
gentoo-2-f9554c18e3226ef3c427da2f966a316998d3cda4.zip
Version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/nufw/ChangeLog7
-rw-r--r--net-firewall/nufw/nufw-2.2.14.ebuild107
2 files changed, 113 insertions, 1 deletions
diff --git a/net-firewall/nufw/ChangeLog b/net-firewall/nufw/ChangeLog
index 436ae765538f..28ff24fb5048 100644
--- a/net-firewall/nufw/ChangeLog
+++ b/net-firewall/nufw/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-firewall/nufw
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/nufw/ChangeLog,v 1.28 2008/03/28 00:10:19 cedk Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/nufw/ChangeLog,v 1.29 2008/04/05 10:24:24 cedk Exp $
+
+*nufw-2.2.14 (05 Apr 2008)
+
+ 05 Apr 2008; Cédric Krier <cedk@gentoo.org> +nufw-2.2.14.ebuild:
+ Version bump
*nufw-2.2.13 (28 Mar 2008)
diff --git a/net-firewall/nufw/nufw-2.2.14.ebuild b/net-firewall/nufw/nufw-2.2.14.ebuild
new file mode 100644
index 000000000000..253ad6d0edb8
--- /dev/null
+++ b/net-firewall/nufw/nufw-2.2.14.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/nufw/nufw-2.2.14.ebuild,v 1.1 2008/04/05 10:24:24 cedk Exp $
+
+inherit autotools ssl-cert eutils pam
+
+DESCRIPTION="An enterprise grade authenticating firewall based on netfilter"
+HOMEPAGE="http://www.nufw.org/"
+SRC_URI="http://www.nufw.org/download/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="debug ldap mysql pam pam_nuauth plaintext postgres prelude \
+unicode nfqueue nfconntrack static syslog test"
+
+DEPEND=">=dev-libs/glib-2
+ dev-libs/libgcrypt
+ >=dev-libs/cyrus-sasl-2
+ net-firewall/iptables
+ >=net-libs/gnutls-1.1
+ ldap? ( >=net-nds/openldap-2 )
+ mysql? ( virtual/mysql )
+ pam? ( sys-libs/pam )
+ pam_nuauth? ( sys-libs/pam )
+ postgres? ( dev-db/postgresql )
+ nfqueue? ( net-libs/libnfnetlink
+ net-libs/libnetfilter_queue )
+ nfconntrack? ( net-libs/libnetfilter_conntrack )
+ prelude? ( dev-libs/libprelude )
+ dev-python/ipy"
+RDEPEND=${DEPEND}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e 's:^#\(nuauth_tls_key="/etc/nufw/\)nuauth-key.pem:\1nuauth.key:' \
+ -e 's:^#\(nuauth_tls_cert="/etc/nufw/\)nuauth-cert.pem:\1nuauth.pem:' \
+ conf/nuauth.conf || die "sed failed"
+ epatch "${FILESDIR}"/${PN}-2.2.13-destdir.patch
+
+ # This tests require inl_tests to be installed. We don't have it now in our
+ # tree so we disable them for now... for more information see tests/README
+ use test && sed -i "s:\(^TESTS=test_all.py\):#\1:" tests/Makefile.am
+
+ eautoreconf
+}
+
+src_compile() {
+ econf \
+ --with-shared \
+ $(use_enable static) \
+ $(use_enable pam_nuauth pam-nuauth) \
+ $(use_with prelude prelude-log) \
+ $(use_with mysql mysql-log) \
+ $(use_with mysql mysql-auth) \
+ $(use_with postgres pgsql-log) \
+ $(use_with syslog syslog-log) \
+ $(use_with plaintext plaintext-auth) \
+ --with-mark-group \
+ $(use_with pam system-auth) \
+ $(use_with ldap) \
+ $(use_with nfqueue) \
+ $(use_with nfconntrack) \
+ $(use_with unicode utf8) \
+ $(use_enable debug) \
+ --sysconfdir="/etc/nufw" \
+ --localstatedir="/var" \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_test() {
+ ewarn "Some tests are skiped! If you wish to run them read tests/README and"
+ ewarn "do that manually."
+ ebeep 5
+ make check
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ newinitd "${FILESDIR}"/nufw-init.d nufw
+ newconfd "${FILESDIR}"/nufw-conf.d nufw
+
+ newinitd "${FILESDIR}"/nuauth-init.d nuauth
+ newconfd "${FILESDIR}"/nuauth-conf.d nuauth
+
+ insinto /etc/nufw
+ doins conf/nuauth.conf
+ keepdir /var/run/nuauth
+
+ dodoc AUTHORS ChangeLog NEWS README TODO
+ docinto scripts
+ dodoc scripts/{clean_conntrack.pl,nuaclgen,nutop,README,ulog_rotate_daily.sh,ulog_rotate_weekly.sh}
+ docinto conf
+ dodoc conf/*.{nufw,schema,conf,dump,xml}
+
+ if use pam; then
+ pamd_mimic system-auth nufw auth account password session
+ fi
+}
+
+pkg_postinst() {
+ install_cert /etc/nufw/{nufw,nuauth}
+}