summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-12-19 19:16:43 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-12-19 19:16:43 +0000
commit5b5fb85744a846e1efba638de5a0cd238bd12d06 (patch)
treecf56c0ace7635aa5dfb58121f6ab2d4573c386a3 /net-firewall
parentVersion bump. (diff)
downloadgentoo-2-5b5fb85744a846e1efba638de5a0cd238bd12d06.tar.gz
gentoo-2-5b5fb85744a846e1efba638de5a0cd238bd12d06.tar.bz2
gentoo-2-5b5fb85744a846e1efba638de5a0cd238bd12d06.zip
Revision bump: add compatibility patch for kernel 3.11. Drop old
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/ipt_netflow/ChangeLog9
-rw-r--r--net-firewall/ipt_netflow/files/ipt_netflow-1.8-numphyspages-fix.patch20
-rw-r--r--net-firewall/ipt_netflow/ipt_netflow-1.8-r1.ebuild63
-rw-r--r--net-firewall/ipt_netflow/ipt_netflow-1.8-r4.ebuild (renamed from net-firewall/ipt_netflow/ipt_netflow-1.8-r2.ebuild)8
4 files changed, 35 insertions, 65 deletions
diff --git a/net-firewall/ipt_netflow/ChangeLog b/net-firewall/ipt_netflow/ChangeLog
index 37bd344af642..39ebfba141c4 100644
--- a/net-firewall/ipt_netflow/ChangeLog
+++ b/net-firewall/ipt_netflow/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-firewall/ipt_netflow
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipt_netflow/ChangeLog,v 1.11 2013/09/04 09:11:47 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipt_netflow/ChangeLog,v 1.12 2013/12/19 19:16:43 pinkbyte Exp $
+
+*ipt_netflow-1.8-r4 (19 Dec 2013)
+
+ 19 Dec 2013; Sergey Popov <pinkbyte@gentoo.org> -ipt_netflow-1.8-r1.ebuild,
+ -ipt_netflow-1.8-r2.ebuild, +ipt_netflow-1.8-r4.ebuild,
+ +files/ipt_netflow-1.8-numphyspages-fix.patch:
+ Revision bump: add compatibility patch for kernel 3.11. Drop old
04 Sep 2013; Sergey Popov <pinkbyte@gentoo.org>
files/ipt_netflow-1.8-procfs-fix.patch:
diff --git a/net-firewall/ipt_netflow/files/ipt_netflow-1.8-numphyspages-fix.patch b/net-firewall/ipt_netflow/files/ipt_netflow-1.8-numphyspages-fix.patch
new file mode 100644
index 000000000000..b64980f02666
--- /dev/null
+++ b/net-firewall/ipt_netflow/files/ipt_netflow-1.8-numphyspages-fix.patch
@@ -0,0 +1,20 @@
+commit 76c1610c10f863e4f8b38e88af60044b42b79422
+Author: ABC <abc@telekom.ru>
+Date: Mon Sep 30 11:07:07 2013 +0400
+
+ num_physpages to totalram_pages rename for linux 3.11
+
+diff --git a/ipt_NETFLOW.c b/ipt_NETFLOW.c
+index 5ec725d..71d4087 100644
+--- a/ipt_NETFLOW.c
++++ b/ipt_NETFLOW.c
+@@ -2025,6 +2025,9 @@ static int __init ipt_netflow_init(void)
+
+ /* determine hash size (idea from nf_conntrack_core.c) */
+ if (!hashsize) {
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(3,11,0)
++#define num_physpages totalram_pages
++#endif
+ hashsize = (((num_physpages << PAGE_SHIFT) / 16384)
+ / sizeof(struct hlist_head));
+ if (num_physpages > (1024 * 1024 * 1024 / PAGE_SIZE))
diff --git a/net-firewall/ipt_netflow/ipt_netflow-1.8-r1.ebuild b/net-firewall/ipt_netflow/ipt_netflow-1.8-r1.ebuild
deleted file mode 100644
index 6de3d3007650..000000000000
--- a/net-firewall/ipt_netflow/ipt_netflow-1.8-r1.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipt_netflow/ipt_netflow-1.8-r1.ebuild,v 1.5 2013/04/16 16:53:57 ago Exp $
-
-EAPI="5"
-
-inherit eutils linux-info linux-mod multilib toolchain-funcs
-
-MY_PN="ipt-netflow"
-
-DESCRIPTION="Netflow iptables module"
-HOMEPAGE="http://sourceforge.net/projects/ipt-netflow"
-SRC_URI="mirror://sourceforge/${MY_PN}/${P}.tgz"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-
-RDEPEND="net-firewall/iptables"
-DEPEND="${RDEPEND}
- virtual/linux-sources
- virtual/pkgconfig"
-
-BUILD_TARGETS="all"
-CONFIG_CHECK="~IP_NF_IPTABLES"
-MODULE_NAMES="ipt_NETFLOW(ipt_netflow:${S})"
-
-IPT_LIB=/usr/$(get_libdir)/xtables
-
-src_prepare() {
- sed -i -e 's:-I$(KDIR)/include::' \
- -e 's:gcc -O2:$(CC) $(CFLAGS) $(LDFLAGS):' \
- -e 's:gcc:$(CC) $(CFLAGS) $(LDFLAGS):' Makefile.in || die 'sed on Makefile.in failed'
- sed -i -e '/IPT_NETFLOW_VERSION/s/1.7.2/1.8/' ipt_NETFLOW.c || die 'sed on ipt_NETFLOW.c failed'
- epatch "${FILESDIR}"/${PN}-1.8-configure.patch
-}
-
-src_configure() {
- local IPT_VERSION="$($(tc-getPKG_CONFIG) --modversion xtables)"
- # econf can not be used, cause configure script fails when see unknown parameter
- # ipt-src need to be defined, see bug #455984
- ./configure \
- --ipt-lib="${IPT_LIB}" \
- --ipt-src="/usr/" \
- --ipt-ver="${IPT_VERSION}" \
- --kdir="${KV_DIR}" \
- --kver="${KV_FULL}" \
- || die 'configure failed'
-}
-
-src_compile() {
- local ARCH=$(tc-arch-kernel)
- emake CC="$(tc-getCC)" all
-}
-
-src_install() {
- linux-mod_src_install
- exeinto "${IPT_LIB}"
- doexe libipt_NETFLOW.so
- insinto /usr/include
- doins ipt_NETFLOW.h
- dodoc README*
-}
diff --git a/net-firewall/ipt_netflow/ipt_netflow-1.8-r2.ebuild b/net-firewall/ipt_netflow/ipt_netflow-1.8-r4.ebuild
index ec68ef03317d..1bf35093bdec 100644
--- a/net-firewall/ipt_netflow/ipt_netflow-1.8-r2.ebuild
+++ b/net-firewall/ipt_netflow/ipt_netflow-1.8-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipt_netflow/ipt_netflow-1.8-r2.ebuild,v 1.1 2013/06/27 03:52:41 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipt_netflow/ipt_netflow-1.8-r4.ebuild,v 1.1 2013/12/19 19:16:43 pinkbyte Exp $
EAPI="5"
@@ -36,6 +36,12 @@ src_prepare() {
# bug #455984
epatch "${FILESDIR}"/${PN}-1.8-configure.patch
+ # compatibility with 3.10 kernel
+ epatch "${FILESDIR}"/${PN}-1.8-procfs-fix.patch
+
+ # compatibility with 3.11 kernel
+ epatch "${FILESDIR}"/${PN}-1.8-numphyspages-fix.patch
+
# bug #466430
if use pax_kernel; then
epatch "${FILESDIR}"/${PN}-1.8-pax-const.patch