summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-12-18 16:00:01 +0000
committerMike Frysinger <vapier@gentoo.org>2009-12-18 16:00:01 +0000
commit5a2a255533ac64e5148ec696b8094fd88acfc2f3 (patch)
tree83fcd1482107e747a7c626d35d7504153023878f /net-firewall
parentold (diff)
downloadgentoo-2-5a2a255533ac64e5148ec696b8094fd88acfc2f3.tar.gz
gentoo-2-5a2a255533ac64e5148ec696b8094fd88acfc2f3.tar.bz2
gentoo-2-5a2a255533ac64e5148ec696b8094fd88acfc2f3.zip
Version bump #297365 by Milos Ivanovic.
(Portage version: 2.2_rc55/cvs/Linux x86_64)
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/iptables/ChangeLog7
-rw-r--r--net-firewall/iptables/iptables-1.4.6.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/net-firewall/iptables/ChangeLog b/net-firewall/iptables/ChangeLog
index 6d0615f4e97b..fd7ecca66948 100644
--- a/net-firewall/iptables/ChangeLog
+++ b/net-firewall/iptables/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-firewall/iptables
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/ChangeLog,v 1.207 2009/09/23 20:32:15 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/ChangeLog,v 1.208 2009/12/18 16:00:01 vapier Exp $
+
+*iptables-1.4.6 (18 Dec 2009)
+
+ 18 Dec 2009; Mike Frysinger <vapier@gentoo.org> +iptables-1.4.6.ebuild:
+ Version bump #297365 by Milos Ivanovic.
*iptables-1.4.5 (23 Sep 2009)
diff --git a/net-firewall/iptables/iptables-1.4.6.ebuild b/net-firewall/iptables/iptables-1.4.6.ebuild
new file mode 100644
index 000000000000..1daf286ba5e3
--- /dev/null
+++ b/net-firewall/iptables/iptables-1.4.6.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.4.6.ebuild,v 1.1 2009/12/18 16:00:01 vapier Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Linux kernel (2.4+) firewall, NAT and packet mangling tools"
+HOMEPAGE="http://www.iptables.org/"
+SRC_URI="http://iptables.org/projects/iptables/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="ipv6"
+
+DEPEND="virtual/os-headers"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${P}.tar.bz2
+ cd "${S}"
+ epatch_user
+}
+
+src_compile() {
+ econf \
+ --sbindir=/sbin \
+ --libexecdir=/$(get_libdir) \
+ --enable-devel \
+ --enable-libipq \
+ --enable-shared \
+ --enable-static \
+ $(use_enable ipv6)
+ emake V=1 || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+
+ insinto /usr/include
+ doins include/iptables.h $(use ipv6 && echo include/ip6tables.h) || die
+ insinto /usr/include/iptables
+ doins include/iptables/internal.h || die
+
+ keepdir /var/lib/iptables
+ newinitd "${FILESDIR}"/${PN}-1.3.2.init iptables || die
+ newconfd "${FILESDIR}"/${PN}-1.3.2.confd iptables || die
+ if use ipv6 ; then
+ keepdir /var/lib/ip6tables
+ newinitd "${FILESDIR}"/iptables-1.3.2.init ip6tables || die
+ newconfd "${FILESDIR}"/ip6tables-1.3.2.confd ip6tables || die
+ fi
+}