summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-07-27 18:16:07 +0000
committerMike Frysinger <vapier@gentoo.org>2009-07-27 18:16:07 +0000
commit4c508f83ad1eeb3e0518011027e161b1efcb052d (patch)
tree68e62b129b545363df789cc65094e1771083c601 /net-firewall
parentVersion bump, as requested by Jan Aniŝĉuk in bug #266402. Taking maintainer... (diff)
downloadgentoo-2-4c508f83ad1eeb3e0518011027e161b1efcb052d.tar.gz
gentoo-2-4c508f83ad1eeb3e0518011027e161b1efcb052d.tar.bz2
gentoo-2-4c508f83ad1eeb3e0518011027e161b1efcb052d.zip
Add USE=ipv6 support by Christian Affolter #277366.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/iptables/ChangeLog5
-rw-r--r--net-firewall/iptables/iptables-1.4.4.ebuild17
2 files changed, 14 insertions, 8 deletions
diff --git a/net-firewall/iptables/ChangeLog b/net-firewall/iptables/ChangeLog
index 21d8ff4954e8..4cb02ab02ff0 100644
--- a/net-firewall/iptables/ChangeLog
+++ b/net-firewall/iptables/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-firewall/iptables
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/ChangeLog,v 1.203 2009/07/23 14:59:47 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/ChangeLog,v 1.204 2009/07/27 18:16:07 vapier Exp $
+
+ 27 Jul 2009; Mike Frysinger <vapier@gentoo.org> iptables-1.4.4.ebuild:
+ Add USE=ipv6 support by Christian Affolter #277366.
23 Jul 2009; Raúl Porcel <armin76@gentoo.org> iptables-1.4.3.2.ebuild:
arm/ia64/m68k/s390/sh/sparc stable wrt #274403
diff --git a/net-firewall/iptables/iptables-1.4.4.ebuild b/net-firewall/iptables/iptables-1.4.4.ebuild
index 87dd2f2975e9..268f56878c59 100644
--- a/net-firewall/iptables/iptables-1.4.4.ebuild
+++ b/net-firewall/iptables/iptables-1.4.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.4.4.ebuild,v 1.1 2009/06/17 06:46:45 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.4.4.ebuild,v 1.2 2009/07/27 18:16:07 vapier Exp $
inherit eutils toolchain-funcs
@@ -11,7 +11,7 @@ SRC_URI="http://iptables.org/projects/iptables/files/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE=""
+IUSE="ipv6"
DEPEND="virtual/os-headers"
RDEPEND=""
@@ -42,7 +42,8 @@ src_compile() {
--enable-devel \
--enable-libipq \
--enable-shared \
- --enable-static
+ --enable-static \
+ $(use_enable ipv6)
emake V=1 || die
}
@@ -50,14 +51,16 @@ src_install() {
emake install DESTDIR="${D}" || die
insinto /usr/include
- doins include/iptables.h include/ip6tables.h || die
+ doins include/iptables.h $(use ipv6 && echo include/ip6tables.h) || die
insinto /usr/include/iptables
doins include/iptables/internal.h || die
keepdir /var/lib/iptables
newinitd "${FILESDIR}"/${PN}-1.3.2.init iptables || die
newconfd "${FILESDIR}"/${PN}-1.3.2.confd iptables || die
- keepdir /var/lib/ip6tables
- newinitd "${FILESDIR}"/iptables-1.3.2.init ip6tables || die
- newconfd "${FILESDIR}"/ip6tables-1.3.2.confd ip6tables || die
+ if use ipv6 ; then
+ keepdir /var/lib/ip6tables
+ newinitd "${FILESDIR}"/iptables-1.3.2.init ip6tables || die
+ newconfd "${FILESDIR}"/ip6tables-1.3.2.confd ip6tables || die
+ fi
}