summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-07-07 19:50:24 +0000
committerTim Harder <radhermit@gentoo.org>2013-07-07 19:50:24 +0000
commit4503e318e715a7a26f67fa0eb26468d8c7dd0078 (patch)
tree89296ad09a2661963f087efb0ce9a898a6f1fb2c /net-firewall
parentsci-biology/mira: Version BUmp; fixed compilation with dev-libs/boost-1.53.0 ... (diff)
downloadgentoo-2-4503e318e715a7a26f67fa0eb26468d8c7dd0078.tar.gz
gentoo-2-4503e318e715a7a26f67fa0eb26468d8c7dd0078.tar.bz2
gentoo-2-4503e318e715a7a26f67fa0eb26468d8c7dd0078.zip
Version bump.
(Portage version: 2.2.0_alpha186/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/sanewall/ChangeLog7
-rw-r--r--net-firewall/sanewall/sanewall-1.1.4.ebuild57
2 files changed, 63 insertions, 1 deletions
diff --git a/net-firewall/sanewall/ChangeLog b/net-firewall/sanewall/ChangeLog
index 7cddeadec663..2c2aad5d8d2f 100644
--- a/net-firewall/sanewall/ChangeLog
+++ b/net-firewall/sanewall/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-firewall/sanewall
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/sanewall/ChangeLog,v 1.1 2013/06/15 11:07:43 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/sanewall/ChangeLog,v 1.2 2013/07/07 19:50:24 radhermit Exp $
+
+*sanewall-1.1.4 (07 Jul 2013)
+
+ 07 Jul 2013; Tim Harder <radhermit@gentoo.org> +sanewall-1.1.4.ebuild:
+ Version bump.
*sanewall-1.1.3 (15 Jun 2013)
diff --git a/net-firewall/sanewall/sanewall-1.1.4.ebuild b/net-firewall/sanewall/sanewall-1.1.4.ebuild
new file mode 100644
index 000000000000..fb010c1d938c
--- /dev/null
+++ b/net-firewall/sanewall/sanewall-1.1.4.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/sanewall/sanewall-1.1.4.ebuild,v 1.1 2013/07/07 19:50:24 radhermit Exp $
+
+EAPI=5
+
+inherit linux-info
+
+DESCRIPTION="iptables firewall generator (fork of firehol)"
+HOMEPAGE="http://www.sanewall.org/"
+SRC_URI="http://download.sanewall.org/releases/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="app-arch/xz-utils"
+RDEPEND="net-firewall/iptables
+ sys-apps/iproute2[-minimal]
+ virtual/modutils
+ || (
+ net-misc/wget
+ net-misc/curl
+ )"
+
+pkg_setup() {
+ local KCONFIG_OPTS="~NF_CONNTRACK_IPV4 ~NF_CONNTRACK_MARK ~NF_NAT ~NF_NAT_FTP ~NF_NAT_IRC \
+ ~IP_NF_IPTABLES ~IP_NF_FILTER ~IP_NF_TARGET_REJECT ~IP_NF_TARGET_LOG ~IP_NF_TARGET_ULOG \
+ ~IP_NF_TARGET_MASQUERADE ~IP_NF_TARGET_REDIRECT ~IP_NF_MANGLE \
+ ~NETFILTER_XT_MATCH_LIMIT ~NETFILTER_XT_MATCH_STATE ~NETFILTER_XT_MATCH_OWNER"
+
+ get_version
+ if [[ ${KV_PATCH} -ge 25 ]] ; then
+ CONFIG_CHECK="~NF_CONNTRACK ${KCONFIG_OPTS}"
+ else
+ CONFIG_CHECK="~NF_CONNTRACK_ENABLED ${KCONFIG_OPTS}"
+ fi
+ linux-info_pkg_setup
+}
+
+src_configure() {
+ econf --docdir="/usr/share/doc/${PF}"
+}
+
+src_install() {
+ default
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+}
+
+pkg_postinst() {
+ # install default configuration if it doesn't exist
+ if [[ ! -e "${ROOT}"/etc/${PN}/${PN}.conf ]] ; then
+ einfo "Installing a sample configuration to ${ROOT}/etc/${PN}/${PN}.conf"
+ cp "${ROOT}"/etc/${PN}/${PN}.conf.example "${ROOT}"/etc/${PN}/${PN}.conf || die
+ fi
+}