summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConstanze Hausner <constanze@gentoo.org>2012-01-03 08:50:02 +0000
committerConstanze Hausner <constanze@gentoo.org>2012-01-03 08:50:02 +0000
commit2936c5df2b3622f1052a88babc8fba111dcd88f1 (patch)
tree9a46da469021aefdf94f3e4b449a074a599f24ee /net-firewall
parentVersion Bump (diff)
downloadgentoo-2-2936c5df2b3622f1052a88babc8fba111dcd88f1.tar.gz
gentoo-2-2936c5df2b3622f1052a88babc8fba111dcd88f1.tar.bz2
gentoo-2-2936c5df2b3622f1052a88babc8fba111dcd88f1.zip
Version Bump
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/shorewall6/ChangeLog10
-rw-r--r--net-firewall/shorewall6/shorewall6-4.4.27.ebuild58
2 files changed, 66 insertions, 2 deletions
diff --git a/net-firewall/shorewall6/ChangeLog b/net-firewall/shorewall6/ChangeLog
index 26114185359e..beea9c9a1d1b 100644
--- a/net-firewall/shorewall6/ChangeLog
+++ b/net-firewall/shorewall6/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-firewall/shorewall6
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall6/ChangeLog,v 1.46 2011/11/13 14:57:20 maekke Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall6/ChangeLog,v 1.47 2012/01/03 08:50:02 constanze Exp $
+
+*shorewall6-4.4.27 (03 Jan 2012)
+
+ 03 Jan 2012; Constanze Hausner <constanze@gentoo.org>
+ +shorewall6-4.4.27.ebuild:
+ Version bump
13 Nov 2011; Markus Meier <maekke@gentoo.org> shorewall6-4.4.23.2.ebuild:
x86 stable, bug #388195
diff --git a/net-firewall/shorewall6/shorewall6-4.4.27.ebuild b/net-firewall/shorewall6/shorewall6-4.4.27.ebuild
new file mode 100644
index 000000000000..dede1e0d98de
--- /dev/null
+++ b/net-firewall/shorewall6/shorewall6-4.4.27.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall6/shorewall6-4.4.27.ebuild,v 1.1 2012/01/03 08:50:02 constanze Exp $
+
+EAPI="4"
+
+inherit versionator linux-info
+
+# Select version (stable, RC, Beta, upstream patched):
+MY_PV_TREE=$(get_version_component_range 1-2) # for devel versions use "development/$(get_version_component_range 1-2)"
+MY_PV_BASE=$(get_version_component_range 1-3) # which shorewall-common to use
+
+MY_PN="${PN/6/}"
+MY_P="${MY_PN}-${MY_PV_BASE}"
+MY_P_DOCS="${MY_PN}-docs-html-${PV}"
+
+DESCRIPTION="Shoreline Firewall with IPv6 support."
+HOMEPAGE="http://www.shorewall.net/"
+SRC_URI="http://www1.shorewall.net/pub/${MY_PN}/${MY_PV_TREE}/${MY_P}/${P}.tar.bz2
+ doc? ( http://www1.shorewall.net/pub/${PN}/${MY_PV_TREE}/${MY_P}/${MY_P_DOCS}.tar.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="doc"
+
+RDEPEND=">=net-firewall/iptables-1.4.0
+ sys-apps/iproute2
+ >=net-firewall/shorewall-${MY_PV_BASE}
+ dev-perl/Socket6"
+
+pkg_pretend() {
+ if kernel_is lt 2 6 25 ; then
+ die "${PN} requires at least kernel 2.6.25."
+ fi
+}
+
+src_compile() {
+ # The default make command does not work as expected
+ :
+}
+
+src_install() {
+ keepdir /var/lib/${PN}
+
+ cd "${WORKDIR}/${P}"
+ PREFIX="${D}" ./install.sh || die "install.sh failed"
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+
+ dodoc changelog.txt releasenotes.txt
+ if use doc; then
+ dodoc -r Samples6
+ cd "${WORKDIR}/${MY_P_DOCS}"
+ dohtml -r *
+ fi
+ keepdir /var/lock/subsys
+}