summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaweł Hajdan <phajdan.jr@gentoo.org>2011-11-06 16:30:17 +0000
committerPaweł Hajdan <phajdan.jr@gentoo.org>2011-11-06 16:30:17 +0000
commit18774a3bc3aea292b22519cc3ea2defb8a940488 (patch)
treec1af8695d5b404a1f7b7b7ac3e2af595c364070b /net-firewall
parentMarking claws-mail-3.7.10 ppc for bug 387547 (diff)
downloadgentoo-2-18774a3bc3aea292b22519cc3ea2defb8a940488.tar.gz
gentoo-2-18774a3bc3aea292b22519cc3ea2defb8a940488.tar.bz2
gentoo-2-18774a3bc3aea292b22519cc3ea2defb8a940488.zip
Cleanup: bump to EAPI-4, make kernel-related error message more accurate and informative, fix dodoc QA warnings (bug #377235 by flameeyes).
(Portage version: 2.1.10.11/cvs/Linux i686)
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/ipsec-tools/ChangeLog7
-rw-r--r--net-firewall/ipsec-tools/ipsec-tools-0.7.3-r1.ebuild110
2 files changed, 57 insertions, 60 deletions
diff --git a/net-firewall/ipsec-tools/ChangeLog b/net-firewall/ipsec-tools/ChangeLog
index 8ae3f0f70de3..32a2a0b687f6 100644
--- a/net-firewall/ipsec-tools/ChangeLog
+++ b/net-firewall/ipsec-tools/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-firewall/ipsec-tools
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipsec-tools/ChangeLog,v 1.77 2011/06/06 00:24:56 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipsec-tools/ChangeLog,v 1.78 2011/11/06 16:30:17 phajdan.jr Exp $
+
+ 06 Nov 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
+ ipsec-tools-0.7.3-r1.ebuild:
+ Cleanup: bump to EAPI-4, make kernel-related error message more accurate and
+ informative, fix dodoc QA warnings (bug #377235 by flameeyes).
06 Jun 2011; Robin H. Johnson <robbat2@gentoo.org> ipsec-tools-0.7.3.ebuild,
ipsec-tools-0.7.3-r1.ebuild:
diff --git a/net-firewall/ipsec-tools/ipsec-tools-0.7.3-r1.ebuild b/net-firewall/ipsec-tools/ipsec-tools-0.7.3-r1.ebuild
index eb77f7159440..400a6d972986 100644
--- a/net-firewall/ipsec-tools/ipsec-tools-0.7.3-r1.ebuild
+++ b/net-firewall/ipsec-tools/ipsec-tools-0.7.3-r1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipsec-tools/ipsec-tools-0.7.3-r1.ebuild,v 1.4 2011/06/06 00:24:56 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipsec-tools/ipsec-tools-0.7.3-r1.ebuild,v 1.5 2011/11/06 16:30:17 phajdan.jr Exp $
+
+EAPI="4"
inherit eutils flag-o-matic autotools linux-info
@@ -31,66 +33,61 @@ DEPEND="${DEPEND_COMMON}
pkg_setup() {
get_version
- if kernel_is -ge 2 6 ; then
- if test "${KV_PATCH}" -ge 19 ; then
- # Just for kernel >=2.6.19
- einfo "Checking for suitable kernel configuration (Networking | Networking support | Networking options)"
-
- if use nat; then
- CONFIG_CHECK="${CONFIG_CHECK} ~NETFILTER_XT_MATCH_POLICY"
- export WARNING_NETFILTER_XT_MATCH_POLICY="NAT support may fail weirdly unless you enable this option in your kernel"
- fi
-
- for i in XFRM_USER NET_KEY; do
- CONFIG_CHECK="${CONFIG_CHECK} ~${i}"
- eval "export WARNING_${i}='No tunnels will be available at all'"
- done
-
- for i in INET_IPCOMP INET_AH INET_ESP \
- INET_XFRM_MODE_TRANSPORT \
- INET_XFRM_MODE_TUNNEL \
- INET_XFRM_MODE_BEET ; do
- CONFIG_CHECK="${CONFIG_CHECK} ~${i}"
- eval "export WARNING_${i}='IPv4 tunnels will not be available'"
- done
-
- for i in INET6_IPCOMP INET6_AH INET6_ESP \
- INET6_XFRM_MODE_TRANSPORT \
- INET6_XFRM_MODE_TUNNEL \
- INET6_XFRM_MODE_BEET ; do
- CONFIG_CHECK="${CONFIG_CHECK} ~${i}"
- eval "export WARNING_${i}='IPv6 tunnels will not be available'"
- done
-
- CONFIG_CHECK="${CONFIG_CHECK} ~CRYPTO_NULL"
- export WARNING_CRYPTO_NULL="Unencrypted tunnels will not be available"
- export CONFIG_CHECK
-
- check_extra_config
- else
- eerror "You must have a kernel >=2.6.19 to run ipsec-tools."
- eerror "Building now, assuming that you will run on a different kernel"
+ if kernel_is -ge 2 6 19 ; then
+ einfo "Checking for suitable kernel configuration (Networking | Networking support | Networking options)"
+
+ if use nat; then
+ CONFIG_CHECK="${CONFIG_CHECK} ~NETFILTER_XT_MATCH_POLICY"
+ export WARNING_NETFILTER_XT_MATCH_POLICY="NAT support may fail weirdly unless you enable this option in your kernel"
fi
+
+ for i in XFRM_USER NET_KEY; do
+ CONFIG_CHECK="${CONFIG_CHECK} ~${i}"
+ eval "export WARNING_${i}='No tunnels will be available at all (${i})'"
+ done
+
+ for i in INET_IPCOMP INET_AH INET_ESP \
+ INET_XFRM_MODE_TRANSPORT \
+ INET_XFRM_MODE_TUNNEL \
+ INET_XFRM_MODE_BEET ; do
+ CONFIG_CHECK="${CONFIG_CHECK} ~${i}"
+ eval "export WARNING_${i}='IPv4 tunnels will not be available (${i})'"
+ done
+
+ for i in INET6_IPCOMP INET6_AH INET6_ESP \
+ INET6_XFRM_MODE_TRANSPORT \
+ INET6_XFRM_MODE_TUNNEL \
+ INET6_XFRM_MODE_BEET ; do
+ CONFIG_CHECK="${CONFIG_CHECK} ~${i}"
+ eval "export WARNING_${i}='IPv6 tunnels will not be available (${i})'"
+ done
+
+ CONFIG_CHECK="${CONFIG_CHECK} ~CRYPTO_NULL"
+ export WARNING_CRYPTO_NULL="Unencrypted tunnels will not be available (CRYPTO_NULL)"
+ export CONFIG_CHECK
+
+ check_extra_config
+ else
+ eerror "You must have a kernel >=2.6.19 to run ipsec-tools."
+ eerror "Building now, assuming that you will run on a different kernel"
fi
}
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
# fix for bug #76741
- sed -i 's:#include <sys/sysctl.h>::' src/racoon/pfkey.c src/setkey/setkey.c
+ sed -i 's:#include <sys/sysctl.h>::' src/racoon/pfkey.c src/setkey/setkey.c || die
# fix for bug #124813
- sed -i 's:-Werror::g' "${S}"/configure.ac
+ sed -i 's:-Werror::g' "${S}"/configure.ac || die
# Fixing duplicate specification of vmbuf.h #300161
epatch "${FILESDIR}"/${PN}-duplicate-header.patch
# fix for building with gcc-4.6
- sed -i 's: -R: -Wl,-R:' "${S}"/configure.ac
+ sed -i 's: -R: -Wl,-R:' "${S}"/configure.ac || die
AT_M4DIR="${S}" eautoreconf
epunt_cxx
}
-src_compile() {
+src_configure() {
# fix for bug #61025
filter-flags -march=c3
@@ -136,28 +133,23 @@ src_compile() {
# See bug #77369
#myconf="${myconf} --enable-samode-unspec"
- econf ${myconf} || die
- emake -j1 || die
+ econf ${myconf}
+}
+
+src_compile() {
+ emake -j1
}
src_install() {
- emake DESTDIR="${D}" install || die
+ emake DESTDIR="${D}" install
keepdir /var/lib/racoon
newconfd "${FILESDIR}"/racoon.conf.d racoon
newinitd "${FILESDIR}"/racoon.init.d racoon
dodoc ChangeLog README NEWS
- dodoc src/racoon/samples/*
+ dodoc -r src/racoon/samples
dodoc src/racoon/doc/*
- docinto roadwarrior
- dodoc src/racoon/samples/roadwarrior/*
-
- docinto roadwarrior/client
- dodoc src/racoon/samples/roadwarrior/client/*
- docinto roadwarrior/server
- dodoc src/racoon/samples/roadwarrior/server/*
-
docinto setkey
dodoc src/setkey/sample.cf