summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Whyman <thev00d00@gentoo.org>2012-09-23 18:20:24 +0000
committerIan Whyman <thev00d00@gentoo.org>2012-09-23 18:20:24 +0000
commita0e470df3ae7ca8473e465b5d9e5402a116b54a9 (patch)
treef180cb508fbdc5e75a062d06de5f924ccb48c176 /net-firewall/ufw
parentfix upstream email (diff)
downloadgentoo-2-a0e470df3ae7ca8473e465b5d9e5402a116b54a9.tar.gz
gentoo-2-a0e470df3ae7ca8473e465b5d9e5402a116b54a9.tar.bz2
gentoo-2-a0e470df3ae7ca8473e465b5d9e5402a116b54a9.zip
Fix for bug #428768 by Sławomir Nizio
(Portage version: 2.2.0_alpha130/cvs/Linux x86_64)
Diffstat (limited to 'net-firewall/ufw')
-rw-r--r--net-firewall/ufw/ChangeLog5
-rw-r--r--net-firewall/ufw/ufw-0.31.1.ebuild42
2 files changed, 45 insertions, 2 deletions
diff --git a/net-firewall/ufw/ChangeLog b/net-firewall/ufw/ChangeLog
index 52d73526539e..37bdaa2559a1 100644
--- a/net-firewall/ufw/ChangeLog
+++ b/net-firewall/ufw/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-firewall/ufw
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ufw/ChangeLog,v 1.7 2012/06/18 19:39:03 thev00d00 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ufw/ChangeLog,v 1.8 2012/09/23 18:20:24 thev00d00 Exp $
+
+ 23 Sep 2012; Ian Whyman <thev00d00@gentoo.org> ufw-0.31.1.ebuild:
+ Fix for bug #428768 by Sławomir Nizio
18 Jun 2012; Ian Whyman <thev00d00@gentoo.org> ufw-0.30.1-r4.ebuild,
ufw-0.31.1.ebuild:
diff --git a/net-firewall/ufw/ufw-0.31.1.ebuild b/net-firewall/ufw/ufw-0.31.1.ebuild
index 264b00b1983c..a76dfa8efe59 100644
--- a/net-firewall/ufw/ufw-0.31.1.ebuild
+++ b/net-firewall/ufw/ufw-0.31.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ufw/ufw-0.31.1.ebuild,v 1.2 2012/06/18 19:39:03 thev00d00 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ufw/ufw-0.31.1.ebuild,v 1.3 2012/09/23 18:20:24 thev00d00 Exp $
EAPI=4
PYTHON_DEPEND="2:2.5"
@@ -41,6 +41,46 @@ pkg_pretend() {
fi
check_extra_config
+
+ # Check for default, useful optional features.
+ if ! linux_config_exists; then
+ ewarn "Cannot determine configuration of your kernel."
+ return
+ fi
+
+ local nf_nat_ftp_ok="yes"
+ local nf_conntrack_ftp_ok="yes"
+ local nf_conntrack_netbios_ns_ok="yes"
+
+ linux_chkconfig_present \
+ NF_NAT_FTP || nf_nat_ftp_ok="no"
+ linux_chkconfig_present \
+ NF_CONNTRACK_FTP || nf_conntrack_ftp_ok="no"
+ linux_chkconfig_present \
+ NF_CONNTRACK_NETBIOS_NS || nf_conntrack_netbios_ns_ok="no"
+
+ # This is better than an essay for each unset option...
+ if [[ ${nf_nat_ftp_ok} = no ]] || [[ ${nf_conntrack_ftp_ok} = no ]] \
+ || [[ ${nf_conntrack_netbios_ns_ok} = no ]]
+ then
+ echo
+ local mod_msg="Kernel options listed below are not set. They are not"
+ mod_msg+=" mandatory, but they are often useful."
+ mod_msg+=" If you don't need some of them, please remove relevant"
+ mod_msg+=" module name(s) from IPT_MODULES in"
+ mod_msg+=" '${EROOT}etc/default/ufw' before (re)starting ufw."
+ mod_msg+=" Otherwise ufw may fail to start!"
+ ewarn "${mod_msg}"
+ if [[ ${nf_nat_ftp_ok} = no ]]; then
+ ewarn "NF_NAT_FTP: for better support for active mode FTP."
+ fi
+ if [[ ${nf_conntrack_ftp_ok} = no ]]; then
+ ewarn "NF_CONNTRACK_FTP: for better support for active mode FTP."
+ fi
+ if [[ ${nf_conntrack_netbios_ns_ok} = no ]]; then
+ ewarn "NF_CONNTRACK_NETBIOS_NS: for better Samba support."
+ fi
+ fi
}
src_prepare() {