summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2009-10-09 12:06:44 +0000
committerPeter Volkov <pva@gentoo.org>2009-10-09 12:06:44 +0000
commitb3462edbf7592fc6ba95bb73d37996ea399df8ed (patch)
treef26e90af495ea66d3e4a98f7361c66820542ac3e /net-firewall/shorewall6
parentVersion bump, bug #281617, thank Vieri for this work. (diff)
downloadgentoo-2-b3462edbf7592fc6ba95bb73d37996ea399df8ed.tar.gz
gentoo-2-b3462edbf7592fc6ba95bb73d37996ea399df8ed.tar.bz2
gentoo-2-b3462edbf7592fc6ba95bb73d37996ea399df8ed.zip
Version bump, bug #281617, thank Vieri for this work.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'net-firewall/shorewall6')
-rw-r--r--net-firewall/shorewall6/ChangeLog7
-rw-r--r--net-firewall/shorewall6/shorewall6-4.2.11.ebuild72
2 files changed, 78 insertions, 1 deletions
diff --git a/net-firewall/shorewall6/ChangeLog b/net-firewall/shorewall6/ChangeLog
index 120ea3e10363..2db3d07a566e 100644
--- a/net-firewall/shorewall6/ChangeLog
+++ b/net-firewall/shorewall6/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-firewall/shorewall6
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall6/ChangeLog,v 1.9 2009/06/22 04:33:56 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall6/ChangeLog,v 1.10 2009/10/09 12:06:44 pva Exp $
+
+*shorewall6-4.2.11 (09 Oct 2009)
+
+ 09 Oct 2009; Peter Volkov <pva@gentoo.org> +shorewall6-4.2.11.ebuild:
+ Version bump, bug #281617, thank Vieri for this work.
22 Jun 2009; Jeroen Roovers <jer@gentoo.org> shorewall6-4.2.9.ebuild:
Marked ~hppa (bug #256063).
diff --git a/net-firewall/shorewall6/shorewall6-4.2.11.ebuild b/net-firewall/shorewall6/shorewall6-4.2.11.ebuild
new file mode 100644
index 000000000000..fdddae5e0695
--- /dev/null
+++ b/net-firewall/shorewall6/shorewall6-4.2.11.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall6/shorewall6-4.2.11.ebuild,v 1.1 2009/10/09 12:06:44 pva Exp $
+
+inherit versionator linux-info
+
+# Select version (stable, RC, Beta, upstream patched):
+MY_PV_TREE=$(get_version_component_range 1-2) # for devel versions use "development/$(get_version_component_range 1-2)"
+MY_P_BETA="" # stable or experimental (eg. "-RC1" or "-Beta4")
+MY_PV_BASE=$(get_version_component_range 1-3) # which shorewall-common to use
+
+MY_PN="${PN/6/}"
+MY_P="${MY_PN}-${MY_PV_BASE}${MY_P_BETA}"
+
+DESCRIPTION="Shoreline Firewall with IPv6 support."
+HOMEPAGE="http://www.shorewall.net/"
+SRC_URI="http://www1.shorewall.net/pub/${MY_PN}/${MY_PV_TREE}/${MY_P}/${P}${MY_P_BETA}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc64 ~x86"
+
+IUSE="doc"
+
+DEPEND=">=net-firewall/iptables-1.4.0
+ sys-apps/iproute2
+ >=net-firewall/shorewall-perl-${MY_PV_BASE}
+ dev-perl/Socket6
+ !<net-firewall/shorewall-4.0"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ if kernel_is lt 2 6 25 ; then
+ die "${PN} requires at least kernel 2.6.25."
+ fi
+}
+
+src_compile() {
+ einfo "Nothing to compile."
+}
+
+src_install() {
+ keepdir /var/lib/${PN}
+
+ cd "${WORKDIR}/${P}${MY_P_BETA}"
+ PREFIX="${D}" ./install.sh || die "install.sh failed"
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN} || die "doinitd failed"
+
+ dodoc releasenotes.txt
+ if use doc; then
+ cp -pR Samples6 "${D}/usr/share/doc/${PF}"
+ fi
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Documentation is available at http://www.shorewall.net"
+ einfo "There are man pages for ${PN}(8)."
+ einfo "For additional information, see"
+ einfo "http://www.shorewall.net/IPV6Support.html"
+ use doc && einfo "Sample configuration files are in /usr/share/doc/${PF}."
+ einfo
+ elog "If you wish to include DNS names in your IPv6 configuration files,"
+ elog "you must have Perl 5.10 and must emerge dev-perl/Socket6."
+ einfo
+ einfo "Please read the included release notes for more information."
+ einfo
+ einfo "Known problems:"
+ einfo "http://www.shorewall.net/pub/${MY_PN}/${MY_PV_TREE}/${MY_P}/known_problems.txt"
+ einfo
+}