summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConstanze Hausner <constanze@gentoo.org>2012-10-21 12:56:33 +0000
committerConstanze Hausner <constanze@gentoo.org>2012-10-21 12:56:33 +0000
commit0a54038f66e6b560063341edd643178fe2259cbc (patch)
treeaad8b38005c88e8e80a161dae2ca8b83921ab9ab /net-firewall/shorewall6
parentAdded checkpath -d to init-script, see Bug 429750 (diff)
downloadgentoo-2-0a54038f66e6b560063341edd643178fe2259cbc.tar.gz
gentoo-2-0a54038f66e6b560063341edd643178fe2259cbc.tar.bz2
gentoo-2-0a54038f66e6b560063341edd643178fe2259cbc.zip
Added checkpath -d to init-script, see Bug 429750
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'net-firewall/shorewall6')
-rw-r--r--net-firewall/shorewall6/ChangeLog8
-rw-r--r--net-firewall/shorewall6/files/shorewall6.initd10
-rw-r--r--net-firewall/shorewall6/shorewall6-4.5.8.2-r1.ebuild61
3 files changed, 77 insertions, 2 deletions
diff --git a/net-firewall/shorewall6/ChangeLog b/net-firewall/shorewall6/ChangeLog
index 34ccef7af8be..30cc4434eb12 100644
--- a/net-firewall/shorewall6/ChangeLog
+++ b/net-firewall/shorewall6/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-firewall/shorewall6
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall6/ChangeLog,v 1.54 2012/10/12 18:17:00 constanze Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall6/ChangeLog,v 1.55 2012/10/21 12:56:33 constanze Exp $
+
+*shorewall6-4.5.8.2-r1 (21 Oct 2012)
+
+ 21 Oct 2012; Constanze Hausner <constanze@gentoo.org> files/shorewall6.initd,
+ +shorewall6-4.5.8.2-r1.ebuild:
+ Added checkpath -d to init-script, see Bug #429750
*shorewall6-4.5.8.2 (12 Oct 2012)
diff --git a/net-firewall/shorewall6/files/shorewall6.initd b/net-firewall/shorewall6/files/shorewall6.initd
index 5eccb81e41f0..299b02ef7d50 100644
--- a/net-firewall/shorewall6/files/shorewall6.initd
+++ b/net-firewall/shorewall6/files/shorewall6.initd
@@ -1,11 +1,17 @@
#!/sbin/runscript
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall6/files/shorewall6.initd,v 1.2 2012/02/24 18:53:41 constanze Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall6/files/shorewall6.initd,v 1.3 2012/10/21 12:56:33 constanze Exp $
extra_commands="check clear"
extra_started_commands="refresh reset"
+checkconfig() {
+ if [ ! -d /var/lock/subsys ] ; then
+ checkpath -d -m 755 /var/lock/subsys
+ fi
+}
+
depend() {
need net
provide firewall
@@ -13,6 +19,7 @@ depend() {
}
start() {
+ checkconfig
ebegin "Starting firewall"
/sbin/shorewall6 -f start 1>/dev/null
eend $?
@@ -25,6 +32,7 @@ stop() {
}
restart() {
+ checkconfig
# shorewall comes with its own control script that includes a
# restart function, so refrain from calling svc_stop/svc_start
# here. Note that this comment is required to fix bug 55576;
diff --git a/net-firewall/shorewall6/shorewall6-4.5.8.2-r1.ebuild b/net-firewall/shorewall6/shorewall6-4.5.8.2-r1.ebuild
new file mode 100644
index 000000000000..0253d98bb4f5
--- /dev/null
+++ b/net-firewall/shorewall6/shorewall6-4.5.8.2-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall6/shorewall6-4.5.8.2-r1.ebuild,v 1.1 2012/10/21 12:56:33 constanze Exp $
+
+EAPI="4"
+
+inherit versionator linux-info
+
+# Select version (stable, RC, Beta, upstream patched):
+MY_PV_TREE=$(get_version_component_range 1-2) # for devel versions use "development/$(get_version_component_range 1-2)"
+MY_PV_BASE=$(get_version_component_range 1-3) # which shorewall-common to use
+
+MY_PN="${PN/6/}"
+MY_P="${MY_PN}-${MY_PV_BASE}"
+MY_P_DOCS="${MY_PN}-docs-html-${PV}"
+
+DESCRIPTION="Shoreline Firewall with IPv6 support."
+HOMEPAGE="http://www.shorewall.net/"
+SRC_URI="http://www1.shorewall.net/pub/${MY_PN}/${MY_PV_TREE}/${MY_P}/${P}.tar.bz2
+ doc? ( http://www1.shorewall.net/pub/${PN}/${MY_PV_TREE}/${MY_P}/${MY_P_DOCS}.tar.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="doc"
+
+RDEPEND=">=net-firewall/iptables-1.4.0
+ sys-apps/iproute2
+ >=net-firewall/shorewall-${MY_PV_BASE}
+ dev-perl/Socket6"
+
+pkg_pretend() {
+ if kernel_is lt 2 6 25 ; then
+ die "${PN} requires at least kernel 2.6.25."
+ fi
+}
+
+src_configure() {
+ :;
+}
+
+src_compile() {
+ :;
+}
+
+src_install() {
+ keepdir /var/lib/${PN}
+
+ cd "${WORKDIR}/${P}"
+ DESTDIR="${D}" ./install.sh "${FILESDIR}"/shorewallrc_new || die "install.sh failed"
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+
+ dodoc changelog.txt releasenotes.txt
+ if use doc; then
+ dodoc -r Samples6
+ cd "${WORKDIR}/${MY_P_DOCS}"
+ dohtml -r *
+ fi
+ keepdir /var/lock/subsys
+}