summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2005-09-21 16:34:52 +0000
committerSeemant Kulleen <seemant@gentoo.org>2005-09-21 16:34:52 +0000
commit91f6d8ebe785d4dc47b24430c174bc76002c3023 (patch)
tree6564baa34c4f2eed961b94e239e864c882993531 /net-firewall/psad
parentPrepare for beta1. (diff)
downloadgentoo-2-91f6d8ebe785d4dc47b24430c174bc76002c3023.tar.gz
gentoo-2-91f6d8ebe785d4dc47b24430c174bc76002c3023.tar.bz2
gentoo-2-91f6d8ebe785d4dc47b24430c174bc76002c3023.zip
fix the grep for mydomain so that it takes only ^domain, as the word domain can appear in other places in resolv.conf. Thanks to Chandler Carruth (chandlerc on IRC)
(Portage version: 2.0.52-r1)
Diffstat (limited to 'net-firewall/psad')
-rw-r--r--net-firewall/psad/ChangeLog8
-rw-r--r--net-firewall/psad/psad-1.3.4.ebuild4
-rw-r--r--net-firewall/psad/psad-1.4.0.ebuild4
-rw-r--r--net-firewall/psad/psad-1.4.2.ebuild4
4 files changed, 13 insertions, 7 deletions
diff --git a/net-firewall/psad/ChangeLog b/net-firewall/psad/ChangeLog
index 5b3e056167d7..5fb0093adffa 100644
--- a/net-firewall/psad/ChangeLog
+++ b/net-firewall/psad/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-firewall/psad
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/psad/ChangeLog,v 1.29 2005/07/31 05:17:05 battousai Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/psad/ChangeLog,v 1.30 2005/09/21 16:34:19 seemant Exp $
+
+ 21 Sep 2005; Seemant Kulleen <seemant@gentoo.org> psad-1.4.0.ebuild,
+ psad-1.4.2.ebuild:
+ fix the grep for mydomain so that it takes only ^domain, as the word domain
+ can appear in other places in resolv.conf. Thanks to Chandler Carruth
+ (chandlerc on IRC)
31 Jul 2005; Bryan Stine <battousai@gentoo.org> psad-1.3.4.ebuild:
Stable x86...whoops.
diff --git a/net-firewall/psad/psad-1.3.4.ebuild b/net-firewall/psad/psad-1.3.4.ebuild
index c8ebf08c3969..564664bfa482 100644
--- a/net-firewall/psad/psad-1.3.4.ebuild
+++ b/net-firewall/psad/psad-1.3.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/psad/psad-1.3.4.ebuild,v 1.6 2005/07/31 05:20:27 battousai Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/psad/psad-1.3.4.ebuild,v 1.7 2005/09/21 16:34:52 seemant Exp $
inherit eutils perl-module
@@ -124,7 +124,7 @@ fix_psad_conf() {
# Ditch the _CHANGEME_ for hostname, substituting in our real hostname
[ -e /etc/hostname ] && myhostname="$(< /etc/hostname)"
[ "${myhostname}" == "" ] && myhostname="$HOSTNAME"
- mydomain=".$(grep domain /etc/resolv.conf | cut -d" " -f2)"
+ mydomain=".$(grep ^domain /etc/resolv.conf | cut -d" " -f2)"
sed -i "s:HOSTNAME\(.\+\)\_CHANGEME\_;:HOSTNAME\1${myhostname}${mydomain};:" psad.conf || die "fix_psad_conf failed"
# Fix up paths
diff --git a/net-firewall/psad/psad-1.4.0.ebuild b/net-firewall/psad/psad-1.4.0.ebuild
index e7ab447d1346..96b703356b1b 100644
--- a/net-firewall/psad/psad-1.4.0.ebuild
+++ b/net-firewall/psad/psad-1.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/psad/psad-1.4.0.ebuild,v 1.5 2005/07/31 03:09:02 battousai Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/psad/psad-1.4.0.ebuild,v 1.6 2005/09/21 16:34:19 seemant Exp $
inherit eutils perl-module
@@ -142,7 +142,7 @@ fix_psad_conf() {
# Ditch the _CHANGEME_ for hostname, substituting in our real hostname
[ -e /etc/hostname ] && myhostname="$(< /etc/hostname)"
[ "${myhostname}" == "" ] && myhostname="$HOSTNAME"
- mydomain=".$(grep domain /etc/resolv.conf | cut -d" " -f2)"
+ mydomain=".$(grep ^domain /etc/resolv.conf | cut -d" " -f2)"
sed -i "s:HOSTNAME\(.\+\)\_CHANGEME\_;:HOSTNAME\1${myhostname}${mydomain};:" psad.conf || die "fix_psad_conf failed"
# Fix up paths
diff --git a/net-firewall/psad/psad-1.4.2.ebuild b/net-firewall/psad/psad-1.4.2.ebuild
index 4717ab543b4d..a28e04c194ae 100644
--- a/net-firewall/psad/psad-1.4.2.ebuild
+++ b/net-firewall/psad/psad-1.4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/psad/psad-1.4.2.ebuild,v 1.1 2005/07/31 03:09:02 battousai Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/psad/psad-1.4.2.ebuild,v 1.2 2005/09/21 16:34:19 seemant Exp $
inherit eutils perl-module
@@ -146,7 +146,7 @@ fix_psad_conf() {
# Ditch the _CHANGEME_ for hostname, substituting in our real hostname
[ -e /etc/hostname ] && myhostname="$(< /etc/hostname)"
[ "${myhostname}" == "" ] && myhostname="$HOSTNAME"
- mydomain=".$(grep domain /etc/resolv.conf | cut -d" " -f2)"
+ mydomain=".$(grep ^domain /etc/resolv.conf | cut -d" " -f2)"
sed -i "s:HOSTNAME\(.\+\)\_CHANGEME\_;:HOSTNAME\1${myhostname}${mydomain};:" psad.conf || die "fix_psad_conf failed"
# Fix up paths