summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJavier Villavicencio <the_paya@gentoo.org>2012-07-22 00:01:31 +0000
committerJavier Villavicencio <the_paya@gentoo.org>2012-07-22 00:01:31 +0000
commit91c64cf4dbffa4824c29b140e53e773bef692cc8 (patch)
tree15e7646aa8253d7052455ef2fe885c0abda5cf2b /net-firewall/pftop
parentRemove older version (diff)
downloadgentoo-2-91c64cf4dbffa4824c29b140e53e773bef692cc8.tar.gz
gentoo-2-91c64cf4dbffa4824c29b140e53e773bef692cc8.tar.bz2
gentoo-2-91c64cf4dbffa4824c29b140e53e773bef692cc8.zip
Fix for bug #426662.
(Portage version: 2.2.0_alpha120/cvs/FreeBSD i386)
Diffstat (limited to 'net-firewall/pftop')
-rw-r--r--net-firewall/pftop/ChangeLog7
-rw-r--r--net-firewall/pftop/pftop-0.7-r2.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/net-firewall/pftop/ChangeLog b/net-firewall/pftop/ChangeLog
index f7e8f35c26d9..540cb0047d22 100644
--- a/net-firewall/pftop/ChangeLog
+++ b/net-firewall/pftop/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-firewall/pftop
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/pftop/ChangeLog,v 1.8 2012/04/13 19:37:32 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/pftop/ChangeLog,v 1.9 2012/07/22 00:01:31 the_paya Exp $
+
+*pftop-0.7-r2 (21 Jul 2012)
+
+ 21 Jul 2012; Javier Villavicencio <the_paya@gentoo.org> +pftop-0.7-r2.ebuild:
+ Fix for bug #426662, thanks adeel_n@yahoo.com
13 Apr 2012; Ulrich Müller <ulm@gentoo.org> pftop-0.7-r1.ebuild:
Move EAPI assignment to top of ebuild, bug 411875.
diff --git a/net-firewall/pftop/pftop-0.7-r2.ebuild b/net-firewall/pftop/pftop-0.7-r2.ebuild
new file mode 100644
index 000000000000..a979d6eb2211
--- /dev/null
+++ b/net-firewall/pftop/pftop-0.7-r2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/pftop/pftop-0.7-r2.ebuild,v 1.1 2012/07/22 00:01:31 the_paya Exp $
+
+EAPI=4
+PATCH_PV=3
+
+inherit bsdmk flag-o-matic eutils
+
+DESCRIPTION="Pftop: curses-based utility for real-time display of active states and rule statistics for pf"
+HOMEPAGE="http://www.eee.metu.edu.tr/~canacar/pftop/"
+SRC_URI="http://www.eee.metu.edu.tr/~canacar/${P}.tar.gz
+ mirror://gentoo/${P}-patches-${PATCH_PV}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86-fbsd"
+IUSE="altq"
+
+RDEPEND="sys-libs/ncurses"
+
+src_prepare() {
+ epatch "${WORKDIR}"/patches/*
+}
+
+src_compile() {
+ # OS_LEVEL variable refers to the version of pf shipped with OpenBSD.
+ # On FreeBSD we have to know it.
+ local OSLEVEL
+
+ case ${CHOST} in
+ *-openbsd*)
+ local obsdver=${CHOST/*-openbsd/}
+ OSLEVEL=${obsdver//.}
+ ;;
+ *-freebsd[78]*) OSLEVEL=41 ;;
+ *-freebsd9*) OSLEVEL=45 ;;
+ *)
+ die "Your OS/Version is not supported (${CHOST}), please report."
+ ;;
+ esac
+ append-flags "-DHAVE_SNPRINTF -DHAVE_VSNPRINTF -DOS_LEVEL=${OSLEVEL}"
+ use altq && append-flags "-DHAVE_ALTQ"
+ mkmake LOCALBASE="/usr" CFLAGS="${CFLAGS}" || die "pmake failed"
+}
+
+src_install() {
+ mkinstall DESTDIR="${D}" LOCALBASE="/usr" MANDIR="/usr/share/man/man" \
+ NO_MANCOMPRESS= install || die
+}