summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2011-06-09 07:42:01 +0000
committerPeter Volkov <pva@gentoo.org>2011-06-09 07:42:01 +0000
commit9bbb378e5787d3ac6020111a6957052bfa45611f (patch)
tree55e220221e1965b2609c6ddf8a2af3dd2df01d3f /net-firewall/iptables
parentVersion bump (bug #365807). (diff)
downloadgentoo-2-9bbb378e5787d3ac6020111a6957052bfa45611f.tar.gz
gentoo-2-9bbb378e5787d3ac6020111a6957052bfa45611f.tar.bz2
gentoo-2-9bbb378e5787d3ac6020111a6957052bfa45611f.zip
Version bump.
(Portage version: 2.1.9.50/cvs/Linux x86_64)
Diffstat (limited to 'net-firewall/iptables')
-rw-r--r--net-firewall/iptables/ChangeLog7
-rw-r--r--net-firewall/iptables/iptables-1.4.11.1.ebuild75
2 files changed, 81 insertions, 1 deletions
diff --git a/net-firewall/iptables/ChangeLog b/net-firewall/iptables/ChangeLog
index 218e77f4d62a..a3756c2e5596 100644
--- a/net-firewall/iptables/ChangeLog
+++ b/net-firewall/iptables/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-firewall/iptables
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/ChangeLog,v 1.236 2011/02/10 04:05:05 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/ChangeLog,v 1.237 2011/06/09 07:42:01 pva Exp $
+
+*iptables-1.4.11.1 (09 Jun 2011)
+
+ 09 Jun 2011; Peter Volkov <pva@gentoo.org> +iptables-1.4.11.1.ebuild:
+ Version bump.
*iptables-1.4.10-r1 (10 Feb 2011)
diff --git a/net-firewall/iptables/iptables-1.4.11.1.ebuild b/net-firewall/iptables/iptables-1.4.11.1.ebuild
new file mode 100644
index 000000000000..5b5948df362a
--- /dev/null
+++ b/net-firewall/iptables/iptables-1.4.11.1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.4.11.1.ebuild,v 1.1 2011/06/09 07:42:01 pva Exp $
+
+EAPI="4"
+
+# Force users doing their own patches to install their own tools
+AUTOTOOLS_AUTO_DEPEND=no
+
+inherit eutils toolchain-funcs autotools
+
+DESCRIPTION="Linux kernel (2.4+) firewall, NAT and packet mangling tools"
+HOMEPAGE="http://www.iptables.org/"
+SRC_URI="http://iptables.org/projects/iptables/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="ipv6 netlink"
+
+DEPEND="virtual/os-headers"
+RDEPEND="netlink? ( net-libs/libnfnetlink )"
+
+src_prepare() {
+ # Only run autotools if user patched something
+ epatch_user && eautoreconf || elibtoolize
+}
+
+src_configure() {
+ sed -i \
+ -e "/nfnetlink=[01]/s:=[01]:=$(use netlink && echo 1 || echo 0):" \
+ configure
+ econf \
+ --sbindir=/sbin \
+ --libexecdir=/$(get_libdir) \
+ --enable-devel \
+ --enable-libipq \
+ --enable-shared \
+ --enable-static \
+ $(use_enable ipv6)
+}
+
+src_compile() {
+ emake V=1
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dodoc INCOMPATIBILITIES iptables/iptables.xslt
+
+ # all the iptables binaries are in /sbin, so might as well
+ # put these small files in with them
+ into /
+ dosbin iptables/iptables-apply
+ dosym iptables-apply /sbin/ip6tables-apply
+ doman iptables/iptables-apply.8
+
+ insinto /usr/include
+ doins include/iptables.h $(use ipv6 && echo include/ip6tables.h)
+ insinto /usr/include/iptables
+ doins include/iptables/internal.h
+
+ keepdir /var/lib/iptables
+ newinitd "${FILESDIR}"/${PN}-1.3.2.init iptables
+ newconfd "${FILESDIR}"/${PN}-1.3.2.confd iptables
+ if use ipv6 ; then
+ keepdir /var/lib/ip6tables
+ newinitd "${FILESDIR}"/iptables-1.3.2.init ip6tables
+ newconfd "${FILESDIR}"/ip6tables-1.3.2.confd ip6tables
+ fi
+
+ # Move important libs to /lib
+ gen_usr_ldscript -a ip{4,6}tc ipq iptc xtables
+ find "${ED}" -type f -name '*.la' -exec rm -rf '{}' '+' || die "la removal failed"
+}