summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-08-27 08:57:51 +0000
committerMike Frysinger <vapier@gentoo.org>2009-08-27 08:57:51 +0000
commit97df8e22e79f5d8e3ec930e90a3c4807fc9f3dc0 (patch)
tree7d1ff06fa9a360714372b48eb95569909d3fcf02 /net-firewall/iptables
parentMove to common epatch code. (diff)
downloadgentoo-2-97df8e22e79f5d8e3ec930e90a3c4807fc9f3dc0.tar.gz
gentoo-2-97df8e22e79f5d8e3ec930e90a3c4807fc9f3dc0.tar.bz2
gentoo-2-97df8e22e79f5d8e3ec930e90a3c4807fc9f3dc0.zip
Move to common epatch code.
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'net-firewall/iptables')
-rw-r--r--net-firewall/iptables/ChangeLog7
-rw-r--r--net-firewall/iptables/iptables-1.3.8-r3.ebuild16
-rw-r--r--net-firewall/iptables/iptables-1.4.0-r1.ebuild16
-rw-r--r--net-firewall/iptables/iptables-1.4.2-r2.ebuild16
-rw-r--r--net-firewall/iptables/iptables-1.4.3.2.ebuild17
-rw-r--r--net-firewall/iptables/iptables-1.4.4.ebuild17
6 files changed, 16 insertions, 73 deletions
diff --git a/net-firewall/iptables/ChangeLog b/net-firewall/iptables/ChangeLog
index 4cb02ab02ff0..ff7bc537ff7e 100644
--- a/net-firewall/iptables/ChangeLog
+++ b/net-firewall/iptables/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-firewall/iptables
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/ChangeLog,v 1.204 2009/07/27 18:16:07 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/ChangeLog,v 1.205 2009/08/27 08:57:51 vapier Exp $
+
+ 27 Aug 2009; Mike Frysinger <vapier@gentoo.org> iptables-1.3.8-r3.ebuild,
+ iptables-1.4.0-r1.ebuild, iptables-1.4.2-r2.ebuild,
+ iptables-1.4.3.2.ebuild, iptables-1.4.4.ebuild:
+ Move to common epatch code.
27 Jul 2009; Mike Frysinger <vapier@gentoo.org> iptables-1.4.4.ebuild:
Add USE=ipv6 support by Christian Affolter #277366.
diff --git a/net-firewall/iptables/iptables-1.3.8-r3.ebuild b/net-firewall/iptables/iptables-1.3.8-r3.ebuild
index 9b878eea08df..724b2f56e667 100644
--- a/net-firewall/iptables/iptables-1.3.8-r3.ebuild
+++ b/net-firewall/iptables/iptables-1.3.8-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.3.8-r3.ebuild,v 1.11 2009/01/30 21:54:08 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.3.8-r3.ebuild,v 1.12 2009/08/27 08:57:51 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs linux-info
@@ -78,19 +78,7 @@ src_unpack() {
-e "s/PF_EXT_SLIB:=/PF_EXT_SLIB:=stealth /g" \
extensions/Makefile || die "failed to enable stealth extension"
- local check base=${PORTAGE_CONFIGROOT}/etc/portage/patches
- for check in {${CATEGORY}/${PF},${CATEGORY}/${P},${CATEGORY}/${PN}}; do
- EPATCH_SOURCE=${base}/${CTARGET}/${check}
- [[ -r ${EPATCH_SOURCE} ]] || EPATCH_SOURCE=${base}/${CHOST}/${check}
- [[ -r ${EPATCH_SOURCE} ]] || EPATCH_SOURCE=${base}/${check}
- if [[ -d ${EPATCH_SOURCE} ]] ; then
- EPATCH_SUFFIX="patch"
- EPATCH_FORCE="yes" \
- EPATCH_MULTI_MSG="Applying user patches from ${EPATCH_SOURCE} ..." \
- epatch
- break
- fi
- done
+ epatch_user
if use imq ; then
EPATCH_OPTS="-p1" epatch "${DISTDIR}"/${IMQ_PATCH}
diff --git a/net-firewall/iptables/iptables-1.4.0-r1.ebuild b/net-firewall/iptables/iptables-1.4.0-r1.ebuild
index 24f51605bd4f..1d05bb6cabce 100644
--- a/net-firewall/iptables/iptables-1.4.0-r1.ebuild
+++ b/net-firewall/iptables/iptables-1.4.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.4.0-r1.ebuild,v 1.15 2009/01/30 21:54:08 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.4.0-r1.ebuild,v 1.16 2009/08/27 08:57:51 vapier Exp $
inherit eutils toolchain-funcs linux-info
@@ -76,19 +76,7 @@ src_unpack() {
-e "s/PF_EXT_SLIB:=/PF_EXT_SLIB:=stealth /g" \
extensions/Makefile || die "failed to enable stealth extension"
- local check base=${PORTAGE_CONFIGROOT}/etc/portage/patches
- for check in {${CATEGORY}/${PF},${CATEGORY}/${P},${CATEGORY}/${PN}}; do
- EPATCH_SOURCE=${base}/${CTARGET}/${check}
- [[ -r ${EPATCH_SOURCE} ]] || EPATCH_SOURCE=${base}/${CHOST}/${check}
- [[ -r ${EPATCH_SOURCE} ]] || EPATCH_SOURCE=${base}/${check}
- if [[ -d ${EPATCH_SOURCE} ]] ; then
- EPATCH_SUFFIX="patch"
- EPATCH_FORCE="yes" \
- EPATCH_MULTI_MSG="Applying user patches from ${EPATCH_SOURCE} ..." \
- epatch
- break
- fi
- done
+ epatch_user
if use imq ; then
EPATCH_OPTS="-p1" epatch "${DISTDIR}"/${IMQ_PATCH}
diff --git a/net-firewall/iptables/iptables-1.4.2-r2.ebuild b/net-firewall/iptables/iptables-1.4.2-r2.ebuild
index a9a0f4c03c1e..4cf7a62d8500 100644
--- a/net-firewall/iptables/iptables-1.4.2-r2.ebuild
+++ b/net-firewall/iptables/iptables-1.4.2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.4.2-r2.ebuild,v 1.9 2009/02/16 16:57:34 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.4.2-r2.ebuild,v 1.10 2009/08/27 08:57:51 vapier Exp $
inherit eutils toolchain-funcs linux-info
@@ -52,19 +52,7 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-libxt_iprange.c-build.patch
epatch "${FILESDIR}"/${P}-hashlimit.patch #254496
- local check base=${PORTAGE_CONFIGROOT}/etc/portage/patches
- for check in {${CATEGORY}/${PF},${CATEGORY}/${P},${CATEGORY}/${PN}}; do
- EPATCH_SOURCE=${base}/${CTARGET}/${check}
- [[ -r ${EPATCH_SOURCE} ]] || EPATCH_SOURCE=${base}/${CHOST}/${check}
- [[ -r ${EPATCH_SOURCE} ]] || EPATCH_SOURCE=${base}/${check}
- if [[ -d ${EPATCH_SOURCE} ]] ; then
- EPATCH_SUFFIX="patch"
- EPATCH_FORCE="yes" \
- EPATCH_MULTI_MSG="Applying user patches from ${EPATCH_SOURCE} ..." \
- epatch
- break
- fi
- done
+ epatch_user
if use l7filter ; then
cp "${WORKDIR}/${L7_P}/iptables-1.4.1.1-for-kernel-2.6.20forward"/* extensions \
diff --git a/net-firewall/iptables/iptables-1.4.3.2.ebuild b/net-firewall/iptables/iptables-1.4.3.2.ebuild
index 83500becb470..a10dfd095e3e 100644
--- a/net-firewall/iptables/iptables-1.4.3.2.ebuild
+++ b/net-firewall/iptables/iptables-1.4.3.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.4.3.2.ebuild,v 1.7 2009/07/23 14:59:47 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.4.3.2.ebuild,v 1.8 2009/08/27 08:57:51 vapier Exp $
inherit eutils toolchain-funcs
@@ -19,20 +19,7 @@ RDEPEND=""
src_unpack() {
unpack ${P}.tar.bz2
cd "${S}"
-
- local check base=${PORTAGE_CONFIGROOT}/etc/portage/patches
- for check in {${CATEGORY}/${PF},${CATEGORY}/${P},${CATEGORY}/${PN}}; do
- EPATCH_SOURCE=${base}/${CTARGET}/${check}
- [[ -r ${EPATCH_SOURCE} ]] || EPATCH_SOURCE=${base}/${CHOST}/${check}
- [[ -r ${EPATCH_SOURCE} ]] || EPATCH_SOURCE=${base}/${check}
- if [[ -d ${EPATCH_SOURCE} ]] ; then
- EPATCH_SUFFIX="patch"
- EPATCH_FORCE="yes" \
- EPATCH_MULTI_MSG="Applying user patches from ${EPATCH_SOURCE} ..." \
- epatch
- break
- fi
- done
+ epatch_user
}
src_compile() {
diff --git a/net-firewall/iptables/iptables-1.4.4.ebuild b/net-firewall/iptables/iptables-1.4.4.ebuild
index 268f56878c59..ee9e35c8b8c7 100644
--- a/net-firewall/iptables/iptables-1.4.4.ebuild
+++ b/net-firewall/iptables/iptables-1.4.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.4.4.ebuild,v 1.2 2009/07/27 18:16:07 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.4.4.ebuild,v 1.3 2009/08/27 08:57:51 vapier Exp $
inherit eutils toolchain-funcs
@@ -19,20 +19,7 @@ RDEPEND=""
src_unpack() {
unpack ${P}.tar.bz2
cd "${S}"
-
- local check base=${PORTAGE_CONFIGROOT}/etc/portage/patches
- for check in {${CATEGORY}/${PF},${CATEGORY}/${P},${CATEGORY}/${PN}}; do
- EPATCH_SOURCE=${base}/${CTARGET}/${check}
- [[ -r ${EPATCH_SOURCE} ]] || EPATCH_SOURCE=${base}/${CHOST}/${check}
- [[ -r ${EPATCH_SOURCE} ]] || EPATCH_SOURCE=${base}/${check}
- if [[ -d ${EPATCH_SOURCE} ]] ; then
- EPATCH_SUFFIX="patch"
- EPATCH_FORCE="yes" \
- EPATCH_MULTI_MSG="Applying user patches from ${EPATCH_SOURCE} ..." \
- epatch
- break
- fi
- done
+ epatch_user
}
src_compile() {