summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-12-18 15:59:27 +0000
committerMike Frysinger <vapier@gentoo.org>2009-12-18 15:59:27 +0000
commit85360c1164d980f302fff4924a470820818293e2 (patch)
treee2ce8a7a5fb68fce69c9cb75b4e8c033dd9e44f6 /net-firewall/iptables
parentold (diff)
downloadgentoo-2-85360c1164d980f302fff4924a470820818293e2.tar.gz
gentoo-2-85360c1164d980f302fff4924a470820818293e2.tar.bz2
gentoo-2-85360c1164d980f302fff4924a470820818293e2.zip
old
Diffstat (limited to 'net-firewall/iptables')
-rw-r--r--net-firewall/iptables/files/1.3.1-files/grsecurity-1.2.8-iptables.patch-1.3.167
-rw-r--r--net-firewall/iptables/files/1.3.1-files/install_all_dev_files.patch-1.3.180
-rw-r--r--net-firewall/iptables/files/1.3.1-files/install_ipv6_apps.patch13
3 files changed, 0 insertions, 160 deletions
diff --git a/net-firewall/iptables/files/1.3.1-files/grsecurity-1.2.8-iptables.patch-1.3.1 b/net-firewall/iptables/files/1.3.1-files/grsecurity-1.2.8-iptables.patch-1.3.1
deleted file mode 100644
index 61b3d0934730..000000000000
--- a/net-firewall/iptables/files/1.3.1-files/grsecurity-1.2.8-iptables.patch-1.3.1
+++ /dev/null
@@ -1,67 +0,0 @@
---- /dev/null
-+++ extensions/libipt_stealth.c
-@@ -0,0 +1,64 @@
-+/* Shared library add-on to iptables to add stealth support.
-+ * Copyright (C) 2002 Brad Spengler <spender@grsecurity.net>
-+ * This netfilter module is licensed under the GNU GPL.
-+ */
-+
-+#include <stdio.h>
-+#include <netdb.h>
-+#include <stdlib.h>
-+#include <getopt.h>
-+#include <iptables.h>
-+
-+/* Function which prints out usage message. */
-+static void
-+help(void)
-+{
-+ printf("stealth v%s takes no options\n\n", IPTABLES_VERSION);
-+}
-+
-+static struct option opts[] = {
-+ {0}
-+};
-+
-+/* Initialize the match. */
-+static void
-+init(struct ipt_entry_match *m, unsigned int *nfcache)
-+{
-+ *nfcache |= NFC_UNKNOWN;
-+}
-+
-+static int
-+parse(int c, char **argv, int invert, unsigned int *flags,
-+ const struct ipt_entry *entry,
-+ unsigned int *nfcache,
-+ struct ipt_entry_match **match)
-+{
-+ return 0;
-+}
-+
-+static void
-+final_check(unsigned int flags)
-+{
-+ return;
-+}
-+
-+static
-+struct iptables_match stealth = {
-+ .next = NULL,
-+ .name = "stealth",
-+ .version = IPTABLES_VERSION,
-+ .size = IPT_ALIGN(0),
-+ .userspacesize = IPT_ALIGN(0),
-+ .help = &help,
-+ .init = &init,
-+ .parse = &parse,
-+ .final_check = &final_check,
-+ .print = NULL,
-+ .save = NULL,
-+ .extra_opts = opts
-+};
-+
-+void _init(void)
-+{
-+ register_match(&stealth);
-+}
diff --git a/net-firewall/iptables/files/1.3.1-files/install_all_dev_files.patch-1.3.1 b/net-firewall/iptables/files/1.3.1-files/install_all_dev_files.patch-1.3.1
deleted file mode 100644
index d60b45385b87..000000000000
--- a/net-firewall/iptables/files/1.3.1-files/install_all_dev_files.patch-1.3.1
+++ /dev/null
@@ -1,80 +0,0 @@
---- iptables-1.3.1/Makefile
-+++ iptables-1.3.1/Makefile
-@@ -38,8 +38,10 @@
- CFLAGS += -DNO_SHARED_LIBS=1
- endif
-
--EXTRAS+=iptables iptables.o iptables.8
-+EXTRAS+=iptables iptables.o iptables.8 libiptables.a
- EXTRA_INSTALLS+=$(DESTDIR)$(BINDIR)/iptables $(DESTDIR)$(MANDIR)/man8/iptables.8
-+DEVEL_HEADERS+=include/iptables.h include/iptables_common.h
-+DEVEL_LIBS+=libiptables.a
-
- # No longer experimental.
- ifneq ($(DO_MULTI), 1)
-@@ -48,10 +50,12 @@
- EXTRA_INSTALLS+=$(DESTDIR)$(BINDIR)/iptables-save $(DESTDIR)$(BINDIR)/iptables-restore $(DESTDIR)$(MANDIR)/man8/iptables-restore.8 $(DESTDIR)$(MANDIR)/man8/iptables-save.8
-
- ifeq ($(DO_IPV6), 1)
--EXTRAS+=ip6tables ip6tables.o ip6tables.8
-+EXTRAS+=ip6tables ip6tables.o ip6tables.8 libip6tables.a
- EXTRA_INSTALLS+=$(DESTDIR)$(BINDIR)/ip6tables $(DESTDIR)$(MANDIR)/man8/ip6tables.8
- EXTRAS+=ip6tables-save ip6tables-restore
- EXTRA_INSTALLS+=$(DESTDIR)$(BINDIR)/ip6tables-save $(DESTDIR)$(BINDIR)/ip6tables-restore # $(DESTDIR)$(MANDIR)/man8/iptables-restore.8 $(DESTDIR)$(MANDIR)/man8/iptables-save.8 $(DESTDIR)$(MANDIR)/man8/ip6tables-save.8 $(DESTDIR)$(MANDIR)/man8/ip6tables-restore.8
-+DEVEL_HEADERS+=include/ip6tables.h
-+DEVEL_LIBS+=libip6tables.a
- endif
-
- # Sparc64 hack
-@@ -113,6 +117,8 @@
- print-extensions:
- @[ -n "$(OPTIONALS)" ] && echo Extensions found: $(OPTIONALS)
-
-+libiptables.a: libiptables.a(iptables.o)
-+
- iptables.o: iptables.c
- $(CC) $(CFLAGS) -DIPT_LIB_DIR=\"$(IPT_LIBDIR)\" -c -o $@ $<
-
-@@ -154,6 +160,8 @@
- cp $< $@
- endif
-
-+libip6tables.a: libip6tables.a(ip6tables.o)
-+
- ip6tables.o: ip6tables.c
- $(CC) $(CFLAGS) -DIP6T_LIB_DIR=\"$(IPT_LIBDIR)\" -c -o $@ $<
-
-@@ -202,7 +210,7 @@
- .PHONY: install-devel-headers
- install-devel-headers: $(DEVEL_HEADERS)
- @[ -d $(DESTDIR)$(INCDIR) ] || mkdir -p $(DESTDIR)$(INCDIR)
-- @cp -v $(DEVEL_HEADERS) $(DESTDIR)$(INCDIR)
-+ @cp -v --parents $(DEVEL_HEADERS) `echo $(DESTDIR)$(INCDIR) | sed -e "s:/include/\?::"`
-
- .PHONY: install-devel-libs
- install-devel-libs: $(DEVEL_LIBS)
---- iptables-1.3.1/libipq/Makefile
-+++ iptables-1.3.1/libipq/Makefile
-@@ -17,7 +17,7 @@
-
- DEVEL_LIBS+=libipq/libipq.a
-
--DEVEL_HEADERS+=include/libipq/libipq.h
-+DEVEL_HEADERS+=include/libipq/libipq.h include/libipq/ip_queue_64.h
-
- ifndef TOPLEVEL_INCLUDED
- local:
---- iptables-1.3.1/libiptc/Makefile
-+++ iptables-1.3.1/libiptc/Makefile
-@@ -16,8 +16,11 @@
- ifeq ($(DO_IPV6), 1)
- EXTRA_DEPENDS+= libiptc/libip6tc.d
- libiptc/libiptc.a: libiptc/libiptc.a(libiptc/libip6tc.o)
-+DEVEL_HEADERS+=include/libiptc/libip6tc.h
- endif
-
-+DEVEL_HEADERS+=include/libiptc/libiptc.h include/libiptc/ipt_kernel_headers.h
-+
- libiptc/libip4tc.d libiptc/libip6tc.d: %.d: %.c
- @-$(CC) -M -MG $(CFLAGS) $< | sed -e 's@^.*\.o:@$*.d libiptc/libiptc.a($*.o):@' > $@
- endif
diff --git a/net-firewall/iptables/files/1.3.1-files/install_ipv6_apps.patch b/net-firewall/iptables/files/1.3.1-files/install_ipv6_apps.patch
deleted file mode 100644
index ac5357283575..000000000000
--- a/net-firewall/iptables/files/1.3.1-files/install_ipv6_apps.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- Makefile
-+++ Makefile
-@@ -63,8 +63,8 @@
- ifeq ($(DO_IPV6), 1)
- EXTRAS+=ip6tables ip6tables.o
- EXTRA_INSTALLS+=$(DESTDIR)$(BINDIR)/ip6tables $(DESTDIR)$(MANDIR)/man8/ip6tables.8
--EXTRAS_EXP+=ip6tables-save ip6tables-restore
--EXTRA_INSTALLS_EXP+=$(DESTDIR)$(BINDIR)/ip6tables-save $(DESTDIR)$(BINDIR)/ip6tables-restore # $(DESTDIR)$(MANDIR)/man8/iptables-restore.8 $(DESTDIR)$(MANDIR)/man8/iptables-save.8 $(DESTDIR)$(MANDIR)/man8/ip6tables-save.8 $(DESTDIR)$(MANDIR)/man8/ip6tables-restore.8
-+EXTRAS+=ip6tables-save ip6tables-restore
-+EXTRA_INSTALLS+=$(DESTDIR)$(BINDIR)/ip6tables-save $(DESTDIR)$(BINDIR)/ip6tables-restore # $(DESTDIR)$(MANDIR)/man8/iptables-restore.8 $(DESTDIR)$(MANDIR)/man8/iptables-save.8 $(DESTDIR)$(MANDIR)/man8/ip6tables-save.8 $(DESTDIR)$(MANDIR)/man8/ip6tables-restore.8
- endif
-
- # Sparc64 hack