summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2011-06-16 12:32:39 +0000
committerPeter Volkov <pva@gentoo.org>2011-06-16 12:32:39 +0000
commitfe3c371e1a2ab99340a15fdcd869bcc168aaf073 (patch)
tree4737b211999367203342d5003d64ca806e9469c4 /net-firewall/ipset
parentAdd version 0.75. Use systemd eclass (diff)
downloadgentoo-2-fe3c371e1a2ab99340a15fdcd869bcc168aaf073.tar.gz
gentoo-2-fe3c371e1a2ab99340a15fdcd869bcc168aaf073.tar.bz2
gentoo-2-fe3c371e1a2ab99340a15fdcd869bcc168aaf073.zip
Add missing xt_set and ip_set_hash_netiface modules. Drop old.
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'net-firewall/ipset')
-rw-r--r--net-firewall/ipset/ChangeLog8
-rw-r--r--net-firewall/ipset/ipset-6.4.ebuild102
-rw-r--r--net-firewall/ipset/ipset-6.6.ebuild106
-rw-r--r--net-firewall/ipset/ipset-6.7-r1.ebuild (renamed from net-firewall/ipset/ipset-6.7.ebuild)6
4 files changed, 10 insertions, 212 deletions
diff --git a/net-firewall/ipset/ChangeLog b/net-firewall/ipset/ChangeLog
index 9e5de8d00548..04ca19516528 100644
--- a/net-firewall/ipset/ChangeLog
+++ b/net-firewall/ipset/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-firewall/ipset
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipset/ChangeLog,v 1.46 2011/06/16 11:22:44 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipset/ChangeLog,v 1.47 2011/06/16 12:32:39 pva Exp $
+
+*ipset-6.7-r1 (16 Jun 2011)
+
+ 16 Jun 2011; Peter Volkov <pva@gentoo.org> -ipset-6.4.ebuild,
+ -ipset-6.6.ebuild, -ipset-6.7.ebuild, +ipset-6.7-r1.ebuild:
+ Add missing xt_set and ip_set_hash_netiface modules. Drop old.
*ipset-6.7 (16 Jun 2011)
diff --git a/net-firewall/ipset/ipset-6.4.ebuild b/net-firewall/ipset/ipset-6.4.ebuild
deleted file mode 100644
index 36efa6c1d55b..000000000000
--- a/net-firewall/ipset/ipset-6.4.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipset/ipset-6.4.ebuild,v 1.3 2011/05/15 11:44:10 pva Exp $
-
-EAPI="4"
-
-inherit autotools linux-info linux-mod
-
-DESCRIPTION="IPset tool for iptables, successor to ippool."
-HOMEPAGE="http://ipset.netfilter.org/"
-SRC_URI="http://ipset.netfilter.org/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="modules"
-
-RDEPEND=">=net-firewall/iptables-1.4.4
- net-libs/libmnl"
-DEPEND="${RDEPEND}"
-
-# configurable from outside, e.g. /etc/make.conf
-IP_NF_SET_MAX=${IP_NF_SET_MAX:-256}
-
-BUILD_TARGETS="modules"
-MODULE_NAMES_ARG="kernel/net/netfilter/ipset/:${S}/kernel/net/netfilter/ipset"
-MODULE_NAMES=""
-for i in ip_set{,_bitmap_{ip{,mac},port},_hash_{ip{,port{,ip,net}},net,netport},_list_set}; do
- MODULE_NAMES+=" ${i}(${MODULE_NAMES_ARG})"
-done
-CONFIG_CHECK="NETFILTER IP6_NF_IPTABLES"
-ERROR_CFG="ipset requires netfilter support in your kernel."
-
-check_header_patch() {
- if ! $(grep -q NFNL_SUBSYS_IPSET "${KV_DIR}/include/linux/netfilter/nfnetlink.h"); then
- eerror "Sorry, but you have to patch kernel sources with the following patch:"
- eerror " # cd ${KV_DIR}"
- eerror " # patch -i ${S}/netlink.patch -p1"
- eerror "You do not need to recompile your kernel."
- die "Unpatched kernel"
- fi
-}
-
-pkg_setup() {
- get_version
-
- build_modules=0
- if use modules; then
- kernel_is -lt 2 6 34 && die "${PN} requires kernel greater then 2.6.34."
- if linux_config_src_exists && linux_chkconfig_builtin "MODULES" ; then
- if linux_chkconfig_builtin "IP_NF_SET"; then #274577
- einfo "Modular kernel detected but IP_NF_SET=y, will not build kernel modules"
- else
- if kernel_is -gt 2 6 39; then
- einfo "This kernel has modules inside, will not build kernel modules"
- else
- einfo "Modular kernel detected, will build kernel modules"
- build_modules=1
- fi
- fi
- else
- einfo "Nonmodular kernel detected, will not build kernel modules"
- fi
- fi
-
- [[ ${build_modules} -eq 1 ]] && linux-mod_pkg_setup
-}
-
-src_prepare() {
- [[ ${build_modules} -eq 1 ]] && check_header_patch
- eautoreconf
-}
-
-src_configure() {
- econf \
- --with-maxsets=${IP_NF_SET_MAX} \
- --libdir=${EPREFIX}/$(get_libdir) \
- --with-kbuild=${KV_DIR} \
- --disable-static
-}
-
-src_compile() {
- einfo "Building userspace"
- emake
-
- if [[ ${build_modules} -eq 1 ]]; then
- einfo "Building kernel modules"
- set_arch_to_kernel
- emake modules
- fi
-}
-
-src_install() {
- einfo "Installing userspace"
- emake DESTDIR=${D} install
-
- if [[ ${build_modules} -eq 1 ]]; then
- einfo "Installing kernel modules"
- linux-mod_src_install
- fi
- find "${ED}" -name '*.la' -exec rm -f '{}' +
-}
diff --git a/net-firewall/ipset/ipset-6.6.ebuild b/net-firewall/ipset/ipset-6.6.ebuild
deleted file mode 100644
index 9d2feb2ae144..000000000000
--- a/net-firewall/ipset/ipset-6.6.ebuild
+++ /dev/null
@@ -1,106 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipset/ipset-6.6.ebuild,v 1.1 2011/05/24 13:04:10 pva Exp $
-
-EAPI="4"
-inherit autotools linux-info linux-mod
-
-DESCRIPTION="IPset tool for iptables, successor to ippool."
-HOMEPAGE="http://ipset.netfilter.org/"
-SRC_URI="http://ipset.netfilter.org/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="modules"
-
-RDEPEND=">=net-firewall/iptables-1.4.4
- net-libs/libmnl"
-DEPEND="${RDEPEND}"
-
-# configurable from outside, e.g. /etc/make.conf
-IP_NF_SET_MAX=${IP_NF_SET_MAX:-256}
-
-BUILD_TARGETS="modules"
-MODULE_NAMES_ARG="kernel/net/netfilter/ipset/:${S}/kernel/net/netfilter/ipset"
-MODULE_NAMES=""
-for i in ip_set{,_bitmap_{ip{,mac},port},_hash_{ip{,port{,ip,net}},net,netport},_list_set}; do
- MODULE_NAMES+=" ${i}(${MODULE_NAMES_ARG})"
-done
-CONFIG_CHECK="NETFILTER IP6_NF_IPTABLES"
-ERROR_CFG="ipset requires netfilter support in your kernel."
-
-check_header_patch() {
- if ! $(grep -q NFNL_SUBSYS_IPSET "${KV_DIR}/include/linux/netfilter/nfnetlink.h"); then
- eerror "Sorry, but you have to patch kernel sources with the following patch:"
- eerror " # cd ${KV_DIR}"
- eerror " # patch -i ${S}/netlink.patch -p1"
- eerror "You do not need to recompile your kernel."
- die "Unpatched kernel"
- fi
-}
-
-pkg_setup() {
- get_version
-
- build_modules=0
- if use modules; then
- kernel_is -lt 2 6 34 && die "${PN} requires kernel greater then 2.6.34."
- if linux_config_src_exists && linux_chkconfig_builtin "MODULES" ; then
- if linux_chkconfig_builtin "IP_NF_SET"; then #274577
- einfo "Modular kernel detected but IP_NF_SET=y, will not build kernel modules"
- else
- if kernel_is -gt 2 6 39; then
- einfo "This kernel has modules inside, will not build kernel modules"
- else
- einfo "Modular kernel detected, will build kernel modules"
- build_modules=1
- fi
- fi
- else
- einfo "Nonmodular kernel detected, will not build kernel modules"
- fi
- fi
-
- [[ ${build_modules} -eq 1 ]] && linux-mod_pkg_setup
-}
-
-src_prepare() {
- [[ ${build_modules} -eq 1 ]] && check_header_patch
- eautoreconf
-}
-
-src_configure() {
- econf \
- --with-maxsets=${IP_NF_SET_MAX} \
- --libdir=${EPREFIX}/$(get_libdir) \
- --with-kbuild=${KV_DIR}
-}
-
-src_compile() {
- einfo "Building userspace"
- emake
-
- if [[ ${build_modules} -eq 1 ]]; then
- einfo "Building kernel modules"
- set_arch_to_kernel
- emake modules
- fi
-}
-
-src_install() {
- einfo "Installing userspace"
- emake DESTDIR=${D} install
-
- if [[ ${build_modules} -eq 1 ]]; then
- einfo "Installing kernel modules"
- linux-mod_src_install
- fi
- find "${ED}" \( -name '*.la' -o -name '*.a' \) -exec rm -f '{}' +
-}
-
-pkg_postinst() {
- linux-mod_pkg_postinst
- elog "Note you need to rebuid and run kernel with netlink.patch or you'll get error:"
- elog "Kernel error received: Invalid argument"
-}
diff --git a/net-firewall/ipset/ipset-6.7.ebuild b/net-firewall/ipset/ipset-6.7-r1.ebuild
index 2de44c34de79..13fd83a0b9f2 100644
--- a/net-firewall/ipset/ipset-6.7.ebuild
+++ b/net-firewall/ipset/ipset-6.7-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipset/ipset-6.7.ebuild,v 1.1 2011/06/16 11:22:44 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipset/ipset-6.7-r1.ebuild,v 1.1 2011/06/16 12:32:39 pva Exp $
EAPI="4"
inherit autotools linux-info linux-mod
@@ -23,8 +23,8 @@ IP_NF_SET_MAX=${IP_NF_SET_MAX:-256}
BUILD_TARGETS="modules"
MODULE_NAMES_ARG="kernel/net/netfilter/ipset/:${S}/kernel/net/netfilter/ipset"
-MODULE_NAMES=""
-for i in ip_set{,_bitmap_{ip{,mac},port},_hash_{ip{,port{,ip,net}},net,netport},_list_set}; do
+MODULE_NAMES="xt_set(kernel/net/netfilter/ipset/:${S}/kernel/net/netfilter/)"
+for i in ip_set{,_bitmap_{ip{,mac},port},_hash_{ip{,port{,ip,net}},net,net{port,iface}},_list_set}; do
MODULE_NAMES+=" ${i}(${MODULE_NAMES_ARG})"
done
CONFIG_CHECK="NETFILTER IP6_NF_IPTABLES"