summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2007-04-12 18:37:15 +0000
committerStefan Schweizer <genstef@gentoo.org>2007-04-12 18:37:15 +0000
commitc66c0535375ab1dcb0bc08d84ad9b87d50859357 (patch)
tree5903e2d8f698ce3d2ac4d57dc4efd55ea8d5e171 /net-firewall/ipset
parentStable on sparc wrt #174312 (diff)
downloadgentoo-2-c66c0535375ab1dcb0bc08d84ad9b87d50859357.tar.gz
gentoo-2-c66c0535375ab1dcb0bc08d84ad9b87d50859357.tar.bz2
gentoo-2-c66c0535375ab1dcb0bc08d84ad9b87d50859357.zip
Remove old version that uses check_KV, bug 150058
(Portage version: 2.1.2-r12)
Diffstat (limited to 'net-firewall/ipset')
-rw-r--r--net-firewall/ipset/ChangeLog6
-rw-r--r--net-firewall/ipset/files/digest-ipset-2.1.0.200501193
-rw-r--r--net-firewall/ipset/ipset-2.1.0.20050119.ebuild65
3 files changed, 5 insertions, 69 deletions
diff --git a/net-firewall/ipset/ChangeLog b/net-firewall/ipset/ChangeLog
index 1491f115cf93..f4c3c928d3ea 100644
--- a/net-firewall/ipset/ChangeLog
+++ b/net-firewall/ipset/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-firewall/ipset
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipset/ChangeLog,v 1.9 2007/04/10 10:12:08 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipset/ChangeLog,v 1.10 2007/04/12 18:37:15 genstef Exp $
+
+ 12 Apr 2007; Stefan Schweizer <genstef@gentoo.org>
+ -ipset-2.1.0.20050119.ebuild:
+ Remove old version that uses check_KV, bug 150058
*ipset-2.2.9.20070401 (10 Apr 2007)
diff --git a/net-firewall/ipset/files/digest-ipset-2.1.0.20050119 b/net-firewall/ipset/files/digest-ipset-2.1.0.20050119
deleted file mode 100644
index c9954fa559f2..000000000000
--- a/net-firewall/ipset/files/digest-ipset-2.1.0.20050119
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 9f1b9c36d37eb8371c83b5610362d16d ipset-2.1.0-20050119.tar.bz2 23821
-RMD160 315f62e029237beb328dab54e28a0178f6b91ea0 ipset-2.1.0-20050119.tar.bz2 23821
-SHA256 23cfac9c5f08453f3b3567adc4ed4c3d4055da6f25be56c251eb7785e81aa8a6 ipset-2.1.0-20050119.tar.bz2 23821
diff --git a/net-firewall/ipset/ipset-2.1.0.20050119.ebuild b/net-firewall/ipset/ipset-2.1.0.20050119.ebuild
deleted file mode 100644
index b5c8cdbd6e3d..000000000000
--- a/net-firewall/ipset/ipset-2.1.0.20050119.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipset/ipset-2.1.0.20050119.ebuild,v 1.3 2005/05/06 14:34:48 swegener Exp $
-
-inherit eutils flag-o-matic versionator
-
-MY_PV="$(replace_version_separator 3 '-' )"
-MY_P="${PN}-${MY_PV}"
-DESCRIPTION="IPset tool for iptables, successor to ippool."
-HOMEPAGE="http://people.netfilter.org/kadlec/ipset/"
-SRC_URI="${HOMEPAGE}/${MY_P}.tar.bz2"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86 ~amd64"
-IUSE=""
-RDEPEND=">=net-firewall/iptables-1.3"
-DEPEND="${RDEPEND}
- virtual/linux-sources"
-S="${WORKDIR}/${PN}"
-
-pkg_setup() {
- ewarn "If your kernel sources do not contain the IPset functionality,"
- ewarn "this package may file to compile."
-}
-
-src_defs() {
- # these are used in both of src_compile and src_install
- myconf="${myconf} PREFIX="
- myconf="${myconf} LIBDIR=/lib"
- myconf="${myconf} BINDIR=/sbin"
- myconf="${myconf} MANDIR=/usr/share/man"
- myconf="${myconf} INCDIR=/usr/include"
- export myconf
-}
-
-src_compile() {
- src_defs
-
- # for some reason, it doesn't behave right if this is skipped
- replace-flags -O0 -O2
- if [ -z `get-flag O` ]; then
- append-flags -O2
- fi
-
- # see iptables ebuild, as this code links against it
- filter-flags "-fstack-protector"
-
- if [ -L ${ROOT}/usr/src/linux -o -d ${ROOT}/usr/src/linux ]; then
- check_KV
- else
- die "ipset requires your patched kernel source to be at /usr/src/linux!"
- fi
-
- # now build it
- emake COPT_FLAGS="${CFLAGS}" ${myconf} \
- KERNEL_DIR=/usr/src/linux \
- || die "failed to build"
-}
-
-src_install() {
- src_defs
- emake DESTDIR="${D}" ${myconf} \
- KERNEL_DIR=/usr/src/linux \
- install || die "failed to package"
-}