summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2005-12-12 08:10:43 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2005-12-12 08:10:43 +0000
commit8b28b1945158edfb18dacc43b130b21cfc4d1207 (patch)
tree4a5e88d069cc374c447e041529cad2270cd5b457 /net-firewall/ipset
parentVersion bump. (diff)
downloadgentoo-2-8b28b1945158edfb18dacc43b130b21cfc4d1207.tar.gz
gentoo-2-8b28b1945158edfb18dacc43b130b21cfc4d1207.tar.bz2
gentoo-2-8b28b1945158edfb18dacc43b130b21cfc4d1207.zip
Version bump.
(Portage version: 2.0.53)
Diffstat (limited to 'net-firewall/ipset')
-rw-r--r--net-firewall/ipset/ChangeLog8
-rw-r--r--net-firewall/ipset/Manifest10
-rw-r--r--net-firewall/ipset/files/digest-ipset-2.2.8.200512031
-rw-r--r--net-firewall/ipset/ipset-2.2.8.20051203.ebuild61
4 files changed, 75 insertions, 5 deletions
diff --git a/net-firewall/ipset/ChangeLog b/net-firewall/ipset/ChangeLog
index 56a3fa04b70d..62e43d806e79 100644
--- a/net-firewall/ipset/ChangeLog
+++ b/net-firewall/ipset/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-firewall/ipset
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipset/ChangeLog,v 1.5 2005/09/26 04:29:20 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipset/ChangeLog,v 1.6 2005/12/12 08:10:43 robbat2 Exp $
+
+*ipset-2.2.8.20051203 (12 Dec 2005)
+
+ 12 Dec 2005; Robin H. Johnson <robbat2@gentoo.org>
+ +ipset-2.2.8.20051203.ebuild:
+ Version bump.
26 Sep 2005; Robin H. Johnson <robbat2@gentoo.org>
ipset-2.1.0.20050119-r1.ebuild:
diff --git a/net-firewall/ipset/Manifest b/net-firewall/ipset/Manifest
index 49189062a0a4..3e030a0d5266 100644
--- a/net-firewall/ipset/Manifest
+++ b/net-firewall/ipset/Manifest
@@ -1,6 +1,8 @@
-MD5 8c5675e36f2f7d393dd634e387f538d6 ipset-2.1.0.20050119.ebuild 1711
-MD5 81097c0394419fcc18c0d10d5e11bca7 ipset-2.1.0.20050119-r1.ebuild 1608
MD5 a6be5b32657b9c804e789eb54b62e705 ChangeLog 974
-MD5 21cd68602737d7c996bceabf6e62c468 metadata.xml 223
-MD5 eeb0a192ff8d4aa8efabfbae1e3ccf7c files/digest-ipset-2.1.0.20050119-r1 72
MD5 eeb0a192ff8d4aa8efabfbae1e3ccf7c files/digest-ipset-2.1.0.20050119 72
+MD5 eeb0a192ff8d4aa8efabfbae1e3ccf7c files/digest-ipset-2.1.0.20050119-r1 72
+MD5 0990e81a95b5c9cc55cdbe3cb984d160 files/digest-ipset-2.2.8.20051203 72
+MD5 81097c0394419fcc18c0d10d5e11bca7 ipset-2.1.0.20050119-r1.ebuild 1608
+MD5 8c5675e36f2f7d393dd634e387f538d6 ipset-2.1.0.20050119.ebuild 1711
+MD5 00226af8c9a870974ca0cbc0b8ac8871 ipset-2.2.8.20051203.ebuild 1609
+MD5 21cd68602737d7c996bceabf6e62c468 metadata.xml 223
diff --git a/net-firewall/ipset/files/digest-ipset-2.2.8.20051203 b/net-firewall/ipset/files/digest-ipset-2.2.8.20051203
new file mode 100644
index 000000000000..67287591f8dc
--- /dev/null
+++ b/net-firewall/ipset/files/digest-ipset-2.2.8.20051203
@@ -0,0 +1 @@
+MD5 a638af2788ce9e41e07dbe89311c0914 ipset-2.2.8-20051203.tar.bz2 27392
diff --git a/net-firewall/ipset/ipset-2.2.8.20051203.ebuild b/net-firewall/ipset/ipset-2.2.8.20051203.ebuild
new file mode 100644
index 000000000000..06fd2a41f7b5
--- /dev/null
+++ b/net-firewall/ipset/ipset-2.2.8.20051203.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipset/ipset-2.2.8.20051203.ebuild,v 1.1 2005/12/12 08:10:43 robbat2 Exp $
+
+inherit eutils flag-o-matic versionator linux-info
+
+MY_PV="$(replace_version_separator 3 '-' )"
+MY_P="${PN}-${MY_PV}"
+DESCRIPTION="IPset tool for iptables, successor to ippool."
+HOMEPAGE="http://people.netfilter.org/kadlec/ipset/"
+SRC_URI="${HOMEPAGE}/${MY_P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+RDEPEND=">=net-firewall/iptables-1.3"
+DEPEND="${RDEPEND}
+ virtual/linux-sources"
+S="${WORKDIR}/${PN}"
+CONFIG_CHECK="IP_NF_SET"
+
+pkg_setup() {
+ ewarn "If your kernel sources do not contain the IPset functionality,"
+ ewarn "this package may fail to compile."
+ linux-info_pkg_setup
+}
+
+src_defs() {
+ # these are used in both of src_compile and src_install
+ myconf="${myconf} PREFIX="
+ myconf="${myconf} LIBDIR=/lib"
+ myconf="${myconf} BINDIR=/sbin"
+ myconf="${myconf} MANDIR=/usr/share/man"
+ myconf="${myconf} INCDIR=/usr/include"
+ export myconf
+}
+
+src_compile() {
+ src_defs
+
+ # for some reason, it doesn't behave right if this is skipped
+ replace-flags -O0 -O2
+ if [ -z `get-flag O` ]; then
+ append-flags -O2
+ fi
+
+ # see iptables ebuild, as this code links against it
+ filter-flags "-fstack-protector"
+
+ # now build it
+ emake COPT_FLAGS="${CFLAGS}" ${myconf} \
+ KERNEL_DIR="${KERNEL_DIR}" \
+ || die "failed to build"
+}
+
+src_install() {
+ src_defs
+ emake DESTDIR="${D}" ${myconf} \
+ KERNEL_DIR="${KERNEL_DIR}" \
+ install || die "failed to package"
+}