summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2012-08-20 05:19:02 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2012-08-20 05:19:02 +0000
commit2d6e5909d48bcaeba38a1c46aee5af64f01af1c4 (patch)
treebb92499df6895e89009f47e96716eef909b88ef0 /net-firewall/ipset
parentMake sure not to depend on automake (not required). (diff)
downloadgentoo-2-2d6e5909d48bcaeba38a1c46aee5af64f01af1c4.tar.gz
gentoo-2-2d6e5909d48bcaeba38a1c46aee5af64f01af1c4.tar.bz2
gentoo-2-2d6e5909d48bcaeba38a1c46aee5af64f01af1c4.zip
Bug #431456, #418019: version bump. Bug #429814: ensure compile with no /usr/src/linux. Bug #396097 is fixed by upstream as well.
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'net-firewall/ipset')
-rw-r--r--net-firewall/ipset/ChangeLog9
-rw-r--r--net-firewall/ipset/ipset-6.13.ebuild111
2 files changed, 118 insertions, 2 deletions
diff --git a/net-firewall/ipset/ChangeLog b/net-firewall/ipset/ChangeLog
index b3a43dddbc5b..95f35c011d29 100644
--- a/net-firewall/ipset/ChangeLog
+++ b/net-firewall/ipset/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-firewall/ipset
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipset/ChangeLog,v 1.59 2012/06/14 05:57:20 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipset/ChangeLog,v 1.60 2012/08/20 05:19:02 robbat2 Exp $
+
+*ipset-6.13 (20 Aug 2012)
+
+ 20 Aug 2012; Robin H. Johnson <robbat2@gentoo.org> +ipset-6.13.ebuild:
+ Bug #431456, #418019: version bump. Bug #429814: ensure compile with no
+ /usr/src/linux. Bug #396097 is fixed by upstream as well.
14 Jun 2012; Michael Weber <xmw@gentoo.org> ipset-6.11.ebuild:
adding ~ppc keyword (bug 304037)
@@ -306,4 +312,3 @@
10 Mar 2005; Robin H. Johnson <robbat2@gentoo.org> +metadata.xml,
+ipset-2.1.0.20050119.ebuild:
Initial commit, ebuild by Robin H. Johnson <robbat2@gentoo.org>.
-
diff --git a/net-firewall/ipset/ipset-6.13.ebuild b/net-firewall/ipset/ipset-6.13.ebuild
new file mode 100644
index 000000000000..d5cf60a92e63
--- /dev/null
+++ b/net-firewall/ipset/ipset-6.13.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipset/ipset-6.13.ebuild,v 1.1 2012/08/20 05:19:02 robbat2 Exp $
+
+EAPI="4"
+inherit autotools linux-info linux-mod
+
+# Maintainer: with version bump take a look on:
+# http://git.netfilter.org/cgi-bin/gitweb.cgi?p=ipset.git;a=commit;h=70fdf030545f00888bcebb5fca8243a6dccca95b
+
+DESCRIPTION="IPset tool for iptables, successor to ippool."
+HOMEPAGE="http://ipset.netfilter.org/"
+SRC_URI="http://ipset.netfilter.org/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="modules"
+
+RDEPEND=">=net-firewall/iptables-1.4.4
+ net-libs/libmnl"
+DEPEND="${RDEPEND}"
+
+# configurable from outside, e.g. /etc/make.conf
+IP_NF_SET_MAX=${IP_NF_SET_MAX:-256}
+
+BUILD_TARGETS="modules"
+MODULE_NAMES_ARG="kernel/net/netfilter/ipset/:${S}/kernel/net/netfilter/ipset"
+MODULE_NAMES="xt_set(kernel/net/netfilter/ipset/:${S}/kernel/net/netfilter/)"
+for i in ip_set{,_bitmap_{ip{,mac},port},_hash_{ip{,port{,ip,net}},net,net{port,iface}},_list_set}; do
+ MODULE_NAMES+=" ${i}(${MODULE_NAMES_ARG})"
+done
+
+check_header_patch() {
+ if ! $(grep -q NFNL_SUBSYS_IPSET "${KV_DIR}/include/linux/netfilter/nfnetlink.h"); then
+ eerror "Sorry, but you have to patch kernel sources with the following patch:"
+ eerror " # cd ${KV_DIR}"
+ eerror " # patch -i ${S}/netlink.patch -p1"
+ eerror "You should recompile and run new kernel to avoid runtime errors."
+ die "Unpatched kernel"
+ fi
+}
+
+pkg_setup() {
+ get_version
+ CONFIG_CHECK="NETFILTER"
+ ERROR_NETFILTER="ipset requires NETFILTER support in your kernel."
+
+ build_modules=0
+ if use modules; then
+ kernel_is -lt 2 6 35 && die "${PN} requires kernel greater then 2.6.35."
+ if linux_config_src_exists && linux_chkconfig_builtin "MODULES" ; then
+ if linux_chkconfig_present "IP_NF_SET" || \
+ linux_chkconfig_present "IP_SET"; then #274577
+ eerror "There is IP{,_NF}_SET or NETFILTER_XT_SET support in your kernel."
+ eerror "Please either build ipset with modules USE flag disabled"
+ eerror "or rebuild kernel without IP_SET support and make sure"
+ eerror "there is NO kernel ip_set* modules in /lib/modules/<your_kernel>/... ."
+ die "USE=modules and in-kernel ipset support detected."
+ else
+ einfo "Modular kernel detected. Gonna build kernel modules..."
+ build_modules=1
+ fi
+ else
+ eerror "Nonmodular kernel detected, but USE=modules. Either build"
+ eerror "modular kernel (without IP_SET) or disable USE=modules"
+ die "Nonmodular kernel detected, will not build kernel modules"
+ fi
+ fi
+ [[ ${build_modules} -eq 1 ]] && linux-mod_pkg_setup
+}
+
+src_prepare() {
+ [[ ${build_modules} -eq 1 ]] && check_header_patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with modules kmod) \
+ --with-maxsets=${IP_NF_SET_MAX} \
+ --libdir="${EPREFIX}"/$(get_libdir) \
+ --with-ksource="${KV_DIR}" \
+ --with-kbuild="${KV_OUT_DIR}"
+}
+
+src_compile() {
+ einfo "Building userspace"
+ emake
+
+ if [[ ${build_modules} -eq 1 ]]; then
+ einfo "Building kernel modules"
+ set_arch_to_kernel
+ emake modules
+ fi
+}
+
+src_install() {
+ einfo "Installing userspace"
+ emake DESTDIR="${D}" install
+
+ if [[ ${build_modules} -eq 1 ]]; then
+ einfo "Installing kernel modules"
+ linux-mod_src_install
+ fi
+
+ newinitd ${FILESDIR}/ipset.initd-r2 ${PN}
+ newconfd ${FILESDIR}/ipset.confd ${PN}
+ keepdir /var/lib/ipset
+ find "${ED}" \( -name '*.la' -o -name '*.a' \) -exec rm -f '{}' +
+}