summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2009-11-14 08:20:30 +0000
committerPeter Volkov <pva@gentoo.org>2009-11-14 08:20:30 +0000
commit2487baa6076c0b5564af876dfdb896af1355e97c (patch)
tree1895da94783d547faa1f0b8fa3c64f155166acf3 /net-firewall/ipset
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-2487baa6076c0b5564af876dfdb896af1355e97c.tar.gz
gentoo-2-2487baa6076c0b5564af876dfdb896af1355e97c.tar.bz2
gentoo-2-2487baa6076c0b5564af876dfdb896af1355e97c.zip
Version bump, bug #293043, thank Marcin Mirosław for report.
(Portage version: 2.1.7.4/cvs/Linux x86_64)
Diffstat (limited to 'net-firewall/ipset')
-rw-r--r--net-firewall/ipset/ChangeLog8
-rw-r--r--net-firewall/ipset/ipset-2.4.9-r1.ebuild94
-rw-r--r--net-firewall/ipset/ipset-4.1.ebuild (renamed from net-firewall/ipset/ipset-2.5.0-r1.ebuild)32
3 files changed, 24 insertions, 110 deletions
diff --git a/net-firewall/ipset/ChangeLog b/net-firewall/ipset/ChangeLog
index d30576584989..766a31555242 100644
--- a/net-firewall/ipset/ChangeLog
+++ b/net-firewall/ipset/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-firewall/ipset
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipset/ChangeLog,v 1.30 2009/09/06 21:15:43 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipset/ChangeLog,v 1.31 2009/11/14 08:20:30 pva Exp $
+
+*ipset-4.1 (14 Nov 2009)
+
+ 14 Nov 2009; Peter Volkov <pva@gentoo.org> -ipset-2.4.9-r1.ebuild,
+ -ipset-2.5.0-r1.ebuild, +ipset-4.1.ebuild:
+ Version bump, bug #293043, thank Marcin Mirosław for report.
06 Sep 2009; Robin H. Johnson <robbat2@gentoo.org> ipset-2.4.7.ebuild,
ipset-2.4.9-r1.ebuild, ipset-2.5.0-r1.ebuild, ipset-3.0.ebuild:
diff --git a/net-firewall/ipset/ipset-2.4.9-r1.ebuild b/net-firewall/ipset/ipset-2.4.9-r1.ebuild
deleted file mode 100644
index a7b730237bfd..000000000000
--- a/net-firewall/ipset/ipset-2.4.9-r1.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipset/ipset-2.4.9-r1.ebuild,v 1.2 2009/09/06 21:15:43 robbat2 Exp $
-
-inherit eutils versionator toolchain-funcs linux-mod
-
-DESCRIPTION="IPset tool for iptables, successor to ippool."
-HOMEPAGE="http://ipset.netfilter.org/"
-SRC_URI="http://ipset.netfilter.org/${P}.tar.bz2"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-RDEPEND=">=net-firewall/iptables-1.4.1"
-DEPEND="${RDEPEND}"
-
-# configurable from outside
-[ -z "${IP_NF_SET_MAX}" ] && IP_NF_SET_MAX=256
-[ -z "${IP_NF_SET_HASHSIZE}" ] && IP_NF_SET_HASHSIZE=1024
-BUILD_PARAMS="IP_NF_SET_MAX=$IP_NF_SET_MAX IP_NF_SET_HASHSIZE=${IP_NF_SET_HASHSIZE}"
-# module fun
-BUILD_TARGETS="all"
-MODULE_NAMES_ARG="kernel/net/ipv4/netfilter:${S}/kernel"
-MODULE_NAMES=""
-for i in ip_set{,_{{ip,port,macip}map,{ip,net,ipport}hash,iptree{,map}}} \
- ipt_{SET,set}; do
- MODULE_NAMES="${MODULE_NAMES} ${i}(${MODULE_NAMES_ARG})"
-done
-# sanity
-CONFIG_CHECK="NETFILTER"
-ERROR_CFG="ipset needs netfilter support in your kernel."
-
-src_unpack() {
- unpack ${A}
- sed -i \
- -e 's/KERNELDIR/(KERNELDIR)/g' \
- -e 's/^(\?KERNEL_\?DIR.*/KERNELDIR ?= /' \
- -e '/^all::/iV ?= 0' \
- -e '/^all::/iKBUILD_OUTPUT ?=' \
- -e '/$(MAKE)/{s/$@/ V=$(V) KBUILD_OUTPUT=$(KBUILD_OUTPUT) modules/}' \
- "${S}"/kernel/Makefile
-
- cd "${S}"
- epatch "${FILESDIR}/${PN}-2.4.7-LDFLAGS.patch"
- epatch "${FILESDIR}/${PN}-2.4.9-gethostbyname-align.patch"
-}
-
-pkg_setup() {
- get_version
-
- modules=0
- msg=''
- if linux_chkconfig_builtin "MODULES" ; then
- modules=1
- msg="Modular kernel detected, will build kernel modules"
- else
- msg="Nonmodular kernel detected, will not build kernel modules"
- fi
- einfo "${msg}"
-
- [[ $modules -eq 1 ]] && \
- linux-mod_pkg_setup
- myconf="${myconf} PREFIX="
- myconf="${myconf} LIBDIR=/$(get_libdir)"
- myconf="${myconf} BINDIR=/sbin"
- myconf="${myconf} MANDIR=/usr/share/man"
- myconf="${myconf} INCDIR=/usr/include"
- myconf="${myconf} NO_EXTRA_WARN_FLAGS=yes"
- export myconf
-}
-
-src_compile() {
- einfo "Building userspace"
- emake CC="$(tc-getCC)" COPT_FLAGS="${CFLAGS}" ${myconf} binaries || die "failed to build"
-
- if [[ $modules -eq 1 ]]; then
- einfo "Building kernel modules"
- cd "${S}/kernel"
- export KERNELDIR="${KERNEL_DIR}"
- linux-mod_src_compile || die "failed to build modules"
- fi
-}
-
-src_install() {
- einfo "Installing userspace"
- emake DESTDIR="${D}" ${myconf} binaries_install || die "failed to package"
-
- if [[ $modules -eq 1 ]]; then
- einfo "Installing kernel modules"
- cd "${S}/kernel"
- export KERNELDIR="${KERNEL_DIR}"
- linux-mod_src_install
- fi
-}
diff --git a/net-firewall/ipset/ipset-2.5.0-r1.ebuild b/net-firewall/ipset/ipset-4.1.ebuild
index c444f096d71b..d2083e6ee172 100644
--- a/net-firewall/ipset/ipset-2.5.0-r1.ebuild
+++ b/net-firewall/ipset/ipset-4.1.ebuild
@@ -1,17 +1,21 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipset/ipset-2.5.0-r1.ebuild,v 1.2 2009/09/06 21:15:43 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipset/ipset-4.1.ebuild,v 1.1 2009/11/14 08:20:30 pva Exp $
+
+EAPI="2"
inherit eutils versionator toolchain-funcs linux-mod
DESCRIPTION="IPset tool for iptables, successor to ippool."
HOMEPAGE="http://ipset.netfilter.org/"
SRC_URI="http://ipset.netfilter.org/${P}.tar.bz2"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
-RDEPEND=">=net-firewall/iptables-1.4.1"
+
+RDEPEND=">=net-firewall/iptables-1.4.4"
DEPEND="${RDEPEND}"
# configurable from outside
@@ -28,19 +32,7 @@ for i in ip_set{,_{setlist,{ip,port,macip}map,{ip,net,ipport,ipportip,ipportnet}
done
# sanity
CONFIG_CHECK="NETFILTER"
-ERROR_CFG="ipset needs netfilter support in your kernel."
-
-src_unpack() {
- unpack ${A}
- sed -i \
- -e 's/KERNELDIR/(KERNELDIR)/g' \
- -e 's/^(\?KERNEL_\?DIR.*/KERNELDIR ?= /' \
- -e '/^all::/iV ?= 0' \
- -e '/^all::/iKBUILD_OUTPUT ?=' \
- -e '/$(MAKE)/{s/$@/ V=$(V) KBUILD_OUTPUT=$(KBUILD_OUTPUT) modules/}' \
- "${S}"/kernel/Makefile
-
-}
+ERROR_CFG="ipset requires netfilter support in your kernel."
pkg_setup() {
get_version
@@ -66,6 +58,16 @@ pkg_setup() {
export myconf
}
+src_prepare() {
+ sed -i \
+ -e 's/KERNELDIR/(KERNELDIR)/g' \
+ -e 's/^(\?KERNEL_\?DIR.*/KERNELDIR ?= /' \
+ -e '/^all::/iV ?= 0' \
+ -e '/^all::/iKBUILD_OUTPUT ?=' \
+ -e '/$(MAKE)/{s/$@/ V=$(V) KBUILD_OUTPUT=$(KBUILD_OUTPUT) modules/}' \
+ "${S}"/kernel/Makefile
+}
+
src_compile() {
einfo "Building userspace"
emake CC="$(tc-getCC)" COPT_FLAGS="${CFLAGS}" ${myconf} binaries || die "failed to build"