summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDominik Stadler <centic@gentoo.org>2004-05-02 15:22:09 +0000
committerDominik Stadler <centic@gentoo.org>2004-05-02 15:22:09 +0000
commit6495b20902c580f906aed5edf0da0acec1cc79c2 (patch)
tree46d57914a9bf36a61ff8b40239ca5700eab35886 /net-firewall/firehol/firehol-1.159-r1.ebuild
parentadded ipv6arpa use flag and patch to enable ipv6 arpa support (Manifest recom... (diff)
downloadgentoo-2-6495b20902c580f906aed5edf0da0acec1cc79c2.tar.gz
gentoo-2-6495b20902c580f906aed5edf0da0acec1cc79c2.tar.bz2
gentoo-2-6495b20902c580f906aed5edf0da0acec1cc79c2.zip
Fix warning messages because of 'head' and add missing IUSE.
Diffstat (limited to 'net-firewall/firehol/firehol-1.159-r1.ebuild')
-rw-r--r--net-firewall/firehol/firehol-1.159-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-firewall/firehol/firehol-1.159-r1.ebuild b/net-firewall/firehol/firehol-1.159-r1.ebuild
new file mode 100644
index 000000000000..f14984436e07
--- /dev/null
+++ b/net-firewall/firehol/firehol-1.159-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/firehol/firehol-1.159-r1.ebuild,v 1.1 2004/05/02 15:22:09 centic Exp $
+
+DESCRIPTION="iptables firewall generator"
+HOMEPAGE="http://firehol.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+KEYWORDS="~x86"
+
+RDEPEND="net-firewall/iptables
+ sys-apps/iproute2"
+
+src_compile() {
+ sed -i firehol.sh \
+ -e 's|/etc/firehol.conf|/etc/firehol/firehol.conf|' \
+ -e 's|/sbin/ip|/usr/sbin/ip|' \
+ -e 's|/usr/sbin/iptables|/sbin/iptables|' \
+ -e 's|head -1|head -n 1|'
+}
+
+src_install() {
+ newsbin firehol.sh firehol
+ dodir /etc/firehol /etc/firehol/examples
+ insinto /etc/firehol/examples
+ doins examples/*
+ dodoc ChangeLog COPYING README TODO WhatIsNew
+ dohtml doc/*.html doc/*.css
+ docinto scripts
+ dodoc get-iana.sh adblock.sh
+}
+
+pkg_postinst() {
+ einfo "The default path to firehol's configuration file is /etc/firehol/firehol.conf"
+ einfo "See /etc/firehol/examples for configuration examples."
+}