summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-08-20 11:08:19 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-08-20 11:08:19 +0000
commitefad85926d23bea79254d1ed57fcf706269eba17 (patch)
treeba32778ef331095295d5b530ce2c201eb79d58ed /net-dns
parentStable for x86, wrt bug #431956 (diff)
downloadgentoo-2-efad85926d23bea79254d1ed57fcf706269eba17.tar.gz
gentoo-2-efad85926d23bea79254d1ed57fcf706269eba17.tar.bz2
gentoo-2-efad85926d23bea79254d1ed57fcf706269eba17.zip
Version bump to 1.1_rc1. Ebuild by Ondrej Caletka.
(Portage version: 2.2.0_alpha121/cvs/Linux x86_64)
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/knot/ChangeLog7
-rw-r--r--net-dns/knot/knot-1.1.0_rc1.ebuild60
2 files changed, 66 insertions, 1 deletions
diff --git a/net-dns/knot/ChangeLog b/net-dns/knot/ChangeLog
index 8bcb179dc097..0c8540b671c2 100644
--- a/net-dns/knot/ChangeLog
+++ b/net-dns/knot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-dns/knot
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/knot/ChangeLog,v 1.10 2012/07/26 14:00:35 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/knot/ChangeLog,v 1.11 2012/08/20 11:08:19 scarabeus Exp $
+
+*knot-1.1.0_rc1 (20 Aug 2012)
+
+ 20 Aug 2012; Tomáš Chvátal <scarabeus@gentoo.org> +knot-1.1.0_rc1.ebuild:
+ Version bump to 1.1_rc1. Ebuild by Ondrej Caletka.
*knot-1.0.6-r1 (26 Jul 2012)
diff --git a/net-dns/knot/knot-1.1.0_rc1.ebuild b/net-dns/knot/knot-1.1.0_rc1.ebuild
new file mode 100644
index 000000000000..ee0c950ede16
--- /dev/null
+++ b/net-dns/knot/knot-1.1.0_rc1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/knot/knot-1.1.0_rc1.ebuild,v 1.1 2012/08/20 11:08:19 scarabeus Exp $
+
+EAPI=4
+
+inherit eutils autotools
+
+DESCRIPTION="High-performance authoritative-only DNS server"
+HOMEPAGE="http://www.knot-dns.cz/"
+SRC_URI="http://public.nic.cz/files/knot-dns/${P/_/-}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="
+ dev-libs/openssl
+ dev-libs/userspace-rcu
+"
+# sys-libs/glibc
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ sys-devel/flex
+ virtual/yacc
+"
+
+S="${WORKDIR}/${P/_/-}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-move-pidfile-to-var.patch
+ sed -i \
+ -e 's:-Werror::g' \
+ configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --sysconfdir="${EPREFIX}/etc/${PN}" \
+ --libexecdir="${EPREFIX}/usr/libexec/${PN}" \
+ --disable-lto \
+ --enable-recvmmsg \
+ $(use_enable debug debug server,zones,xfr,packet,dname,rr,ns,hash,compiler) \
+ $(use_enable debug debuglevel details)
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}/knot.init" knot-dns
+}
+
+pkg_postinst() {
+ einfo "If this is an update, remember to recompile all zones. Run:"
+ einfo " # knotc stop"
+ einfo " # knotc compile"
+ einfo " # knotc start"
+}