summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2006-04-20 13:34:36 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2006-04-20 13:34:36 +0000
commitdc3968e2b71207559696af13726b62a6a6743ec8 (patch)
treea43da321c7172d001f9ba6d4909c18544c800d99 /net-dns
parentAdd ~amd64 (bug 120375). (diff)
downloadgentoo-2-dc3968e2b71207559696af13726b62a6a6743ec8.tar.gz
gentoo-2-dc3968e2b71207559696af13726b62a6a6743ec8.tar.bz2
gentoo-2-dc3968e2b71207559696af13726b62a6a6743ec8.zip
* enew' stuff moved to pkg_setup()
(Portage version: 2.1_pre7-r5)
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/bind/ChangeLog6
-rw-r--r--net-dns/bind/bind-9.2.5-r4.ebuild9
-rw-r--r--net-dns/bind/bind-9.2.5-r6.ebuild14
-rw-r--r--net-dns/bind/bind-9.2.6.ebuild14
-rw-r--r--net-dns/bind/bind-9.3.2.ebuild12
5 files changed, 35 insertions, 20 deletions
diff --git a/net-dns/bind/ChangeLog b/net-dns/bind/ChangeLog
index 1cd296443989..85eb840d1e85 100644
--- a/net-dns/bind/ChangeLog
+++ b/net-dns/bind/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-dns/bind
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/bind/ChangeLog,v 1.109 2006/03/26 00:07:20 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/bind/ChangeLog,v 1.110 2006/04/20 13:34:36 voxus Exp $
+
+ 20 Apr 2006; Konstantin Arkhipov <voxus@gentoo.org> bind-9.2.5-r4.ebuild,
+ bind-9.2.6.ebuild, bind-9.3.2.ebuild, bind-9.2.5-r6.ebuild:
+ enew{user,group} moved to pkg_setup().
*bind-9.3.2-r1 (26 Mar 2006)
*bind-9.2.5-r1 (26 Mar 2006)
diff --git a/net-dns/bind/bind-9.2.5-r4.ebuild b/net-dns/bind/bind-9.2.5-r4.ebuild
index 03130a03c318..448466e6aa19 100644
--- a/net-dns/bind/bind-9.2.5-r4.ebuild
+++ b/net-dns/bind/bind-9.2.5-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/bind/bind-9.2.5-r4.ebuild,v 1.12 2006/02/23 18:24:15 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/bind/bind-9.2.5-r4.ebuild,v 1.13 2006/04/20 13:34:36 voxus Exp $
inherit eutils libtool
@@ -25,6 +25,13 @@ DEPEND="sys-apps/groff
RDEPEND="${DEPEND}
selinux? ( sec-policy/selinux-bind )"
+pkg_setup() {
+ ebegin "Creating named group and user"
+ enewgroup named 40
+ enewuser named 40 -1 /etc/bind named
+ eend ${?}
+}
+
src_unpack() {
use threads && {
echo
diff --git a/net-dns/bind/bind-9.2.5-r6.ebuild b/net-dns/bind/bind-9.2.5-r6.ebuild
index 526185d8cd70..bb8a662e0ca6 100644
--- a/net-dns/bind/bind-9.2.5-r6.ebuild
+++ b/net-dns/bind/bind-9.2.5-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/bind/bind-9.2.5-r6.ebuild,v 1.10 2006/02/23 18:24:15 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/bind/bind-9.2.5-r6.ebuild,v 1.11 2006/04/20 13:34:36 voxus Exp $
inherit eutils libtool
@@ -25,6 +25,13 @@ DEPEND="sys-apps/groff
RDEPEND="${DEPEND}
selinux? ( sec-policy/selinux-bind )"
+pkg_setup() {
+ ebegin "Creating named group and user"
+ enewgroup named 40
+ enewuser named 40 -1 /etc/bind named
+ eend ${?}
+}
+
src_unpack() {
use threads && {
echo
@@ -179,11 +186,6 @@ src_install() {
# Let's get rid of those tools and their manpages since they're provided by bind-tools
rm -f ${D}/usr/share/man/man1/{dig.1,host.1,nslookup.1}
rm -f ${D}/usr/bin/{dig,host,nslookup}
-
- ebegin "Creating named group and user"
- enewgroup named 40
- enewuser named 40 -1 /etc/bind named
- eend ${?}
}
pkg_postinst() {
diff --git a/net-dns/bind/bind-9.2.6.ebuild b/net-dns/bind/bind-9.2.6.ebuild
index 5848e24fc1aa..b3cd94a57f9e 100644
--- a/net-dns/bind/bind-9.2.6.ebuild
+++ b/net-dns/bind/bind-9.2.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/bind/bind-9.2.6.ebuild,v 1.9 2006/02/23 18:24:15 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/bind/bind-9.2.6.ebuild,v 1.10 2006/04/20 13:34:36 voxus Exp $
inherit eutils libtool
@@ -27,6 +27,13 @@ DEPEND="sys-apps/groff
RDEPEND="${DEPEND}
selinux? ( sec-policy/selinux-bind )"
+pkg_setup() {
+ ebegin "Creating named group and user"
+ enewgroup named 40
+ enewuser named 40 -1 /etc/bind named
+ eend ${?}
+}
+
src_unpack() {
use threads && {
echo
@@ -192,11 +199,6 @@ src_install() {
# Let's get rid of those tools and their manpages since they're provided by bind-tools
rm -f ${D}/usr/share/man/man1/{dig.1,host.1,nslookup.1}
rm -f ${D}/usr/bin/{dig,host,nslookup}
-
- ebegin "Creating named group and user"
- enewgroup named 40
- enewuser named 40 -1 /etc/bind named
- eend ${?}
}
pkg_postinst() {
diff --git a/net-dns/bind/bind-9.3.2.ebuild b/net-dns/bind/bind-9.3.2.ebuild
index 745500c943e7..abb9ff0f7624 100644
--- a/net-dns/bind/bind-9.3.2.ebuild
+++ b/net-dns/bind/bind-9.3.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/bind/bind-9.3.2.ebuild,v 1.9 2006/02/23 18:24:15 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/bind/bind-9.3.2.ebuild,v 1.10 2006/04/20 13:34:36 voxus Exp $
inherit eutils libtool
@@ -35,6 +35,11 @@ pkg_setup() {
ewarn "disable threads support because of linux capabilities dependency"
echo
}
+
+ ebegin "Creating named group and user"
+ enewgroup named 40
+ enewuser named 40 -1 /etc/bind named
+ eend ${?}
}
src_unpack() {
@@ -188,11 +193,6 @@ src_install() {
# Let's get rid of those tools and their manpages since they're provided by bind-tools
rm -f ${D}/usr/share/man/man1/{dig.1,host.1,nslookup.1}
rm -f ${D}/usr/bin/{dig,host,nslookup}
-
- ebegin "Creating named group and user"
- enewgroup named 40
- enewuser named 40 -1 /etc/bind named
- eend ${?}
}
pkg_postinst() {