summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-08-06 13:39:15 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-08-06 13:39:15 +0000
commitd07475d43d4faff959a6165cb91238a9e9c3b3f4 (patch)
treea605f0fdaa1bf2feda6d99dcbcd4baa01bbca9a3 /net-dns
parentQA (diff)
downloadgentoo-2-d07475d43d4faff959a6165cb91238a9e9c3b3f4.tar.gz
gentoo-2-d07475d43d4faff959a6165cb91238a9e9c3b3f4.tar.bz2
gentoo-2-d07475d43d4faff959a6165cb91238a9e9c3b3f4.zip
Repect LDFLAGS + QA fixes from Doktor Notor <notordoktor@gmail.com>. Bug #309153
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/host/ChangeLog11
-rw-r--r--net-dns/host/files/host-20070128-Makefile.patch62
-rw-r--r--net-dns/host/host-20070128-r1.ebuild42
3 files changed, 113 insertions, 2 deletions
diff --git a/net-dns/host/ChangeLog b/net-dns/host/ChangeLog
index 668099245cf1..8fc51b56255f 100644
--- a/net-dns/host/ChangeLog
+++ b/net-dns/host/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-dns/host
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/host/ChangeLog,v 1.10 2009/09/23 18:29:05 patrick Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/host/ChangeLog,v 1.11 2010/08/06 13:39:15 hwoarang Exp $
+
+*host-20070128-r1 (06 Aug 2010)
+
+ 06 Aug 2010; Markos Chandras <hwoarang@gentoo.org>
+ +host-20070128-r1.ebuild, +files/host-20070128-Makefile.patch:
+ Repect LDFLAGS + QA fixes from Doktor Notor <notordoktor@gmail.com>. Bug
+ #309153
23 Sep 2009; Patrick Lauer <patrick@gentoo.org> host-20070128.ebuild:
Remove virtual/libc
diff --git a/net-dns/host/files/host-20070128-Makefile.patch b/net-dns/host/files/host-20070128-Makefile.patch
new file mode 100644
index 000000000000..931c4389db1d
--- /dev/null
+++ b/net-dns/host/files/host-20070128-Makefile.patch
@@ -0,0 +1,62 @@
+--- Makefile.orig 2003-06-05 03:01:45.000000000 +0200
++++ Makefile 2010-03-12 18:53:17.000000000 +0100
+@@ -117,16 +117,11 @@
+ # Compilation definitions.
+ # ----------------------------------------------------------------------
+
+-DEBUGDEFS = -DDEBUG
+
+ DEFS = $(CONFIGDEFS) $(DEBUGDEFS) $(SYSDEFS) $(INCLUDES)
+
+-COPTS = -pipe
+
+-COPTIM = -O2
+-COPTIM = -O
+
+-CDEBUG = -g
+
+ # GCC lint-like warnings -- any warnings are likely bugs in the
+ # platform headers or in gcc itself....
+@@ -139,7 +134,6 @@
+ -Wswitch \
+ -Wcomment \
+ -Wcast-qual \
+- -Wid-clash-30 \
+ -Wpointer-arith \
+ -Wshadow
+ #endif
+@@ -147,7 +141,6 @@
+ #if $(__GNULD__) >= 1
+ GNULDWARNFLAGS = -W \
+ -Wall \
+- -Wid-clash-30
+ #endif
+
+ #if $(__GNUC__) >= 2
+@@ -169,7 +162,7 @@
+ #endif
+
+ CPPFLAGS = $(DEFS)
+-CFLAGS = $(COPTS) $(CDEBUG) $(COPTIM) $(GCCWARNFLAGS) $(GCC2WARNFLAGS) $(GCC3WARNFLAGS)
++CFLAGS += $(GCCWARNFLAGS) $(GCC2WARNFLAGS) $(GCC3WARNFLAGS)
+
+ # Select your favorite compiler if make doesn't already know it...
+ #if defined(next)
+@@ -250,7 +243,7 @@
+ # Unfortunately SunOS-5.9 has only libresolv.so !!!
+ #
+ #if defined(NEED_LIBRESOLV) && !defined(sunos5.x) && !(BIND-8.4.x)
+-LDFLAGS = -static $(GNULDWARNFLAGS)
++LDFLAGS += $(GNULDWARNFLAGS)
+ #else
+ #LDFLAGS = $(GNULDWARNFLAGS)
+ #endif
+@@ -294,7 +287,7 @@
+ # ----------------------------------------------------------------------
+
+ BINOWN = root
+-BINGRP = staff
++BINGRP = root
+ BINMODE = 755
+ #STRIPFLAG = -s
+
diff --git a/net-dns/host/host-20070128-r1.ebuild b/net-dns/host/host-20070128-r1.ebuild
new file mode 100644
index 000000000000..521c47e9799e
--- /dev/null
+++ b/net-dns/host/host-20070128-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/host/host-20070128-r1.ebuild,v 1.1 2010/08/06 13:39:15 hwoarang Exp $
+
+EAPI="2"
+inherit eutils toolchain-funcs multilib
+
+DESCRIPTION="A powerful command-line DNS query and test tool implementing many additional protocols"
+HOMEPAGE="http://www.weird.com/~woods/projects/host.html"
+SRC_URI="ftp://ftp.weird.com/pub/local/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="debug"
+
+# Bug 91515
+RESTRICT="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-Makefile.patch"
+ sed -i -e "s:^\(# if defined(__alpha).*\):\1 || defined(__x86_64__):" \
+ port.h || die "sed failed"
+}
+
+src_compile() {
+ use debug && export DEBUGDEFS="-DDEBUG"
+ emake CC="$(tc-getCC)" RES_LIB=/usr/$(get_libdir)/libresolv.a || die "emake failed"
+}
+
+src_install () {
+ # This tool has slightly different format of output from "standard" host.
+ # Renaming it to host-woods, hopefully this does not conflict with anything.
+
+ newbin host host-woods || die "newbin failed"
+ newman host.1 host-woods.1 || die "newman failed"
+ dodoc RELEASE_NOTES ToDo || die "dodoc failed"
+}