summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2011-07-03 01:28:00 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2011-07-03 01:28:00 +0000
commitbc001d23373de3c31832c818424209507b548973 (patch)
treea0cae8ad41f82f2c9e497e1132cefb99b2cd4692 /net-dns
parentMoved patchbundles out of , bug #370927 (diff)
downloadgentoo-2-bc001d23373de3c31832c818424209507b548973.tar.gz
gentoo-2-bc001d23373de3c31832c818424209507b548973.tar.bz2
gentoo-2-bc001d23373de3c31832c818424209507b548973.zip
Version bumped. Fixed GNU stack issue. Added SUPPORT_PYTHON_ABIS="1".
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/unbound/ChangeLog9
-rw-r--r--net-dns/unbound/unbound-1.4.11.ebuild (renamed from net-dns/unbound/unbound-1.4.9.ebuild)14
-rw-r--r--net-dns/unbound/unbound-1.4.8.ebuild83
3 files changed, 18 insertions, 88 deletions
diff --git a/net-dns/unbound/ChangeLog b/net-dns/unbound/ChangeLog
index e8398a975c43..23df5426b5f4 100644
--- a/net-dns/unbound/ChangeLog
+++ b/net-dns/unbound/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-dns/unbound
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/unbound/ChangeLog,v 1.26 2011/05/31 13:31:03 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/unbound/ChangeLog,v 1.27 2011/07/03 01:28:00 matsuu Exp $
+
+*unbound-1.4.11 (03 Jul 2011)
+
+ 03 Jul 2011; MATSUU Takuto <matsuu@gentoo.org> -unbound-1.4.8.ebuild,
+ -unbound-1.4.9.ebuild, +unbound-1.4.11.ebuild:
+ Version bumped. Fixed GNU stack issue. Added SUPPORT_PYTHON_ABIS="1". Removed
+ old versions.
31 May 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> unbound-1.4.10.ebuild:
x86 stable wrt security bug #368981
diff --git a/net-dns/unbound/unbound-1.4.9.ebuild b/net-dns/unbound/unbound-1.4.11.ebuild
index 9ed6137753c1..3797c3328b80 100644
--- a/net-dns/unbound/unbound-1.4.9.ebuild
+++ b/net-dns/unbound/unbound-1.4.11.ebuild
@@ -1,10 +1,13 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/unbound/unbound-1.4.9.ebuild,v 1.1 2011/04/11 15:01:36 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/unbound/unbound-1.4.11.ebuild,v 1.1 2011/07/03 01:28:00 matsuu Exp $
EAPI="3"
PYTHON_DEPEND="python? 2"
-inherit eutils python
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit eutils flag-o-matic python
DESCRIPTION="A validating, recursive and caching DNS resolver"
HOMEPAGE="http://unbound.net/"
@@ -33,12 +36,12 @@ RDEPEND="${RDEPEND}
net-dns/dnssec-root"
pkg_setup() {
- python_set_active_version 2
enewgroup unbound
enewuser unbound -1 -1 /etc/unbound unbound
}
src_configure() {
+ append-ldflags -Wl,-z,noexecstack || die
econf \
--with-pidfile="${EPREFIX}"/var/run/unbound.pid \
--with-ldns="${EPREFIX}"/usr \
@@ -64,7 +67,10 @@ src_install() {
# bug #299016
if use python ; then
- find "${ED}$(python_get_sitedir)" "(" -name "*.a" -o -name "*.la" ")" -type f -delete || die
+ find "${ED}" -name '_unbound.{la,a}' -delete || die
+ fi
+ if ! use static-libs ; then
+ find "${ED}" -name "*.la" -type f -delete || die
fi
newinitd "${FILESDIR}/unbound.initd" unbound || die "newinitd failed"
diff --git a/net-dns/unbound/unbound-1.4.8.ebuild b/net-dns/unbound/unbound-1.4.8.ebuild
deleted file mode 100644
index 0d6864b7c76e..000000000000
--- a/net-dns/unbound/unbound-1.4.8.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/unbound/unbound-1.4.8.ebuild,v 1.3 2011/05/11 19:37:25 angelos Exp $
-
-EAPI="3"
-PYTHON_DEPEND="python? 2"
-inherit eutils python
-
-DESCRIPTION="A validating, recursive and caching DNS resolver"
-HOMEPAGE="http://unbound.net/"
-SRC_URI="http://unbound.net/downloads/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86 ~x64-macos"
-IUSE="debug gost python static-libs test threads"
-
-RDEPEND="dev-libs/expat
- dev-libs/libevent
- >=dev-libs/openssl-0.9.8
- >=net-libs/ldns-1.6.5[ssl,gost?]"
-
-DEPEND="${RDEPEND}
- python? ( dev-lang/swig )
- test? (
- net-dns/ldns-utils[examples]
- dev-util/splint
- app-text/wdiff
- )"
-
-# bug #347415
-RDEPEND="${RDEPEND}
- net-dns/dnssec-root"
-
-pkg_setup() {
- python_set_active_version 2
- enewgroup unbound
- enewuser unbound -1 -1 /etc/unbound unbound
-}
-
-src_configure() {
- econf \
- --with-pidfile="${EPREFIX}"/var/run/unbound.pid \
- --with-ldns="${EPREFIX}"/usr \
- --with-libevent="${EPREFIX}"/usr \
- --with-rootkey-file="${EPREFIX}"/etc/dnssec/root-anchors.txt \
- $(use_enable debug) \
- $(use_enable debug lock-checks) \
- $(use_enable debug alloc-checks) \
- $(use_enable debug alloc-lite) \
- $(use_enable debug alloc-nonregional) \
- $(use_enable gost) \
- $(use_enable static-libs static) \
- $(use_with threads pthreads) \
- $(use_with python pyunbound) \
- $(use_with python pythonmodule) \
- --disable-rpath || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- # bug #299016
- if use python ; then
- find "${ED}$(python_get_sitedir)" "(" -name "*.a" -o -name "*.la" ")" -type f -delete || die
- fi
-
- newinitd "${FILESDIR}/unbound.initd" unbound || die "newinitd failed"
- newconfd "${FILESDIR}/unbound.confd" unbound || die "newconfd failed"
-
- dodoc doc/{README,CREDITS,TODO,Changelog,FEATURES} || die "dodoc failed"
-
- # bug #315519
- #exeinto /usr/libexec/munin/plugins
- #doexe contrib/unbound_munin_ || die "doexe failed"
- dodoc contrib/unbound_munin_ || die "dodoc failed"
-
- docinto selinux
- dodoc contrib/selinux/* || die "dodoc failed"
-
- exeinto /usr/share/${PN}
- doexe contrib/update-anchor.sh || die "doexe failed"
-}