summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2012-08-28 17:11:42 +0000
committerPatrick McLean <chutzpah@gentoo.org>2012-08-28 17:11:42 +0000
commitac56760fa61a7da7b982f729fd17cceb051a1e8a (patch)
tree82971e5aba2367fc7ac5c2be472155a0fd2ceb5b /net-dns
parentFix COMMON_RDEPEND typo for bug #432794. (diff)
downloadgentoo-2-ac56760fa61a7da7b982f729fd17cceb051a1e8a.tar.gz
gentoo-2-ac56760fa61a7da7b982f729fd17cceb051a1e8a.tar.bz2
gentoo-2-ac56760fa61a7da7b982f729fd17cceb051a1e8a.zip
Version bump (bug #431836). Add installation of a systemd unit (bug # 371871). Make sure LDFLAGS are respected (bug #414223). Clean up some older versions.
(Portage version: 2.1.11.10/cvs/Linux x86_64)
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/dnsmasq/ChangeLog12
-rw-r--r--net-dns/dnsmasq/dnsmasq-2.57-r1.ebuild80
-rw-r--r--net-dns/dnsmasq/dnsmasq-2.59.ebuild82
-rw-r--r--net-dns/dnsmasq/dnsmasq-2.61.ebuild3
-rw-r--r--net-dns/dnsmasq/dnsmasq-2.63.ebuild (renamed from net-dns/dnsmasq/dnsmasq-2.60.ebuild)11
-rw-r--r--net-dns/dnsmasq/files/dnsmasq-fbsd-config.patch15
-rw-r--r--net-dns/dnsmasq/files/dnsmasq-init-r135
-rw-r--r--net-dns/dnsmasq/files/dnsmasq.service11
8 files changed, 31 insertions, 218 deletions
diff --git a/net-dns/dnsmasq/ChangeLog b/net-dns/dnsmasq/ChangeLog
index 0a0d16ab9343..e98e85b215b5 100644
--- a/net-dns/dnsmasq/ChangeLog
+++ b/net-dns/dnsmasq/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for net-dns/dnsmasq
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/dnsmasq/ChangeLog,v 1.215 2012/06/14 02:08:14 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/dnsmasq/ChangeLog,v 1.216 2012/08/28 17:11:42 chutzpah Exp $
+
+*dnsmasq-2.63 (28 Aug 2012)
+
+ 28 Aug 2012; Patrick McLean <chutzpah@gentoo.org> -dnsmasq-2.57-r1.ebuild,
+ -dnsmasq-2.59.ebuild, -dnsmasq-2.60.ebuild, dnsmasq-2.61.ebuild,
+ +dnsmasq-2.63.ebuild, +files/dnsmasq.service,
+ -files/dnsmasq-fbsd-config.patch, -files/dnsmasq-init-r1:
+ Version bump (bug #431836). Add installation of a systemd unit (bug #
+ 371871). Make sure LDFLAGS are respected (bug #414223). Clean up some older
+ versions.
14 Jun 2012; Zac Medico <zmedico@gentoo.org> dnsmasq-2.57-r1.ebuild,
dnsmasq-2.59.ebuild, dnsmasq-2.60.ebuild, dnsmasq-2.61.ebuild:
diff --git a/net-dns/dnsmasq/dnsmasq-2.57-r1.ebuild b/net-dns/dnsmasq/dnsmasq-2.57-r1.ebuild
deleted file mode 100644
index 1ca8bda2b16b..000000000000
--- a/net-dns/dnsmasq/dnsmasq-2.57-r1.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/dnsmasq/dnsmasq-2.57-r1.ebuild,v 1.5 2012/06/14 02:08:14 zmedico Exp $
-
-EAPI=4
-
-inherit eutils toolchain-funcs flag-o-matic user
-
-MY_P="${P/_/}"
-MY_PV="${PV/_/}"
-DESCRIPTION="Small forwarding DNS server"
-HOMEPAGE="http://www.thekelleys.org.uk/dnsmasq/"
-SRC_URI="http://www.thekelleys.org.uk/dnsmasq/${MY_P}.tar.lzma"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="dbus +dhcp idn ipv6 nls tftp"
-
-RDEPEND="dbus? ( sys-apps/dbus )
- idn? ( net-dns/libidn )
- nls? (
- sys-devel/gettext
- net-dns/libidn
- )"
-
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- || ( app-arch/xz-utils app-arch/lzma )"
-
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-pkg_setup() {
- enewgroup dnsmasq
- enewuser dnsmasq -1 -1 /dev/null dnsmasq
-}
-
-src_prepare() {
- # dnsmasq on FreeBSD wants the config file in a silly location, this fixes
- epatch "${FILESDIR}/${PN}-2.47-fbsd-config.patch"
-}
-
-src_configure() {
- COPTS=""
- use tftp || COPTS+=" -DNO_TFTP"
- use dhcp || COPTS+=" -DNO_DHCP"
- use ipv6 || COPTS+=" -DNO_IPV6"
- use dbus && COPTS+=" -DHAVE_DBUS"
- use idn && COPTS+=" -DHAVE_IDN"
-}
-
-src_compile() {
- emake \
- PREFIX=/usr \
- CC="$(tc-getCC)" \
- CFLAGS="${CFLAGS}" \
- COPTS="${COPTS}" \
- all$(use nls && echo "-i18n")
-}
-
-src_install() {
- emake \
- PREFIX=/usr \
- MANDIR=/usr/share/man \
- DESTDIR="${D}" \
- install$(use nls && echo "-i18n")
-
- dodoc CHANGELOG FAQ
- dohtml *.html
-
- newinitd "${FILESDIR}"/dnsmasq-init dnsmasq
- newconfd "${FILESDIR}"/dnsmasq.confd-r1 dnsmasq
- insinto /etc
- newins dnsmasq.conf.example dnsmasq.conf
-
- if use dbus ; then
- insinto /etc/dbus-1/system.d
- doins dbus/dnsmasq.conf
- fi
-}
diff --git a/net-dns/dnsmasq/dnsmasq-2.59.ebuild b/net-dns/dnsmasq/dnsmasq-2.59.ebuild
deleted file mode 100644
index 983fa5e86446..000000000000
--- a/net-dns/dnsmasq/dnsmasq-2.59.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/dnsmasq/dnsmasq-2.59.ebuild,v 1.4 2012/06/14 02:08:14 zmedico Exp $
-
-EAPI=4
-
-inherit eutils toolchain-funcs flag-o-matic user
-
-MY_P="${P/_/}"
-MY_PV="${PV/_/}"
-DESCRIPTION="Small forwarding DNS server"
-HOMEPAGE="http://www.thekelleys.org.uk/dnsmasq/"
-SRC_URI="http://www.thekelleys.org.uk/dnsmasq/${MY_P}.tar.lzma"
-
-LICENSE="|| ( GPL-2 GPL-3 )"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="conntrack dbus +dhcp idn ipv6 nls tftp"
-
-RDEPEND="dbus? ( sys-apps/dbus )
- idn? ( net-dns/libidn )
- conntrack? ( net-libs/libnetfilter_conntrack )
- nls? (
- sys-devel/gettext
- net-dns/libidn
- )"
-
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- || ( app-arch/xz-utils app-arch/lzma )"
-
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-pkg_setup() {
- enewgroup dnsmasq
- enewuser dnsmasq -1 -1 /dev/null dnsmasq
-}
-
-src_prepare() {
- # dnsmasq on FreeBSD wants the config file in a silly location, this fixes
- epatch "${FILESDIR}/${PN}-2.47-fbsd-config.patch"
-}
-
-src_configure() {
- COPTS=""
- use conntrack && COPTS+=" -DHAVE_CONNTRACK"
- use tftp || COPTS+=" -DNO_TFTP"
- use dhcp || COPTS+=" -DNO_DHCP"
- use ipv6 || COPTS+=" -DNO_IPV6"
- use dbus && COPTS+=" -DHAVE_DBUS"
- use idn && COPTS+=" -DHAVE_IDN"
-}
-
-src_compile() {
- emake \
- PREFIX=/usr \
- CC="$(tc-getCC)" \
- CFLAGS="${CFLAGS}" \
- COPTS="${COPTS}" \
- all$(use nls && echo "-i18n")
-}
-
-src_install() {
- emake \
- PREFIX=/usr \
- MANDIR=/usr/share/man \
- DESTDIR="${D}" \
- install$(use nls && echo "-i18n")
-
- dodoc CHANGELOG FAQ
- dohtml *.html
-
- newinitd "${FILESDIR}"/dnsmasq-init-r1 dnsmasq
- newconfd "${FILESDIR}"/dnsmasq.confd-r1 dnsmasq
- insinto /etc
- newins dnsmasq.conf.example dnsmasq.conf
-
- if use dbus ; then
- insinto /etc/dbus-1/system.d
- doins dbus/dnsmasq.conf
- fi
-}
diff --git a/net-dns/dnsmasq/dnsmasq-2.61.ebuild b/net-dns/dnsmasq/dnsmasq-2.61.ebuild
index 22031aad63a9..654eb7efc8ac 100644
--- a/net-dns/dnsmasq/dnsmasq-2.61.ebuild
+++ b/net-dns/dnsmasq/dnsmasq-2.61.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/dnsmasq/dnsmasq-2.61.ebuild,v 1.3 2012/06/14 02:08:14 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/dnsmasq/dnsmasq-2.61.ebuild,v 1.4 2012/08/28 17:11:42 chutzpah Exp $
EAPI=4
@@ -79,6 +79,7 @@ src_compile() {
PREFIX=/usr \
CC="$(tc-getCC)" \
CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
COPTS="${COPTS}" \
all$(use nls && echo "-i18n")
}
diff --git a/net-dns/dnsmasq/dnsmasq-2.60.ebuild b/net-dns/dnsmasq/dnsmasq-2.63.ebuild
index 58231b7f4491..7aa33846de98 100644
--- a/net-dns/dnsmasq/dnsmasq-2.60.ebuild
+++ b/net-dns/dnsmasq/dnsmasq-2.63.ebuild
@@ -1,16 +1,16 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/dnsmasq/dnsmasq-2.60.ebuild,v 1.3 2012/06/14 02:08:14 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/dnsmasq/dnsmasq-2.63.ebuild,v 1.1 2012/08/28 17:11:42 chutzpah Exp $
EAPI=4
-inherit eutils toolchain-funcs flag-o-matic user
+inherit eutils toolchain-funcs flag-o-matic user systemd
MY_P="${P/_/}"
MY_PV="${PV/_/}"
DESCRIPTION="Small forwarding DNS server"
HOMEPAGE="http://www.thekelleys.org.uk/dnsmasq/"
-SRC_URI="http://www.thekelleys.org.uk/dnsmasq/${MY_P}.tar.lzma"
+SRC_URI="http://www.thekelleys.org.uk/dnsmasq/${MY_P}.tar.xz"
LICENSE="|| ( GPL-2 GPL-3 )"
SLOT="0"
@@ -28,7 +28,7 @@ RDEPEND="dbus? ( sys-apps/dbus )
DEPEND="${RDEPEND}
virtual/pkgconfig
- || ( app-arch/xz-utils app-arch/lzma )"
+ app-arch/xz-utils"
S="${WORKDIR}/${PN}-${MY_PV}"
@@ -79,6 +79,7 @@ src_compile() {
PREFIX=/usr \
CC="$(tc-getCC)" \
CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
COPTS="${COPTS}" \
all$(use nls && echo "-i18n")
}
@@ -106,4 +107,6 @@ src_install() {
insinto /etc/dbus-1/system.d
doins dbus/dnsmasq.conf
fi
+
+ systemd_dounit "${FILESDIR}"/dnsmasq.service
}
diff --git a/net-dns/dnsmasq/files/dnsmasq-fbsd-config.patch b/net-dns/dnsmasq/files/dnsmasq-fbsd-config.patch
deleted file mode 100644
index 168c8ac80280..000000000000
--- a/net-dns/dnsmasq/files/dnsmasq-fbsd-config.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- src/config.h.orig 2006-09-12 14:24:54 +0000
-+++ src/config.h 2006-09-12 14:25:23 +0000
-@@ -39,11 +39,7 @@
- #else
- # define LEASEFILE "/var/lib/misc/dnsmasq.leases"
- #endif
--#if defined(__FreeBSD__)
--# define CONFFILE "/usr/local/etc/dnsmasq.conf"
--#else
--# define CONFFILE "/etc/dnsmasq.conf"
--#endif
-+#define CONFFILE "/etc/dnsmasq.conf"
- #define DEFLEASE 3600 /* default lease time, 1 hour */
- #define CHUSER "nobody"
- #define CHGRP "dip"
diff --git a/net-dns/dnsmasq/files/dnsmasq-init-r1 b/net-dns/dnsmasq/files/dnsmasq-init-r1
deleted file mode 100644
index 52e21ba94929..000000000000
--- a/net-dns/dnsmasq/files/dnsmasq-init-r1
+++ /dev/null
@@ -1,35 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/net-dns/dnsmasq/files/dnsmasq-init-r1,v 1.2 2011/12/04 10:28:47 swegener Exp $
-
-extra_started_commands="reload"
-
-depend() {
- provide dns
- need localmount net
- after bootmisc
- use logger
-}
-
-start() {
- ebegin "Starting ${SVCNAME}"
- start-stop-daemon --start --exec /usr/sbin/dnsmasq \
- --pidfile /var/run/dnsmasq.pid \
- -- -x /var/run/dnsmasq.pid ${DNSMASQ_OPTS}
- eend $?
-}
-
-stop() {
- ebegin "Stopping ${SVCNAME}"
- start-stop-daemon --stop --exec /usr/sbin/dnsmasq \
- --pidfile /var/run/dnsmasq.pid
- eend $?
-}
-
-reload() {
- ebegin "Reloading ${SVCNAME}"
- start-stop-daemon --stop --oknodo --signal HUP \
- --exec /usr/sbin/dnsmasq --pidfile /var/run/dnsmasq.pid
- eend $?
-}
diff --git a/net-dns/dnsmasq/files/dnsmasq.service b/net-dns/dnsmasq/files/dnsmasq.service
new file mode 100644
index 000000000000..3f71839ab883
--- /dev/null
+++ b/net-dns/dnsmasq/files/dnsmasq.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=A lightweight DHCP and caching DNS server
+
+[Service]
+Type=simple
+ExecStartPre=/usr/sbin/dnsmasq --test
+ExecStart=/usr/sbin/dnsmasq -k
+ExecReload=/bin/kill -HUP $MAINPID
+
+[Install]
+WantedBy=multi-user.target